Echo Devices (Alexa) as Media Player - Testers Needed

alexa
Tags: #<Tag:0x00007f1b97fa6ef0>

#1206

I get this when trying to call the tts service, when I originally added the media player component and restarted I didn’t get the persistent card, but all the media players were in my front end.

http://192.168.1.81:8123/frontend_latest/app-c039924c.js:1213:26645 SecurityError: Blocked a frame with origin "http://192.168.1.81:8123" from accessing a cross-origin frame. Protocols, domains, and ports must match.

I’m wondering if this is related to ssl, as I don’t expose my instance outside my network as I have no need currently?

any pointers guys?

should probably add i’m running home assistant in a docker container on ubuntu server

Scott


#1207

I don’t expose my HA instance to the outside (except thru the HA Cloud) and mine is working fine using HA (not Hassio) in a Debian Docker container.


#1208

setup was really easy for me! how would i get this on my lovelace screen?

      - type: entity
        title: Living Room Alexa
        entity: media_player.living_room

Doesn’t seem to be working


#1209

Have you tried the Media Control Card?

- type: media-control
  entity: media_player.living_room

#1210

Has anyone tried this on the new dots in the UK.
Im sure i saw someone mention its not working on the new ones, but i cant seem to find the post.


#1211

I’m curious if the Gen 3 dots work in the US? I’d think so but want to verify. Today Amazon has a 3 pack of the Gen 3 Dots for $70. Not a bad price. Might replace some of my Gen 1 echos. But want to make sure they’ll work


#1212

ok I have the assistant cloud working, but my subscription has lapsed, I’m guessing this is not a requirement though?

I’ve only briefly tested it so will dig a little deeper over the weekend.


#1213

cloud shouldn’t have an affect on setting up echo devices, this is all local, only cloud: (in config.yaml) has an affect on the subscription


#1214

I think the error was related to me calling the service from within an organizr window, opening homeassistant directly in the browser (safari) and calling the service results in no errors, unfortunately still no response from the echo, so clearly other issues elsewhere.

this is in the logs

ERROR (SyncWorker_6) [custom_components.media_player.alexa] An error occured accessing the API: An exception of type JSONDecodeError occurred. Arguments: ('Expecting value: line 1 column 1 (char 0)',)

not sure if its an error in the Alexa.py file (downloaded from GitHub and pasted the media_player folder into the custom components folder) or something else?


#1215

seems to that or something went wrong with your first login or with any of your devicenames.
could it be that you got strange characters in it? (or password or mail)
and with strange i mean like ü or é or something simular?

i also dont know if gen 3 gives up new problems in germany.
but with the prices from this moment i am willing to try.
allthough overhere they are no where near as cheap. 30 euro for 1 (about 35 dollar)
still i bought 5 gen 3 (and to make sure it will work also 2 gen 2, because they are only 25 euro :wink: )


#1216

Updated to the latest OS and this has stopped working for me. I’ve also removed the legacy API feature. Anyone else having issues?


#1217

Thanks fo the info on the alexa_media.pickle.
Deleted and now working :slight_smile:


#1218

it works
just user amazon.co.uk

you may need to delete the hidden pickle file


#1219

Yep,
definitely works on the uk gen 3 dot.
Just set it up and home assistant found it straight away.

Significantly better sound on it too.


#1220

I’m having difficulty interacting with my alexa devices. I can SEE them and they update with what’s being played etc, but changing volume, trying to use tts and pressing pause/play does absolutely nothing (apart from at the bottom it says service called).

My config.yaml has:

  • platform: alexa
    email: “myemail”
    password: “mypassword”
    url: “amazon.co.uk

Any ideas where I’m going wrong? I’m running hassio 0.81.2 and the py file I downloaded looks to be V 0.9.5


#1221

Great, works for me.

Only with the devices, the messages are very quiet, even if I have set in the Alexa APP full volume.

If the device plays music, then I can almost not hear the messages.

Is there a way to increase the volume only for the messages and to make the music quieter or to pause during the announcement?

- id: gartenon
  alias: Gartenbrunnen einschalten
  trigger:
  - platform: sun
    event: sunrise
    offset: 00:60:00
  condition:
    condition: state
    entity_id: input_boolean.garten_ckeckbox
    state: 'on'
  action:
  - service: mqtt.publish
    data:
      topic: cmnd/Gartenbrunnen/POWER
      payload: 'ON'
  - service: media_player.alexa_tts
    data:
      entity_id: media_player.esszimmer
      ??? pause...
      ??? set Alexa_tts volume
      message: "Hausmeister meldet: Gartenbrunnen  wurde eingeschaltet "
      ??? continue

#1222

but you can create a skill and start that skill with the tts service. something we cant do.
and the skill can speak the response.

After reading this I made a (private) skill to replicate Simon says but unfortunately it doesn’t work. I mean, the skill itself works flawlessly (I use it to ask stats and other infos to HA instance) but trying to make Alexa speaking custom text is not working.
If I send “chiedi a Tom ripeti messaggio testo da ripetere” (in english: “tell Tom repeat message text to repeat”) to media player it returns error message sound (If I try same message from aws testing skills page it works)…so I think we have to wait something from Amazon to have a TTS in Italian :roll_eyes:


#1223

what if you say that message to alexa?
is it the skill that errors out or the TTS service?
what do you see in the alexa history?


#1224

what if you say that message to alexa?

It works without problems

is it the skill that errors out or the TTS service?

I think is something related to API call. If I say that message to Alexa it works so skill is not the problem and TTS service works as expected because if I send (from services in HA panel) something that can be treated as a command like “notizie” (“news” in english) Alexa starts speaking with the today news or if I send “meteo” (“weather” in english) Alexa starts weather news so TTS works too.

what do you see in the alexa history?

Well…nothing…I mean, in Alexa history I see only working command (like “meteo” or “notizie”) but no history entry of my skill calls from TTS service.
I tried same commands with this script with same results.


#1225

thats to bad.
i expected that if the send command was interpreted as something you say it would also pickup starting skills.

not that its very usefull for me, because i dont speak italian :wink: