Echo Devices (Alexa) as Media Player - Testers Needed

alexa
Tags: #<Tag:0x00007f1b981753a8>

#1246

ok thanks for letting me know


#1247

I did wonder if it would be possible to create a ‘passthrough’ dummy tts component which then made a call through to the alexa service exposed by this component? Do you think in principal that would be possible?


#1248

Getting closer - I can see what’s playing in media_players, play pause and set volume. However TTS is still silent, the music keeps playing if there is some and no ducking to talk. Anyone know how to debug?


#1249

@ReneTode as promised I tried changing skill’s invocation name from Tom to Simon but unfortunately nothing changed: sending command from TTS service ends with error sound, same as calling it Tom :sweat:


#1250

the component calls google tts, so i dont think that would work.
what is possible is to use an input_text and then an automation that sends it to the service.

@phillprice does the alexa history show anything?
is the alexa device connected to the same account?
is the account that uses the alexa device the same?
what alexa server are you on?

@Nerkyator to bad, it was woth a try. dos anything come to the skill?
can you say “simon says something” to alexa and get a reaction from your skill?


#1251

I have to say “Alexa, ask Simon simon says something” (in Italian of course) so I don’t think it will work, but I’ll try when at home and I’ll let you know!


#1252

i think it would work if you say “alexa start simon” and then use TTS. :wink:
but you always need to start your skill before you can use it i guess.
i hoped that simon says would automaticly trigger your skill.


#1253

This is working great! I had to disable TTS and re-enable it after getting set up.
TTS works using the JSON package provided in the description, but I’m wondering if anybody has found a way to get TTS working using the UI, with a custom media player card or otherwise? I’d just rather not have to type out / copy paste the whole json body every time I want to haunt my own house!
I would love a solution to this!

Also, just something I noticed, it auto detected my two fireTVs, but as far as I can tell I can’t do anything with them, they appear to stay idle even when watching standby. Not a bug or anything I’m hoping for an answer to, but maybe an area that could be added support for at some point? That would be really cool if you could control all amazon devices with this, but maybe thats too much to ask. =P

Anyways, really, thanks you!
-Evan


#1254

Hmm,

Device under same account as in the hass setup (my email)

Nothing in my history. Related to the TTS

As for server I believe all under .co.uk but not sure how to tell about the device?

How would I tell?


#1255

…and the answer is…no :roll_eyes:
I tried different commands like “start Simon”, “start Tom”, “open Simon”, “open Tom” (in Italian of course) and all of those commands from TTS return only error sound…


#1256

you see your deies so i guess they exist in the server you use.
is the language from your devices also set to uk english?
you could try setting it to amerikan english, to see if you get better result.

there are several things that came up in this thread or in the one about the script, but i did mention all i could remember.
i got 13 dots running now, and i have als problems with debugging.
in most of the times i send TTS to 6 or 8 devices, 2 or 3 just dont do it.
but they al do respond when i do it 1 at a time.

its very hard to debug. all you can do is read, read and read more and try out everything others have tried.

@Nerkyator
i ment: say start simon to your alexa (that starts your skill) then use tts a second later :wink:
but it wouldnt bring anything usefull, i guess there is nothing to do at the moment then hope and wait (or use english)


#1257

Hello Everyone - Update:

I have been away and not able to work on this due to starting a new job and moving. It has been a crazy year so far, but I do plan on diving back into this and getting it officially supported by Home Assistant.

I want this to work with as many users as possible, and to do that I will need help making those in different regions of the world to test and submit bugs on my GitHub. For those of you familiar with looking at network traffic in Chrome Developer Tools that would be a massive plus.

Alexa Routies:

The custom component currently relies heavily on routines and effectively using the ability to “play” them as a means of getting a lot of the cool functionality like TTS, Music, etc to work. For those in areas where routines are not yet available I do not believe those functions will work, but everything else should work just fine. Hopefully, with help I can drill down which regions do and do not support certain features.

New Features:

Since I first posted this it seems that we’ve gotten a few new updates for routines, such as the ability to set volume without music being played and set a timer for how long music will play. I plan to implement these features to make them available.

Thank you so much to everyone for keeping this thread alive while I’ve been away. Hopefully with a few more weeks I can get this ready to be pushed to home assistant directly.


#1258

Glad to hear you haven’t abandoned the project man, I was a little anxious when I saw the recent GitHub post.


#1259

Hi,
Sorry guys, but the Captcha does not work for me. I tried to restart but nothing. you can help me? thank you
Michele


#1260

Did you ever get this sorted?

In case anyone else gets this issue, I had to delete the pycache folder from the media_player folder and restart HA. That did the trick!


#1261

I can’t wait to see how much more we can get, I wish we could get skills to work with the UI (ie: Alexa, ask chevy to start my car)

The TTS has been great and I love the automation announcements I can make, now the kids don’t forget to take their showers or waking them up in the morning before school. Its great stuff, thanks for all the work you have put into this!


#1262

I did a week or so later I tried again and it went through the process fine. Unfortunately its not clear what was causing the issue previously.


#1263

So just out of curiosity is it possible to start a skill in the US yet using this component?


#1264

no, skills cant be started with this anywhere.


#1265

Appreciate the response @ReneTode I’ve been scouring the comments but there’s just far too many.