EFERGY POWER METER 2021.8 Energy Config - No matching statistics found

sorry, it was a different PR that got merged.
This one works for me

OK. So with the latest update, Efergy was pulled into the integration page and now the total consumption now shows up as a value that can be pulled into the energy tab.
Any ideas on how to bring all your additional CT’s clamps which are connected to the efergy hub into HA? I can see their wattage but it does not automatically generate a kWh value.

1 Like

yes, @tkdrob has done a great job getting this integrated.
I only have one clamp, so I can’t test this, but I believe the data per clamp is power only (W) not energy (kWh).
You could run these to see what you get back:
curl “https://engage.efergy.com/mobile_proxy/getCurrentValuesSummary?token=XXXX”
curl “https://engage.efergy.com/mobile_proxy/getInstant?token=XXXX”
curl “https://engage.efergy.com/mobile_proxy/getEnergy?offset=600&period=day&token=XXXX”

You could always convert the Power to Energy by using the integration platform:

and then use that in the dashboard.

I have four clamps in total but this integration now only shows one

Yes, same as me. To get the others to shows up as individual devices you need to load them up with the Riemann sum integral.

Now I just need to get my Sonoff POW’s listed.

Are you sure it shows one of the clamps or does it show the total energy consumption?
Also, I had quite a few entities in the Efergy integration disabled. Maybe your missing clamps are there?

Its a mess. My AC on the efergy works just mostly fine using Riemann sum integral. My geyser using the exact same integration is completely out (recording more than double the usage of who whole house)

Just curious if anyone has set up a temporary template sensor to allow Efergy to be used as Grid consumption?

I have. Its been working perfectly for a month or so now.



Sorry, very new to HA! I’m running version OS 7.2 and have three Efergy CT sensors (Whole House, ASHP & Solar). None of these Entities appear in the drop-down within the Energy set-up.

If I add your code to my config.yaml, HA boots into Safe Mode. Is this still a valid approach with this version of the OS? Am I completely missing something? Any help, is greatly appreciated but please don’t assume that I have a great level of technical knowledge!

There are two separate files you need to look at to implement the code you quoted…

The third line in the quoted code ( customize: !include customize.yaml) is telling the config to look for customizations in a separate file called customize.yaml (create it in the same folder you have the configuration.yaml file in)
Then in this customize.yaml file place the rest of the code you have quoted. Save the file(s), reboot and you should be good to go :+1:t2:

you can read more about splitting your config files here

1 Like

Thanks. :slight_smile:


@Gav_in - I’m now getting the error:

2022-01-26 17:32:40 ERROR (MainThread) [homeassistant.config] Invalid config for [homeassistant]: [customize_glob] is an invalid option for [homeassistant]. Check: homeassistant->customize->customize_glob. (See /config/configuration.yaml, line 35)

Hi…you’ve an error in your config as the log suggests (though you prob worked that out :slight_smile: )

Without seeing your config file (and line 35 that the error message references in particular) it’s hard to tell.
At a guess you have the customize options in the wrong place(file). If you’ve split up your config as per above posts then the only reference to customize in the configuration.yaml file should the line that has customize: !include customize.yaml in there.
customize_glob and all other customize options should be in the separate customize.yaml file.

So taking the original post you quoted the following should be in your customize.yaml file (and nowhere else)

      last_reset: '1970-01-01T00:00:00+00:00'
      device_class: energy
      state_class: measurement
      unit_of_measurement: kWh

(you can read more about Customize here Customizing entities - Home Assistant which might help too.)

Thanks for your replay, my configuration.yaml file is as follows:

customize: !include customize.yaml

And my Customization.yaml file is:

last_reset: '1970-01-01T00:00:00+00:00'
device_class: energy
state_class: measurement
unit_of_measurement: Wh

The only thing I have changed, ( although the error occurred before as well) is to change sensor name and the unit. Could this be an indent issue? I have tried no indent on customize_glob as well as two spaces.

Yeah could be indentation alright…yaml is very specific like that.
Can you post your code in code format here so we can see exactly what you have (you need to wrap your code in ’ I think), and will see if anything jumps out :+1:t2:

Thanks again. :slight_smile:


  # Insert Customize file
  customize: !include customize.yaml


      last_reset: '1970-01-01T00:00:00+00:00'
      device_class: energy
      state_class: measurement
      unit_of_measurement: Wh

Remove the quotes from the sensor_power_usage line in your customize.yaml file…think that’s the issue.

(sorry for late response…think you replied to the thread in general rather than specifically to my post so didn’t get a notification)


Sorry for the delay, rebuilding my study after decorating!
I’ve tried with and without quotes, same result.

Hi…are you sure that the Sensor you are trying to customise is called (or starts with) sensor.power_usage_?
You might need to adjust the code to match to your own sensor names.

This is what I have in my customize.yaml and it works fine for me…

sensor.efergy_consumption: #Efergy Energy Reading - Customised for Energy Features in 2021.8
  friendly_name: Energy Consumption (Efergy)
  last_reset: '1970-01-01T00:00:00+00:00'
  device_class: energy
  state_class: measurement
  unit_of_measurement: Wh

The sensor I’m customising it the one generated by the Efergy Integration.

If it’s still not working for you post the Attributes of the Sensor you want to use on the Energy Dashboard so we can see what’s missing…(you can get this in Developer Tools > States)

This is my device list for my Efergy: