Elero USB Transmitter to control Elero and Weinor products

Great job @dierk86 :slight_smile:

I just hope @istvan.szirtes joins us again. There is no trace of him for quite a while now :frowning:
At least the Summer is over now so I’m using the shutters less hehe.

1 Like

Hi All!

I kindly sorry to be so gone…

however, you can find a new version of my lib: https://github.com/W00D00/home-assistance-elero

I will read all of your comments and assumptions and bug reports and make corrections.


1 Like

Hi Istvan,

many thanks. I have testet the new version. Cover groups now works fine.
However, close_tilt_cover in continuous mode seems to be wrong. In this mode the shutter closes completely. My expectation was that the shutter moves to the tilt position that I have stored in the shutter (not in hassio, but in shutter itself). For this, there is a separate Elero command, which must be sent to the shutter. Similarly, there is a separate command for an intermediate position.

One more comment on the unknown responses. If you move to any position by going up or down a certain amount of time and then stopping, the stick is in an unknown position and provides feedback. Known positions for the shutters are only at the very top, at the very bottom, as well as the tilt and intermediate positions stored in the roller shutter.

Finally, a note on several Elero sticks. Can you give me some information on how to configure several Elero sticks? I suppose I can not simply write “elero” with the appropriate port in the configuration several times. Furthermore, the covers should know which stick they belong to.

Nice to have you back!!! :smiley:

Hi Dierk,

The tilt modes (stepper and continuous) are in alpha state. I have a big problem with monitoring the covers and stop them where it is needed. I am working on it…but first I need to solve the one-command-more-devices problem…

The tilt and intermediate positions are not implemented yet. Sorry.

From now, you can setup more than one usb stick. Please visit my Github channel for the configuration: https://github.com/W00D00/home-assistance-elero

Please share your experience with me.


1 Like

Hi All,

A new version is ready for test. Please visit my Github: https://github.com/W00D00/home-assistance-elero

If you have any question or you faced with trouble, do not hesitate to contact me, all comments, insight, criticism is welcomed!

1 Like


I made improvements on my Elero lib:

  • Ventilation/Tilt position handling (Elero’s own)
  • Intermediate position handling (Elero’s own)
  • More than one USB stick handling

Please try it and share your experiences with me.


1 Like

Hi Istvan,

many thanks!
With the groups I have again and again the problem that not all shutters drive up or down. Whereby the problem occurs more often when starting up. It’s not always the same shutters that don’t start. This problem also occurred with the previous version.

1 Like

Hi Istvan,

I’ve finally gotten around to testing new version(s).
I can’t get it to work for some reason. I’m probably messing something up in the new config.
Here is my Hass log:


Can you help pls?

Hi @istvan.szirtes

I’ve managed to configure the component.
Here are my findings. I have 9 shutters by the way.

Status reporting is much much better now and control is almost perfect. Shutters don’t get stuck in a position anymore and entity status seems consistent (previously it was jumping from open to closed etc.).
Only thing I noticed is that change from closing to closed takes a while to update (probably around a minute sometimes), I guess it takes a while to pool the info from the shutter.

Also, one of my shutter reports unknown status for some reason, but it does work. Which in turn messes up the cover group status, but that’s not a huge issue for now.

Group operation also seems to work for me, but I haven’t tested it much. I don’t have any problems @dierk86 mentioned.

So apart from that one shutter that reports “unknown” status, rest seems fine for now.
I’ll do more testing when I’m back in the house. Testing from remote location, with help of cameras :slight_smile:

1 Like
Failed config
    - Invalid config for [cover.elero]: expected int for dictionary value @ data['covers']['bedroom']['channel']. Got [9]

As fas a I can see the documentation and the example configuration file is wrong.

Instead of

            - 9

you have to write:

          channel: 9

Thanks, you are correct about that.
I’ve figured it out in the meantime.

I do have another problem, since one of my (10) shutters shows as unknown state in HA.
It does work when I click up/down/stop it’s just the state that is not recognized for some reason.

Anyone has same issue? Is the communication problem between stick and shutter, or stick and HA?

I have the same issue that some of the shutters show “unknown” state in HA. :frowning:
And I’ve no idea about the reason or how to investigate the reason, as I am not really familar with HA.

To be more precise: We have 13 Elero shutters and 5 of them have permanently ‘unknown’ state, but all of the 13 shutters are of the same model / type / …
And all 13 worked fine in FHEM before.

Is there any way how I could help / support investigating this issue, e.g. by providing log files?
I would be very interested that this issue get fixed. :grinning:

By the way - I first thought it could be an timing issue - so increased read_sleep, read_timeout and write_sleep - but this does also not help. :frowning:

Yeah same here. All shutters / motors same model, but just one shows “unknown”.
Only thing that pops to mind is to try to re-pair the shutter with the stick? Maybe the pairing process didn’t go all the way the first time (shutters can operate in two modes, with both way communication and one way).

Any chance you can try to pair one of the unknown ones from the scratch? I’m away from home for a few weeks so can’t try it myself :frowning:

The Elero transmitter stick does only support the two-way communication mode. The older “one way” Elero shutters cannot be paired with this stick at all…

Also I am sure that the stick worked fine with FHEM a few weeks back (and I just use the same stick - so I am sure that the pairing did not get lost…).

But anyways - perhaps I try to repair at least one shutter to verify that.

Sorry for this double-post.

I now found a tool which is running on Windows OS which can be used for checking the stick:

So I inserted the Elero transmitter stick into my Windows machine and executed the tool from Elero.
When I then click on “info” for every channel, then I can see the following:

(Sorry, that everything is on Germany on my machine)

So as I can see - for every channel the correct “open” status is returned (“Stopp in oberer Endlage” = “Stop in upper end position”; meaning open), nothing with “undefined” or similar.

From my point of view this shows that the paring of the shutters to the transmitter stick is fine, the stick is working fine and also all shutters are working properly.

It is just that Home Assistent does not work correctly with the stick up to now… :frowning:

OK, I guess we have to wait and hope @istvan.szirtes can find a fix. But if he doesn’t have the same issue, he can’t replicate it :frowning:

Yes, let’s hope that @istvan.szirtes comes back and has time to investigate this. :slight_smile:

If anybody needs log files, please just ping me and let me know which log file is needed / how extended logging can be enabled.

When I look at the LED on the transmitter stick, I think the blinking is a quite bit “strange”. Normally, when a command is sent (e.g. to get the status or to move a shutter), the LED does indicate this with an orange color. When the answer is received, it should show that in green color. I think both colors show be visible for around 1 second.

But when I watch the LED of the stick while it is used by HA, it is more flickering / flashing, my feeling is, it is much too fast (and the system is not waiting enough time for the response).
Also in comparison when I’ve used the same transmitter stick with FHEM, the blinking was much slower…

So my feeling is, that the stick should be used in a slower way and HA should wait a longer period for an answer, so not to miss the answers from the “slower” shutters. But playing around with the timing parameters also does not help on my system. :frowning:

@Igor_Jurisic: Is your shutter, which reports ‘unknown’ state, the one which has the biggest distance to your HA system / the transmitter stick?

No it isn’t…actually it’s very close (few meters).
But I do remember that binding that shutter took a few tries originally (with stick and outdoor sensero wind sensor).

That’s why I suspected that full-duplex (or whatever it’s called) doesn’t work properly.