Elko Smart 4 button switch setup


I have a well-working setup running HA(RPI3) + RaspBeeII onboard. Things are working fine.
I have several Elko Smart devices connected using ZigBee. However this 4-button light switch(wireless) connects but none of the buttons are recognized, so I’m not able to create any automation/scripts).
I’m not a developer…how do I adjust my installation so that this device I set up/recognized correctly?

The correct model type is FLS/AIRLINK/4 by Schneider Electric

I was looking for the same and found this: Schneider Wiser Remote
It works perfectly well for me with the Elko smart switch connected with ConBee USB stick. For some reason I had to activate 2-channel mode by pressing button 1 and 4 for 10 seconds.

Have you upgraded to the very latest firmware on the RaspBee? If not then start by doing so first.

You forgot to mention which exact Zigbee solution you are using, it is hard to help without knowing.

The device might need a new “quirk” if using ZHA or a new “converter” if using Zigbee2MQTT, read:




respectively. If you can not code a quirk or converter yourself then need to submit new device request.

If you are using deCONZ/Phoscon then believe you have to submit a similar new device request for it.


I’m running new firmware. I tried to set the switch in mode 2, but no change, still it does not show that it has any controls. However, i configured with the automation blueprint in the link and that solved it :slight_smile: So now they are working as they should. Many thanks both!!