Emulated Hue problems

I have quite a complex network so I just tried connecting only two devices at the cable modem, my laptop and the HA-Bridge on Pi2, both hard wired. http://alexa.amazon.com still could not discover the HA Bridge. Doesn’t look like a network issue?

The plot thickens. Did a clean install of Jessie on Pi2 (not Lite) and installed HA Bridge. Bridge working and can connect and control my Vera. However, when doing a Fing scan, no UPnP services are presented (null).

Maybe that’s why Alexa can’t ‘see’ anything? In contrast, my IP cameras are broadcasting on upnp port 5000. The HA Bridge instance only has services running on 22 and 8080.

Could this be something to do with Raspbian? Can someone with a working system do a Fing scan or another upnp scanner and advise what is presented to the network?

And here is the service status from Ha Bridge

pi@raspberrypi:~ $ sudo systemctl -l status habridge
● habridge.service - HA Bridge
   Loaded: loaded (/home/pi/habridge/habridge.service; enabled)
   Active: active (running) since Tue 2016-09-20 22:37:40 NZST; 21min ago
 Main PID: 498 (java)
   CGroup: /system.slice/habridge.service
           └─498 /usr/bin/java -jar -Dconfig.file=/home/pi/habridge/data/habridge.config /home/pi/habridge/ha-bridge-3.1.0.jar

Sep 20 22:37:49 raspberrypi java[498]: 2016-09-20 22:37:49,208 [Thread-0] INFO  spark.webserver.JettySparkServer - == Spark has ignited ...
Sep 20 22:37:49 raspberrypi java[498]: 2016-09-20 22:37:49,236 [Thread-0] INFO  spark.webserver.JettySparkServer - >> Listening on
Sep 20 22:37:49 raspberrypi java[498]: 2016-09-20 22:37:49.266:INFO:oejs.Server:Thread-0: jetty-9.3.z-SNAPSHOT
Sep 20 22:37:49 raspberrypi java[498]: 2016-09-20 22:37:49.640:INFO:oejs.ServerConnector:Thread-0: Started ServerConnector@b6b972{HTTP/1.1,[http/1.1]}{}
Sep 20 22:37:49 raspberrypi java[498]: 2016-09-20 22:37:49.660:INFO:oejs.Server:Thread-0: Started @8672ms
Sep 20 22:37:50 raspberrypi java[498]: 2016-09-20 22:37:50,707 [main] INFO  com.bwssystems.HABridge.devicemanagmeent.DeviceResource - HABridge device management service started....
Sep 20 22:37:50 raspberrypi java[498]: 2016-09-20 22:37:50,832 [main] INFO  com.bwssystems.HABridge.hue.HueMulator - Hue emulator service started....
Sep 20 22:37:50 raspberrypi java[498]: 2016-09-20 22:37:50,887 [main] INFO  com.bwssystems.HABridge.upnp.UpnpSettingsResource - Hue description service started....
Sep 20 22:37:50 raspberrypi java[498]: 2016-09-20 22:37:50,903 [main] INFO  com.bwssystems.HABridge.upnp.UpnpListener - UPNP Discovery Listener starting....
Sep 20 22:37:50 raspberrypi java[498]: 2016-09-20 22:37:50,932 [main] INFO  com.bwssystems.HABridge.upnp.UpnpListener - UPNP Discovery Listener running and ready....

That is a very strange issue everyone seems to be having. I have HA Bridge running on 2 different Raspberry Pis, at 2 different houses. 1 on an RPI2 and 1 on an RPI3. Originally both were running on the default port 8080 and The Amazon Echo and Dots picked them up right away (for the most part, read the last paragraph). 1 House has 1 Echo and 1 Dot and the the other house has 1 Echo and 3 Dots, and all of them picked up the HA Bridge on port 8080.

One of the houses now has the HA Bridge running on port 80, because homebridge for Siri support would only look for Hue Bridges on port 80, but in both cases, with port 8080 and port 80, the Echo and Dot devices picked up the HA Bridge without any special configuration or router changes, so I’m kind of at a loss for why it is not seeing your HA Bridge.

Now, there is a possibility of an issue within the Echo/Dot itself, but only if you have a pysical Hue Bridge in the mix. In the second house, there is a physical Hue Bridge, and the Echo was connected directly to it before I setup HA Bridge. Once I setup HA Bridge, the Echo refused to see it and would only see the physical Hue Bridge, so I had to jump through some hoops to remove the reference to the physical Hue Bridge from the Echo, though in hindsight, it may have been easier to reset the Echo and start from scratch lol Anway, once I got the Echo to no longer be authorized for connection to the physical Hue Bridge, it instantly picked up the HA Bridge and I have not had a problem since.

I have logged a ticket on Github and we’ll see where that goes as I’m running out of hair :grin:

I’m not sure whether Home Assistant Alexa Skill Adapter haaska will be any help.

@brusc put together a good video which demonstrates haaska in action, and provides a walkthrough of the setup process.

OK, I’m a dumb arse. I’m only using Echoism.io as my Echo source at the moment until my new ‘Dots’ arrive sometime next month. It seems that Echoism.io does not expose the home automation devices on the network. Using my Harmony hub, I was able to add a hue bridge, but only using ha-bridge, not the embedded hue on HA. If I use embedded, the harmony gets stuck waiting for me to push the button on the hue which of course I don’t have. If I try the same process using ha-bridge, when it gets to the screen below, it just moves on by itself and completes the pairing process.

The more I look into this, the more I suspect it is related to the SSDP broadcast & response (which is UDP multicast) more so that the emulated_hue activity, which is TCP unicast to HASS. The Echo has to know how to talk to the Hue bridge, and SSDP is the key to discovering the TCP endpoint to interact with. I have UPnP turned on for my router, but I think something might not be working as it should.

I logged one a couple weeks ago too when I thought it just wouldn’t pick up scenes, but I haven’t gotten any replies: Alexa not detecting scenes from Emulated Hue · Issue #3357 · home-assistant/core · GitHub

Where’s yours?

Now I’m having the same issue as everyone here – no devices are getting discovered even though the Emulated Hue server is running and lists my devices. What’s super weird is that it DID work at first. When the Emulated Hue feature first came out, I enabled it and Alexa found all my devices. It was awesome and so easy.

It was a week or so later that I started having problems, noticing that it wouldn’t pick up name changes I made in the config files (but the devices would still work with their old names). In a fit of troubleshooting, I told Alexa to clear all devices and start discovery fresh…and since then it can’t find ANY of my Emulated Hue devices.

I cannot figure out what changed (other than Home Assistant getting updated) between when it worked and didn’t.

I logged mine against ha-bridge but closed the ticket as I’ve made the assumption (unconfirmed) that Echosim.io does not expose your home automation devices to Alexa? As I’m in NZ, The Echo is not readily available so I’ve put everything on hold until my two new ‘Dot’s’ turn up mid Nov.

Is this just a matter on installing homebridge on the same Pi then installing the homebridge-harmonyhub plugin?

@jbardi just experimenting with both and I also get some unstable behavior with the emulated hue (actually HASS does sometimes does not want to start and throws error concerning the emulated hue, other times hass starts without a problem).

HA bridge seems stable.

However HA_bridge seems quit a lot of work to setup (I have about 70 lights/switches, 20 sensors etc,) and for every device an on & off. Is there an easy way to do this at scale?

@jbardi another Q: Could you also explain how you did the control of a climate component in HA_bridge?

Back to the install for a moment, I’ve installed the latest version 3.2.2 and I’m trying to execute it. according the the habridge log file, It tries to load the config file from the data directory, but can’t find it. It doesn’t seem to be to upset about that, but then gives the following error, that makes me think I may be missing something with the web server.

2016-11-13 09:13:04,128 [Thread-0] INFO  spark.webserver.JettySparkServer - == Spark has ignited ...
2016-11-13 09:13:04,136 [Thread-0] INFO  spark.webserver.JettySparkServer - >> Listening on
2016-11-13 09:13:04.147:INFO:oejs.Server:Thread-0: jetty-9.3.z-SNAPSHOT
2016-11-13 09:13:04,457 [Thread-0] ERROR spark.webserver.JettySparkServer - ignite failed
java.net.SocketException: Permission denied
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Net.java:433)
at sun.nio.ch.Net.bind(Net.java:425)
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
at org.eclipse.jetty.server.ServerConnector.open(ServerConnector.java:326)
at org.eclipse.jetty.server.AbstractNetworkConnector.doStart(AbstractNetworkConnector.java:80)
at org.eclipse.jetty.server.ServerConnector.doStart(ServerConnector.java:244)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
at org.eclipse.jetty.server.Server.doStart(Server.java:384)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
at spark.webserver.JettySparkServer.ignite(JettySparkServer.java:131)
at spark.SparkInstance.lambda$init$0(SparkInstance.java:341)
at java.lang.Thread.run(Thread.java:745)

Any thoughts?

I think I had similar errors after updating to 3.2.2. Previously working fine.

There is a read error on first boot that is normal, goes away on next launch.

It seemed permissions related so I changed the paths to absolute rather than relative. I had to do this in the actual habridge.config file itself, wouldn’t seem to stick via web interface. Perhaps check permissions while you are at it. On the Pi all in one install, instead of just “data/habridge.config” & “data/device.db” I used…



Perhaps we need a dedicated Ha-Bridge thread.

While we are here - does anyone know how to control media player volume via the dim command?

that may be part of the problem. I can’t find a habridge.config or device.db file anywhere?

How and what did you install it on?

If it’s Raspberry PI AIO it’s a directory or two above the home assistant folder.




How do you access and edit the HASS config files?

I did this, https://github.com/bwssytems/ha-bridge and created the habridge under the /home/pi directory and did not run it from the virtual environment.

Should be in /home/pi/habridge/data then. Same as mine.

device.db might not be created until first run, but habridge.config is the bit that tells it where to live.

If you are able to load up the web interface try changing the locations under bridge control/setup - I think it is the second tab but don’t have it in front of me.

Secondly - the instructions on BWS needed a little tweaking for auto launching the AIO version - I’m not home so can’t check right now but I posted somewhere what the changes were, just not this thread - I’ll have a look and come back.

EDIT: Here

Basically… The instructions linked to an amazon-echo folder at one point but looks to have been fixed…

I’ve since started renaming the ha-bridge-3.2.x.jar to just ha-bridge.jar each time I upgrade so I don’t need to adjust it.

Now I’m not at home. I’ll give it a try when I get home after work.