Energy Dashboard ESPHome Gas and Water

What am I doing wrong here.
My gas and water statistics aren’t found in the energy dashboard, but I can see the statistics and entities in the Developer Tools menu.
Both water and gas are measured via pulse meters on some ESP32s.
Here is the relevant ESPHome yaml:


  - platform: pulse_counter
    pin: D1
    accuracy_decimals: 2
    unit_of_measurement: 'GPH'
    update_interval: 1s
    name: "Main Water"
    id: main_water
    icon: mdi:water
      # 330 pulses/L  .00303 L/m * 15.8503 to get GPH
      - multiply: 0.048031212
      unit_of_measurement: gl
      name: 'Total Main Water'
      id: total_main_water
      icon: mdi:water
      device_class: water
        # 330 pulses/L  3.78541 L/G
        - multiply: 0.0008005217


   # Gas monitor 1 pulse = 1 Ft3
  - platform: pulse_counter
      number: GPIO3
        input: true
        pulldown: true
    accuracy_decimals: 2
    update_interval: 20s
    unit_of_measurement: ft³/m
    name: "Main Gas"
    id: main_gas
    icon: mdi:fire
      unit_of_measurement: ft³
      name: 'Total Main Gas'
      id: total_main_gas
      icon: mdi:fire
      device_class: energy

Entities In Developer Tools menu:

Statistics in Developer Tools menu:



Gas Energy Dashboard:

Water Energy Dashboard:

I’ve tried numerous reboots, and it’s been well over 3 or 4 hours since I touched the entities in the ESPHome yaml. I have modified the ESPHome yaml, but other than that, I’m pulling my hair out trying to figure out why gas and water isn’t showing up in the energy dashboard.

1 Like

Same issue.

But I am monitoring only water consumption with Wmbusmeters.
I receiving values with Node-RED add-on over MQTT.
Then I’m creating entity in NR.

In my case, I still see the problem that the device class “water” cannot be chosen in the entity parameters in NR!?

Any ideas?

NR MQTT >> HA Entity

NR Entity device-class

Actually I solved my issue and posted here: Water Meter in Energy Dashboard Not Available - #17 by justynnuff

I didn’t realize that thread was open when I posted this.

For your issue, I’m not familiar with Node Red at all, but it sounds like they just need an update to include the relatively new (I think) device_class: water perhaps?

1 Like