Energy Management in Home Assistant

I don’t really understand what they should be if I cannot use ‘1970-01-01T00:00:00+00:00’ for last_reset_topic as you said. Let alone what value this attribute should have last_reset_value_template

At the moment this leads to an error, see this thread: I guess it is a bug, where/how could we report this?

Edit, never mind, I found it on GitHub, will report it in “core”.

Apologize being late to the party.
Any chance that EmonCMS becomes supported?
Being one of the leading Open Source monitoring Package it is a shame it is not


I am already tracking most of my devices for power consumption via sonoff POWs installed between those devices and power grid. I have detailed current energy usage (W) and a history for yesterday and last 30 days (KWh). Is there a way to import that data to HA Energy Management? Do I need to set unit of measurement somehow?


Are there any schematics for SlimmeLezer?
I have a p1 to usb cable and plenty wemos D1’s

1 Like

I think this is working for getting data from Powerwall setup

  - sensor:
    - name: Powerwall Energy Consumption Site
      state: "{{ state_attr('sensor.powerwall_site_now', 'energy_imported_(in_kW)') | float | round(0) }}"
      unit_of_measurement: 'kWh'
      state_class: measurement
      device_class: energy 

    - name: Powerwall Energy Loading Site
      state: "{{ state_attr('sensor.powerwall_site_now', 'energy_exported_(in_kW)') | float | round(0) }}"
      unit_of_measurement: 'kWh'
      state_class: measurement
      device_class: energy 

    - name: Powerwall Solar Generated Site
      state: "{{ state_attr('sensor.powerwall_solar_now', 'energy_exported_(in_kW)') | float | round(0) }}"
      unit_of_measurement: 'kWh'
      state_class: measurement
      device_class: energy 

I then had to go and add to the states manually, since I get errors when trying to do it in the template

  last_reset: '1970-01-01T00:00:00+00:00'
  last_reset_value_template: '1970-01-01T00:00:00+00:00'

Reported! Can't set last_reset value for MQTT sensor · Issue #53988 · home-assistant/core · GitHub

we are missing tons of device coming with Solaredge integration… I have both Solaredge standard integration and modbus one.

Missing a lot…

1 Like

Just a question, is it possible to also get this to work with consumed gas? I can add the gas usage to the dashboard when I change the “unit_of_measurement” from m3 to kWh, so in theory it should be possible. Are there plans to also add gas (m3) to the dashboard? Or is it already possible? If not, I’ll make a feature request.

Btw, it must be said, this dashboard is really a killer feature, I love it a lot! Well done!

it’s not working properly with Solaredge integration and even with modbus… I have both with Smartmeter and battery… I can’t find how to use all infos I have and integrate to energy dashboard

fantastic! Will this make it easier to get direct data from
my Epsolar inverters directly i to HA? Forecast is nice, but getting the actual production would be great - without buying hardware. Have USB-RS485 cable, and should be possible to connect directly with RPi?, if there was an integration?

Hi Frank, nice work!

From a developer point of view could you help out to point out how to make my custom component easy to intergrade with the new modules.

I created a Module to read private api of SAJ eSolar portal for those that do not have a Dongle with local API. I am still a bit new at creating modules but think i did a good first job. I also got a user asking me to make it compatible with this new module.

I am only struggling to find the correct documentation and examples. Hope you can help out or point me into the right direction.

The module can be found at :


Great work!

It may be a good idea to add to the article (and Home Assistant Glow readme) that pulse counters work just as well with a blinking LED as with the S0 / DIN 43864 standard for directly connected pulse reading.

Most older meters in Europe at least have an S0 output, and although your local utility may have put it behind the tamper-proof portion of the meter, many utilities will connect it for you if you ask.

When I try to configure my Enphase Envoy it complains about this: Key need to start with energy_

What does that mean?


Did the update and reboot my homeassistant core,I try to access the config_energy page, but I get a 404

My home assistant is working in

So the config page should be on:

System Health

version: core-2021.8.0
installation_type: Home Assistant OS
dev: false
hassio: true
docker: true
user: root
virtualenv: false
python_version: 3.9.6
os_name: Linux
os_version: 5.10.53
arch: aarch64
timezone: Europe/Amsterdam

GitHub API: ok
Github API Calls Remaining: 4726
Installed Version: 1.13.2
Stage: running
Available Repositories: 844
Installed Repositories: 21

logged_in: false
can_reach_cert_server: ok
can_reach_cloud_auth: ok
can_reach_cloud: ok

host_os: Home Assistant OS 6.2
update_channel: stable
supervisor_version: supervisor-2021.06.8
docker_version: 20.10.6
disk_total: 28.0 GB
disk_used: 7.5 GB
healthy: true
supported: true
board: odroid-c2
supervisor_api: ok
version_api: ok
installed_addons: File editor (5.3.3), TasmoBackup (1.04.02), Home Assistant Google Drive Backup (0.104.3), Terminal & SSH (9.1.3)

dashboards: 2
resources: 13
views: 5
mode: yaml

I just tried to set mine up and I see the same thing. I tried to create a daily energy monitor using utility_meter:

    source: sensor.envoy_today_s_energy_consumption
    cycle: daily
    source: sensor.envoy_today_s_energy_production
    cycle: daily

After a minute or two of the restart, I saw it in the list of options but when I select it and hit “save”, it pops up this message: Key need to start with energy_ I’m not sure what that means but this seems like it’s not working.

I am also very interested in getting my Envoy working with this stuff. It’s a shame that it’s not working. :-/

I have a CT clamp on my grid feed which is positive on import, negative on export. How are people handing that? I’ve template sensors at the moment but they’re not compatible yet. Is there another solution?

1 Like

So I have an EmonPi and tried to “Qualify” my energy/power sensors to get “sensed” by the energy integration:

FeedId: '49'
Tag: emonpi
FeedName: import
Size: '2830280'
UserId: '1'
LastUpdated: 1628113249
LastUpdatedStr: '2021-08-04 23:40:49'
unit_of_measurement: W
friendly_name: import
device_class: power


FeedId: '50'
Tag: emonpi
FeedName: import_kwh
Size: '2830268'
UserId: '1'
LastUpdated: 1628113584
LastUpdatedStr: '2021-08-04 23:46:24'
unit_of_measurement: kWh
friendly_name: import kwh
device_class: energy

Despite this energy integration installation is not possible.
What should be done?

I have this working - my instant consumption is delivered to Home Assistant via MQTT from an RFXComm433 stick. I had already previously set up the integration component to get daily, weekly, monthly, quarterly and yearly readings out of this (using the utility_meter integration). The sensor I use with the integration component is being picked up in the Energy dashboard with no modifications:

  - platform: mqtt
    name: "House Electric"
    state_topic: "dhjm/rfxgateway/CM119_160/0xC872"
    device_class: power
    unit_of_measurement: 'W'
    value_template: "{{ value_json.power.value | int }}"
  - platform: integration
    source: sensor.house_electric
    name: House Electric KWh
    unit_prefix: k
    round: 2

Hope this helps.
Link to integration docs: Integration - Riemann sum integral - Home Assistant


uhm not here:

FeedId: '50'
Tag: emonpi
FeedName: import_kwh
Size: '2830268'
UserId: '1'
LastUpdated: 1628113584
LastUpdatedStr: '2021-08-04 23:46:24'
unit_of_measurement: kWh
friendly_name: import kwh
device_class: energy