Enphase Envoy - Current state of things

My point in attempting to show the commit history was that the home assistant devs are making changes to the enphase_envoy core component so that it stays compatible with future home assistant releases.

The home assistant devs won’t be responsible for any of the forks mentioned in this thread and the risk is that a new HA release may cause a new issue with an older fork.

If that happens, your only support option is the author of the fork you are using.

1 Like

Once it’s committed/released to core I’m going to be up shit creek trying to figure out how to delete the old and get the official one working lol

1 Like

I am fully aware of that. You see, I just got solar panel installed last week, so I cannot wait the official integration. The DEV version works fine for now. Currently, I am trying to figure out Forecast Solar which is way off.

Here is today, Forecast Solar is the dashed line.


And here is the discussion with person who knows about it. It is still not right :laughing:

Can’t get forecast.solar forecast to line up with my production - Configuration - Home Assistant Community (home-assistant.io)


As I am in Australia which is not supported natively last time I checked, I have to use an add on called Solcast which works well for me.


I had similar forecast issues. I subscribed at the lower tier, got the proper tilt/azimuth for each array and split them apart into two forecasts (front roof/back roof) and now it gets pretty close. Today is a bit of an oddity, but forecast was sun/haze and it is hardcore overcast out of nowhere so seems like the general weather pattern shifted so can’t blame the dev for today.

1 Like

sorry for the delay… Here is what I created for my enphase sensors to plug into the energy dashboard
its been a while since I have done this, so there may be better ways now ???
Did a little more digging (might update this again…)
Use this as your base to learn → Enphase Envoy with Energy Dashboard

I have another HA environment I am building out to try and simplify a lot of things as HASS keeps getting more user friendly. And I also like not having to constantly tutor my friends using it on how to use vi and code files/configs/yaml when they barely know to click-drag-drop in windows.

but not all things are as simple as we would like, so you gotta at least know how to create a template in the configuration yaml for now.

I dropped this at the bottom: (gives me a couple sensors)

  - sensor:
        name: Grid Import Power
        state_class: measurement
        icon: mdi:transmission-tower
        unit_of_measurement: W
        device_class: power
        state: >
            {{ [0, states('sensor.envoy_20230xxxx_current_power_consumption') | int - states('sensor.envoy_202302xxxxxx_current_power_production') | int ] | max }}
  - sensor:
        name: Grid Export Power
        state_class: measurement
        icon: mdi:transmission-tower
        unit_of_measurement: W
        device_class: power
        state: >
            {{ [0, states('sensor.envoy_202302xxxxxxxx_current_power_production') | int - states('sensor.envoy_202302xxxxx_current_power_consumption') | int ] | max }}

Next I restarted then went into the HELPERS section and create 2 energy sensors. This is a new method to replace the 2nd part of the link I posted above…

Now I have the basic sensors for the dashboard
Much easier this way!!!
Only CATCH22 I have encountered is… since it is dark here, my sensor.grid_export_energy isn’t populating a value so I might have to wait until the sun comes up to plug it into the dashboard (that is very odd) Just didn’t wait long enough… it finally popped in there

1 Like

Here is the comparison
Which now that I look at this… seems I have something off, because they do not match perfectly or even close.
The Production is pretty close, but I need to revisit my sensors/templates for import/export energy
Revisited this and made a couple changes for the forcast.solar and co2 signal integrations… will see how this pans out tomorrow.

1 Like

Anyone sees this error in the Settings, System, Logs?

It’s quite concerning if this custom integration will be broken in the upcoming 2023.3.


Hi guys,

I have just installed home assistant on my PC and envoy got picked up automatically. The only thing is the visual dashboard does not look anything like the enphase app graph. What do I need to do?


This guide will show you what to do to get started.

After you get the grid import power, grid export power, grid import energy, grid export energy sensors created, you can then follow this post on how to duplicate the look and feel of the enphase app graph.

Here is mine at the moment

Hello everyone, sorry but I’m new to this. I have installed solar panels and have integrated them with Enphase Envoy (DEV). It recognizes all the sensors but the current consumption and current production sensors will not let me use them in the energy tab.
Could you tell me what I have to do? thank you very much for everything.
All the best,

I’ve recently documented that exact point for someone else:

Hmmm… I got the Enphase DEV repo installed, and when i go to actually add the integration, it autodetects my system. I check the box for “use enlighten” and then darn - unexpected error. Anything I should be looking at?

Is there a more detailed error message in the log? Otherwise, because you are using a custom component, we may need to refer you to its developer for more help.

See my earlier post in this topic on this issue:

I strongly believe that my unit only generates “Production” figures, for each individual IQ7+ and a total. I believe the “Energy” numbers like total life cycle energy production are calculated in the Enlight-cloud, and will therefore never be retrievable from the unit itself.
As a workaround, I used the power of HA:
sensor.envoy_1222380xxxxx_current_power_production is input to a helper (Riemann Sum Integral - Per hour) which will show lifetime production in Wh. This is then input to another helper (Utility Meter in Wh) which is plugged into the energy dashboard as Solar Production source.

1 Like

I am currently using the briancmpbll fork of the Envoy integration. I’m having some intermittent problems with HA sometimes no longer getting the data from my IQ Envoy (combiner 4). The symptom is this :
"Retrying setup : Error communicating with API: Request URL is missing an http:// or https:// protocol.


Sometimes, HA will recover and reconnect to the IQ Envoy on its own. Other times, not. I tried setting an automation that reloads the Envoy integration hourly, but it made things worse, so I stopped doing that. A “quick reload” of HA does not fix things. A full “restart server” does fix it.

I have seen it happen randomly in the middle of the day to overnight all night.

Just to be clear, my IQ Envoy of course has a static IP DHCP address reservation in my router, and I pointed HA to this static IP address . I run smokeping from a Pi and know that the IQ Envoy is available on the network when those issues in HA occur.

Any help about this would be appreciated.

It doesn’t look like @gtdiehl has done anything for over a year.

Would somebody else need to become the owner in order for the core to be updated?

I have an existing system running firmware D5.0.62 (5e57a9) but our new system (expansion) today came with D7.3.120 (ac5b3c) so I’m in a pickle on what to do. @HA_n00b did you end up installing something via HACS?

@PureeTofu and @madbrain

You need to switch to the Posixx repository. That one is updated to the HA update 2023-03.

See my post in this topic.


I tried the Posixx repository, after multiple reboots - took a good hour.
Unfortunately, it doesn’t work with the Envoy R (2010 generation, LCD model), unlike the briancampbell integration I was using.
It does work with my MY2022 IQ Envoy, but I won’t be able to find out if it solves the problem I had with connectivity.
I have both the old gen and new gen Envoy and need an integration that supports both models. The briancampbell integration did support both.
However, it was exhibiting intermittent connectivity issues with the IQ Envoy. The connecitivity with the Envoy R (LCD) never had issues, though.

Back to briancampbell for now.
Edit : looks like it already has the async fix for 2023/3 .

1 Like

Getting same error. I have uninstalled and reinstalled a couple of times. Each time it works for a few days.