Error during HACS installation. HACS cannot be installed

Hello everyone, I’m really stuck and that’s why I signed up here. I hope someone can help me. I’ve installed Home Assistant on a NUC (OS Version 10.5 - HA Core 2023.8.4), it seems to have worked as I can control my blinds through HA, for example. However, I can’t install HACS. I receive the following error message when trying to run the installation command:

"Resolving (… failed: Try again.
wget: unable to resolve host address ‘’ "

I’m not sure if this could be related, but I’m also having trouble setting up the Weather Integration. I’m getting the following error message here (copied from the log file):

ERROR (MainThread) [metno] Access to returned error ‘ClientConnectorError’

In the log file, I also see the following error message:

ERROR (MainThread) [homeassistant.components.homeassistant_alerts] Error requesting homeassistant_alerts data: Cannot connect to host ssl:default [Try again]

Does anyone have an idea how I can fix these errors and install HACS?

This is an actual URL (, if home assistant cannot reach this web page, i would look for internet access issues.

Internet access is available. I’ve integrated a website on the dashboard to display the current weather via a URL - it’s working.

Recently installed ? Used Balena Etcher ?

Hi, yes, recently installed using Balena Etcher.

You are not the first :slight_smile:

Thank you for sharing - I hadn’t been able to find the posts myself. I’ll see if I can find a solution in the shared posts.

Just use USBImager instead of Balena Etcher

1 Like

Is there any tutorial how to install HA with USBImager? I can’t seem to get it… I’ve tried various ways, but I can’t seem to make any progress each time.

According to Flashing hard drive get stuck at 31% (balena fetcher) - #48 by Damos

Here are the steps (from the beginning):

  • create bootable Ubuntu LTS USB Stick
  • UEFI boot the machine from the USB stick
  • “try” Ubuntu (live from USB stick)
  • download haos_generic-x86-64-10.5.img.xz
  • download USBimager & extract from zip file
  • delete everything from the MMC disk with the disk utility
  • create one big Ext4 file system partion with disk utility
  • move haos_generic-x86-64-10.5.img.xz to /tmp (for finding it easier later as sudo)
  • sudo usbimager in a terminal window (otherwise it didn’t let me flash the disk)
  • flash the mmc disk
  • Reboot the Mini-PC and remove the USB stick

I’ve already tried these steps, but I am unable to go beyond step 9. I’m unable to execute the command “sudo usbimager”, I’m getting the error message “sudo: usbimager: command not found”. In the installation tutorial of USBimager it is written that I have to extract the zip file to “/usr”, however I don’t have permission to do that… So I’m stuck

sudo unzip  usbimager_*.zip -d /usr

replace usbimager_* with the actual file downloaded.

Absolutely, you’re my savior, it worked now. I could install HA without any error messages. Thank you very much.

Hi man,
did what everyone was saying in the comments…created one big EXT4 file system and ran the USB image with sudo…still i can’t select my SSD. Did you use additional commands to do so?

Thank you!!!

Did you sudo usbimager?

Hi, yes I did!
Anyways, I tried to flash my SSD with Balena in Windows and it got past 32%…works like a charm now!

1 Like