Error updating Home Assistant Core 'HomeAssistantCore.update' blocked from execution, no host internet connection

I recently tried to update my Home Assistant Core from 2022.6.7 to 2022.8.6. However, it shows Error updating Home Assistant Core ‘HomeAssistantCore.update’ blocked from execution, no host internet connection." I wondering how to fix this issue.

I saw people posting solution like changing DNS to 8.8.8.8. I tried to add integration DNSIP, but the hostname was wrong for that integration. Is there another way to fix this issue? In addition, my add-on store does not load properly. Does anyone know why?

3 Likes

Go to Settings → System → Network and update your DNS server there.

11 Likes

Tanks a lot … it solve my problem

That fixed it for me just now. :slight_smile:

Yes that worked for me too! BT’s DNS now replaced. Thank you.

I hope this is the right place to ask.
I am having the same issue but on the installation of Home Assistant so I can not got to the settings of HA.
If I net info on the ha shell, I get no internet connection with the host as well as supervisor.

Is there a way to “update” the DNS setting using the shell?
Thanks.

Changing DNS did not work for me. My issue was proxy server blocking port 80 for the network connection check.

I have same problem and changed dns don’t work How you solved proxy blacking port 80

i managed to disable this check but ignoring the internet_host condition.

ha jobs options --ignore-conditions internet_host

8 Likes

This worked a treat Thanks
and to reset it back to normal

ha jobs reset

Seemed to work

You are my sunshine! I have 2 network adapters and a good connection, but don’t use the Wifi and have it disabled. Despite disabling, enabling, DNS tricks and whatnot this was the only fix that really worked! Thank you.

Did not work below, but a more technical solution in this thread worked.

So much i hope this settle my same issue but it is not…

i see comments asking to check the log, but i have no clue how to do that, anyone with any link so that i can learn? Thanks

use the terminal and write it:
ha jobs options --ignore-conditions internet_host

2 Likes

This is :ok_hand::ok_hand::ok_hand::ok_hand: @sh00t2kill

I have my primary HA host with several secondarys I just use as basically addon hosts instead of running Ubuntu and docker. The secondary ha hosts always have this problem even though the primary DNS server(AdGuard on the main ha host) is up. It happens if

  • primary host is rebooted(full system)
  • secondary hosts are not rebooted after primary is up(full system not just HA core)

Updates in UI or cli won’t work. DNS works fine for every other host in my network of 150+ devices.

I set this as an ssh -c command for my secondaries to be able to call updates via ssh -c and not get host internet warnings for calling updates via commnd line as shell commands from the primary.

Thanks!

Interesting. This made me think in more detail about what causes it.

The whole “dns wasn’t available at some point” seems to hold for me too.

I think in my case potentially supervisor starts before my dnsmasq container does.

1 Like

That’s pretty much the best short worded explanation of it.

1 Like

Works for me, Thanks.
By the way, why this happened?

I have tested that several times. This happened to me when I have not finished Sync backup with add on Google Drive and I internet connection is of - I have changed IP address of HA.