ESP32 badly shows ADC

Why shows me ADC output 1.1V
If the fact is the input 0.7V?
Please advise. well thank you.
ESP32 is powered by a 3.7V battery to a USB charger with 5V on a GND and 5V pin.
ADC Connected to SP Pin (GPIO36 ADC0)

  • platform: adc
    pin: A0
    name: “ESP32-BLE-Gateway Voltage”
    accuracy_decimals: 3
    update_interval: 60s
    • multiply: 1.0

First off, for future questions, please try to take the time to format your post correctly, and if possible, please use a translation page like It is very hard to understand what you want and where you need help. And it is a kind gesture to the repsondents, that you value their time and effort. See this post for support in doing this:

How to help us help you - or How to ask a good question

To your question, that I hopefully understand correctly. You need to set the attenuation for an ESP32. See here:

1 Like

Hi thanks for the reply. I also tried attenuation set up.
With no result. It still shows 0dB 1.1V or 11dB 3.9V at the output.

According to the multimeter, there is 0.8V at the ADC input.

Sorry for my bad English. well thank you

Problem solved:
Poorly connected resistor R1K
I changed the resistors
R 4Kohm → R 1000ohm
R 1Kohm → R 220ohm
Everything works.

1 Like