Esp32 Cam - help connect to network

excalty like in the video :

time in video: 14 sec.

i pull out the blue wire after i finished flashing
do i need to do something else?

i didn’t configure anything on esphome, i just installed the addon without any configuration.

Someone has any idea?

Well I assume you would have had to change the wifi details.

Different varities of esp32 camera boards have different pinouts. The three most common ones are documented in the esphome documentation.

Which one do you have?

please look at photos below,

The funny think is that when following this guide :
without esp home, the device connecting instantly without any issues.

only when i’m following this guide using esphome its not working, i dont what is the issue, maybe i’m doing something wrong, i never worked before with esphome, maybe i need to configure something?

The config you are using uses someone else’s wifi config.

Looking at your photos tells me nothing. How about a link to where you bought the device? How about posting a proper config file?

TL;DR - read this instead: How to help us help you - or How to ask a good question

PS, not interested in youtube videos either.

This is what i bought :

This is my config that i flashed :

hostname: ‘espcam’
ssid: ‘myssid’
password: ‘mypassword’
name: $hostname
platform: ESP32
board: esp32dev
ssid: $ssid
password: $password
fast_connect: True
reboot_timeout: 0s

pin: GPIO0
frequency: 20MHz
sda: GPIO26
scl: GPIO27
data_pins: [GPIO5, GPIO18, GPIO19, GPIO21, GPIO36, GPIO39, GPIO34, GPIO35]
vsync_pin: GPIO25
href_pin: GPIO23
pixel_clock_pin: GPIO22
power_down_pin: GPIO32

name: bedroom

… Frame Settings



  • platform: gpio
    pin: GPIO4
    id: gpio_4
  • platform: binary
    output: gpio_4
    name: $hostname light

Not correctly formatted and therefore ignored.

i would appreciate that you would tell me what is wrong with config that i have been posted.

i’m not doing it on purpose you know.

any way thanks

I have already posted this How to help us help you - or How to ask a good question

This is the link to Yaml file that i used… i just change two things in the file

ssid: ‘mywifi’
password: ‘mypassword’

link to the file:

if its not helping, that i really don’t know what i’m doing wrong…

Do I have to spell it out? Look at point 11 in the link I gave you.

i saw man, an there is blocks, never mind…

Also try taking out fast_connect and show us the logs as it boots.

i will try today and update

Not working, that so strange, it’s connecting only when trying flash through esphome.

If I flash with Arduino, it’s connecting instantly .

Maybe I need to configure something in my router for esphome? I’m also use duckdns

The log, post the log!

I’m flashing using espflasher and there is no log , I can attached the log when I compile the yaml file

It will still be logging to serial. But if you used esphome to flash this would be simpler.

Do you mean esphomeflahser?