ESP32 S3 Box3

Short term fix - downgrading to an older version of esp-idf:

esp32:
  board: esp32s3box
  flash_size: 16MB
  framework:
    type: esp-idf
    version: 4.4.6
3 Likes

I’ve been looking on how to downgrade. I’ve only installed esphome/voice assistant via the web browser before. Do I need to run esphome on my linux laptop and compile a firmware and put it onto the esp32-s3-box-3? Just trying to find some clear steps of how I can put an older version on it.

any help is appreciated.

I also needed this, but first my microphone didn’t work. I’m unsure what change fixed that, maybe the revert to ESPHome 2024.4.x, but I have a working version now with on-device hot word working, mic, Wi-Fi, everything working GitHub - D3SOX/firmware: Holds firmware configuration files for projects that the ESPHome team provides.

Flashed via web esp home on the first click on Configure Wi-Fi it might give an error but try again it always worked the second time for me.

2 Likes

Yes thats correct.

good evening I saw your firmware it is really great and I have no bugs everything works perfect but it is impossible for me to add in the compilation
github://jaymunro/esphome_firmware/wake-word-voice-assistant/esp32-s3-box-3.yaml@continued-conversation

While github://jaymunro/esphome_firmware/esp32-box-docks/box3-sensor-for-voice-assistant.yaml@sensor_dock.
Installs in esphome compilation works

Here is my config for my brand new ESP32-S3-BOX-3 which “works” except the wake word detection is awful. It works maybe 1 in 10 times and that’s when we’re talking directly into the mic (10cm away) quite loudly. No chance from across the room. Am I doing something wrong? Do I have a unit with a duff mic?

# NOTE: Microphone is broken when using ESPHome 2024.5.x, so use 2024.4.2 docker image for now!

# Global variables
substitutions:
  name: ha-voice-1
  friendly_name: HA Voice 1
  micro_wake_word_model: hey_jarvis

# Main package
packages:
  esphome.voice-assistant: github://esphome/firmware/wake-word-voice-assistant/esp32-s3-box-3.yaml@main

# Remove MAC from name
esphome:
  name_add_mac_suffix: true

# WiFi credentials
wifi:
  ssid: !secret wifi_ssid
  password: !secret wifi_password
  domain: .not.lan

# Bug fix for speaker not working
esp32:
  framework:
    version: 4.4.6

DragonQ

I too have a brand new box with the same exact problem, with the only difference that I have not installed esphome, it’s still with factory firmware. I came here searching for possible clues, thought to myself, perhaps if I install a different firmware I could get some ideas as to what’s wrong with it… Now I think espressif is just selling crap. My experience with customer service was… totally bizarre, namely solid denial, what you are saying can’t possibly be true, because it just can’t and that’s that. Didn’t really expect that from espressif, but here I am with a box’o’crap instead of a working product and looking for other more reliable vendors…

Perhaps rather than simply using the github package link you could try copying the code and editing the following bit (or using further substitutions), playing with the settings to see if you can get the mic working better.

voice_assistant:
  id: va
  microphone: box_mic
  speaker: box_speaker
  use_wake_word: true
  noise_suppression_level: 2
  auto_gain: 31dBFS
  volume_multiplier: 2.0
  vad_threshold: 3

Try playing with the volume multiplier and, noise suppression and vad threshold. Having said that, mine isn’t great either.

FYI, copying the code doesn’t achieve anything, you can override those values after including the package.

I have messed with the volume_multipler and vad_threshold a bit but they don’t seem to help.

1 Like

Which is why I also said:

1 Like

I do have another unit to try so if that has the same issues then I think I’ll have to sadly park this as “not even ready for early adopters”.

Maybe some updates in a few months will improve things but it does seem odd that videos exist of people using this hardware seemingly with ease.

EDIT: Good news, the second unit I bought seems to work way better than the first one, despite both running the same software (same YAML except device name). 3/3 wake words recognised so far, all from a metre away.

I will try to return the first one as faulty unless the shipping is prohibitive, in which case I’ll keep it as a device to play with.

Mine works very well at a distance of about 5m.
Have you removed the foil from the display and microphones?

Mine came with a plastic film over the screens (which I have removed), nothing covering the mics (unless you mean that single film covered both).

I have 4 of these, I stupidly bought all at once. They all suffer from the same problem you’re describing. I see people say the work well at 5m and so on. Maybe a batch of them are bad? But I doubt it. Good mic arrays are expensive, and this doesn’t seem to have it. I’ve shelved them.

Hi all, I received my Box 3 a couple of days ago and I also have the low volume issue. I tried a couple of different YAMLs posted here but cant get it any louder. I am guessing that we need to wait for the volume multiplayer PR to make it into the main firmware?

I like “undecimo” keep getting these warnings about missing initializers for the i2s driver config. So far I have made 8 attempts and all have failed. Everything works fine with the stock ESP Home version with the exception of the levels of the mic and speaker. I can’t seem to find any information on these warnings any where else either.

I managed to get 2 crashes yesterday, both seemingly while it was sorting out TTS because it did the action both times but didn’t play the response speech either time. Had to reset the box both times.

Is there a way to see logs without having the ESPHome log window open all day?

Hi,

I tried searching but it seems like I am missing something.

Is it still the case that we can’t use both media player and voice assistant at the same time ?

VA works great ( with the no audio response fix ), but I can’t find a way to tell HA to play an audio notification on the s3-box…

Correct, voice assistants still do not show up as a media_player entity.

1 Like

Hi,

Just got an update for esp-32-s3-box-3, but my microphone still does not work or at least the s3-box-3 is not responding to “OK, Nabu” command…

1 Like