ESPHome, compile error

But that (BT) shouldn’t be a problem when doing OTA, since then esp is in programming mode and it doesn’t execute regular program, consequently it doesn’t use BT… right?

And how is your mileage? Already tried to activate the safe mode and just run the ota then? For me that always worked…

Made no difference on the two devices I used it on. According to the ESP docs, all ESP 8xxx chips default to Safe Mode. I couldn’t find about ESP32, but I have very few of them here.

Apparently, I am the only one here who has a number of ESP devices that will not connect to WiFi since updating to ESPHome 2024.1. (Or later. I test every new release of ESPHome to see if the issue is fixed). If I compile the device with ESPHome version 2023.9, WiFi works just fine.

So, I repeat my last question on this subject. Am I the only one seeing this issue?

Any particular reason why you created yet another thread instead of using the others you created in the past months?

1 Like

Or just install it on another machine (windows, linux or mac or docker):

Note that this requires a physical connection to your ESP device, at least the first time.

Another option is to use you RP to generate a minimal config with just web/ota, and install the locally compiled binaries from there using the web interface:

1 Like

I hadn’t thought of that, but wouldn’t the application on the PC (installed by pip3 install -U esphome) be the same as installed as the add-on? How would that make any difference about connecting by WiFi?

But, I will pursue that.

BTW, slightly off-topic- when I run the dashboard (esphome dashboard \), none of the devices present as “online”. Any idea why?

When I click on “visit” to open the device’s webpage, it connects just fine, and I can do an OTA, so it is online.

If you’re HA host is a RaspberryPi, it would make a difference; it doesn’t have enough resources to compile (and your PC will)

You mDNS is not working properly.

Resolution, either use fixed IP, or add you local dns suffix in your esphome’s wifi section in yaml:

  ssid: !secret wifi_ssid
  password: !secret wifi_iotpw
  domain: .domain.mine

Also note that the addon is only required to compile your binaries; after that you can just shut it down;)

Doesn’t work.
Here’s what I did:
On the PC, ipconfig /all shows no local DNS

Windows IP Configuration

   Host Name . . . . . . . . . . . . : River-2
   Primary Dns Suffix  . . . . . . . :

What do I set this to?

Incidentlly, the add-on has no difficulty finding btest.local

It is the DHCP server in your network that hands out DNS server details and this DNS server deals with (local) domain-names (which is most likely dealt with in your router).

I also hand out fixed IP’s ( due to address reservation), meaning I can reach all my local devices by using their <reservation-name>.domain.mine

The latter is not required, as the DHCP server should normally hand out the domain suffix to be added (which wouldn’t work when using static IP’s, hence you can add it manually too)

Which results on my W11 machine using ipconfig /all as:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : IA-CMQ4337N1Z
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : domain.mine