ESPHome no longer getting data after the latest update

Hello, after the last update for ESPHome most of my sensors seem to be no longer working. I use them to collect data from some Xiaomi LYWSD03MMC temp/hum sensors. If I check the logs, it goes to scan but nothing is showing up after that like it used to.

I am wondering if I missed something about the update that I needed to do. I checked the github page but I didn’t see anything.

Is anyone else having this issue or know what I may be missing?

what was the the version running before and what is running now (latest is at the moment is 2023.6.4)?

mind to share your logs with us?

Consult the breaking changes in the change log. When skipping updates all the missed breaking changes need to be taking into account

I got it working by adding some code to what was there. One of my sensors had it but the rest didn’t. After updating and installing the update it seems to be working again. Here’s what I added:

# Enable Bluetooth scanning for this ESP32
    active: true
    interval: 1100ms
    window: 1100ms
  active: true

I didn’t have an interval or window entry.

Thanks for your time.

I’m experiencing the same issue: home assistant stops processing the bluetooth proxy data.

For me seems to be connected with home assistant core update 2023.7

settings the scan parameters as Scott did not solve the issue. whenever I restart home assistant it works for a cycle (5 mins?) but then it keeps reporting the same temperature and humidity.

rolled back ha core to 2023.6.2 and now its working again. not sure how many things I broke with this action :slight_smile:

relevant link of a bug report: Xiaomi Miscale stopped working with esphome since docker upgrade to 2023.07 · Issue #96014 · home-assistant/core · GitHub

1 Like

I’m having the issue again as of this morning so I didn’t fix anything. I was hoping the update last night would have fixed it but it didn’t.

Have any of you tried re-flashing serially? I know that’s been required in the past for BT Proxy and wonder if a combo of factors is requiring this again for some reason?

In my case I haven’t upgraded HA yet as I’m out of town, but have a number of BT Proxy devices so will be watching this closely for when I do.

the ticket I was referring to is now closed. here
The issue is solved with ESPhome update.

Did you guys have any opportunity to test the updated release ? :slight_smile:

I just flashed all of my BT Proxy devices in the last day or 2 and haven’t had any issues (ESPHome 2023.6.5) that I’ve noticed with any BT devices not showing up.

Yes, mine is working now.

Feel free to mark the thread as :white_check_mark: solved