Esphomelib - library to greatly simplify Home Assistant integration with ESP32

mqtt
esp8266
Tags: #<Tag:0x00007f2043a39e58> #<Tag:0x00007f2043a39a98>

#82

I’ll give it a try ASAP!


#83

@OttoWinter I have 2 magnetic reed switches connected to 2 pins and set up sensors using esphomeyaml in HA for garage door open or closed. I see that the sensors go unavailable frequently and come back online. See pic below. Is there a way to resolve this?


#84

Jep, that’s a known problem - and I don’t know a “real” solution to it. Somehow some ESP8266 like randomly loosing the WiFi connection and not being able to recover from it.

A few work-arounds that can help:

  • Use the latest arduino framework version (see this) - something in the low level IP stack (short lwip) seems to be quite broken in older version.
  • Play around with the MQTT keepalive option. For me, on some nodes reducing this value has helped, on others increasing it helped. I have no idea why :confused:
  • (Apparently, the “cheap” ESP8266/NodeMCU boards are much worse at this. Probably something related to them having a worse WiFi antenna.)

#85

@OttoWinter Ok thanks will try those option.

Do you have any idea of adding RF devices? Here is a link to a program.


#86

Yes I will support RF signals quite soon. The sending part is now more or less done with the IR Transmitter component (RF signals are really nothing else than a modulated signal like IR). I only need to add support for all the protocols now and create a RF receiver to sniff the codes.


#87

Looks very good so far. I saw your note in the docs “In the future, this integration will be expanded to support reading RSSI values and hopefully support lots more devices like tracking smartphones and reading temperature values from BLE sensors.”

I’d love to put an ESP32 outside to drive a drip irrigation valve and be able to read (Bluetooth) miflora values and publish it on MQTT for HA to use.

Any idea when reading BLE sensors will come in?


#88

Yeah sure it’s on my list, but that list is quite long… :wink: The problem is that I don’t own any BLE sensors (which send temperature values) and they seem quite expensive. Do you know of any cheap BLE-enabled sensors (~10$)? I’m thinking of maybe buying one as BLE is an interesting standard


#89

The Miflora is a good device to use as an example. It’s fairly cheap also ~10-15USD.


#90

Close enough to 10 (if measured in euros :slight_smile: )
http://s.aliexpress.com/IZJVNfUB


#91

As @Landrash said, Miflora is very popular among the Home Assistant crowd, and runs about 13 USD.

https://www.aliexpress.com/item/Xiaomi-Mi-Flora-Monitor-International-Version-Digital-Plants-Grass-Flower-Care-Soil-Water-Light-Smart-Tester/32861409524.html


#92

Thank you! Just ordered one from eBay (I’m not a big fan of AliExpress) and will try to add support for it when it arrives - Gotta say that one @Petrica posted really looks quite dope (from a design perspective). So I’m already excited to have it arrive :slight_smile:


#93

@OttoWinter is there any chance of including control for digital LED’s? I found this earlier today as linked from another thread on this forum and thought it would be a nice addition to your awesome work to have digital LED control since the NodeMCU’s make such a neat little controller for this type of thing


#94

You mean individually addressabld lights like WS2811 or neopixel rings? See the FastLED lights https://esphomelib.com/esphomeyaml/index.html#light-components


#95

yep, thats what I was thinking of… you already have it sorted, although to have more effects would be sweet, any chance of including these? (I’m just now reading up on how to do this from your page but it seems way above my skill level)


#96

Man, This Thing is Great.
You have no Idea how much easier it has made implementing home automation.!! Actually, I’m guessing you do :slight_smile:
I have a small Issue tho. The OTA update wont work using the Hass.io web interface. It tries to upload to sensorname.local . I have an internal DNS namespace called internal.local (imaginative I know).
The HASS Server quite happily resolves sensorname.internal.local but it cant resolve sensorname.local.
I tried to Cheat and named my sensor something.internal, so then it tried to connect to something.internal.local but you cant have a fullstop in the sensor name.

Any idea’s on where I can make the software append the correct DNS suffix?

Thanks


#97

See the domain parameter of the wifi: section courtesy of @HeMan :slight_smile: https://esphomelib.com/esphomeyaml/components/wifi.html

wifi:
  # ...
  domain: .internal.local

#98

Thanks,
Works perfectly :smile:


#99

@OttoWinter my code is:

esphomeyaml:
  name: aaaa
  platform: ESP8266
  board: nodemcuv2

wifi:
  ssid: 'Casa'
  password: 'SECRET'

mqtt:
  broker: '192.168.1.85'
  username: 'username'
  password: 'password'

# Enable logging
logger:

ota:
  password: 'SECRET'

And when i click upload… i have this error;

image

How i can solve?


#100

Hi Rodolfo,
Loos like you had the same error I had. you need to setup your domain Information. See the above post by myself and Otto.


#101

@knottyau75 hi friend… so its like a:~

wifi:
  ssid: 'bla bla'
  password: 'bla bla bla'
  domain: .internal.local

???