Everything broken in 0.50.x

Hi all,

flawless upgrades up to this point but I now can’t get past 0.49.0

When I upgrade like this…

sudo pip3 install --upgrade homeassistant

nothing works in 0.50.0

the logs fill up with this sort of thing.

ImportError: No module named ‘phue’
ImportError: No module named ‘speedtest’
ImportError: No module named ‘xmltodict’

I go back to 0.49 to fix.

Pi3 if it matters

Be really grateful for any help, not sure what to do, stuck at 0.49.0 for now.


You are running hass as root?

as user pi by the looks…

[email protected]:~/.homeassistant$ ps aux | grep hass
pi 665 13.3 5.0 223800 47660 ? Ssl 13:54 0:28 /usr/bin/python3 /usr/local/bin/hass

Most people run HA in a virtualenv. If you did, then sudo is not appropriate and you should just switch to the virtual environment and run the command without sudo.

If not, I think you need to describe your installation method, because otherwise we will be playing a game of 20 questions for a while.:slight_smile:

sounds like i might be best to blow out the existing install and reinstall in a virtualenv.


maybe its the same error. I solved this by setting permissions to the new deps folder.

gawd - i’ve blown out my existing install and using the virtualenv method…

like here…

now two problems…

  1. starting it at reboot
  2. i can’t even find the .homeassistant folder to add back my config

don’t really understand how to enter/exit the virtual env to config stuff.

double eeek.

sorted the autostart by following this…

Assuming you have set up the directories the same

$ source /srv/homeassistant/bin/activate

will start the virtual environment, and

$ desactivate

will exit from it.

You only have to do this when using pip (or starting HA manually). Editing the config file you can do without the virtual environment.

That’ll be in /home/homeassistant

(or possibly /srv/homeassistant, I’ve never used the manual install, but the All In One)

Thanks Tinks,

Works a treat. Appreciate the extra explanation.

I’m on 0.50.2 now in a virtual environment and things seem to be going fine.


Thanks for this, helpful