Failed to call service media_player/turn_on

New to HomeAssistant and just setup a server using the VMware image. I’ve successfully added an LG WebOS TV and can change inputs, volume, and power off with HomeAssistant. When I try to turn the TV on, however, I get an error in the lower left of the screen: “Failed to call service media_player/turn_on. Service not found.” If I go to Developer Tools > Services, I see that service listed. When I select it, select the TV as the entity, and select call service. I get the same error. I’ve tried restarting the server and Configuration validation doesn’t give any errors. Running HomeAssistant 0.92.1.

1 Like

Have you done what’s recommended in the documentation for WebOS Media Player?

WebOSTV Turn-on Action

It uses Wake-On-LAN to send a ‘magic packet’ to your TV’s MAC address thereby causing it to turn on. However, this technique only works if your TV’s Ethernet connection is hard-wired not WiFi.

This thread shows how others are using Wake-On-LAN to turn on their WebOS TVs.

Thanks for the links. I tried several different things, but I think what did it was that I had missed adding the wake_on_lan line above the Media player config. It was in the example in the documentation but my brain missed it. I also put “mac” in quotes. It’s working for me now.

wake_on_lan: # enables `wake_on_lan` domain

# LG WebOS TV Setup
- platform: webostv
  name: ChurchTV1
  timeout: 15
  filename: webostv1.conf
    service: wake_on_lan.send_magic_packet
      "mac": "A8:23:XX:XX:XX:XX"

Bro thanks!

I also totally didn’t see the first line!


Just want to add that I use the tv only with wifi and the WAKE ON LAN also works

1 Like


My wake on line has always worked but down the line it stopped.
I have the following error:

Failed to call service media_player/turn_on. Unable to find service wake_on_lan/send_magic_packet

Once i turn on the tv by the normal remote, i have full access to the tv through HA including turning it off.
my configuration is

  - platform: webostv
    host: !secret webostv_host
    name: Living Room TV 
        service: wake_on_lan.send_magic_packet
            mac: !secret webostv_mac

Thanks for this post, I was going crazy figuring out why it didnt work. Just a simple line

Did the Mac have to be separated via : or via - as described here or didn’t it matter?

So I`ve been going crazy over this! changing indents, adding and removing " in the section for mac address. So I found the solution after searching the web. The wake_on_lan service is not natively active in home assistant, you need to add wake_on_lan: to your configuration.yaml


You saved my day sir! I have been digging this for hours and surprisingly no one’s ever mentioned this.

There really isn’t any reason for you to hide either the host or the mac address.
The host is most likely something like (meaning local to your home), so it’s not really a secret.
Your TV’s mac address is unique in the world, but I don’t see what anyone else could possibly use it for.

That was the key for it to work.

Tank you!