Failed to login through LAN to HA while Internet was down (DuckDNS being used)


I just had the internet down all day and could not login to HA all day from various devices.

  • Failed to login from my tablet and mobile phone running the Companion App (both Android)

    • All were logged onto the local network
    • HTTP & HTTPS addresses
    • tried the duckdns address as well as the IP address of HA (IP Address is static and assigned in the router), with and without :8123
  • Also failed to login from my laptop through google chrome trying all the various combinations above

  • Internal URL was configured same as external ( in the companion apps

  • Router is a TP Link AR2800 which apparently does support Nat Loopback

  • Even though I tried all different variations to login, I am still under the impression that the single URL (duckdns) is all the is needed to login both externally & locally.

  • I also have mostly local devices on my network (Zigbee) and HA also failed to start the automations for these while there was no internet

    • This could be because while I was trying to troubleshoot today I did unplug the power to the Pi hoping that may solve the problem of not being able to login, however, I believe this may have made it lose its clock (NTP setting?) which it then could not reset once it started again due to no internet?

While going through a setup tutorial video (by everythingsmarthome - Home Assistant Remote Access for FREE - DuckDNS + LetsEncrypt + Single URL) I noticed that my setup had a line in my config.yaml that was not written by the guy doing the video. It was marked as “DEPRECATED” in the config file as per below.

In this same video tutorial it advises that other tutorials state that you should also forward Port 80 to 8123 via TCP protocol, but that this was not needed. When I tested this by deleting this port forwarding in my router, HA started acting quite weird, would not load some dashboards and would not follow some commands such as restarting, etc. As soon as I reinstated the Port 80 forwarding rule it started working fine again. I tested this twice to make sure i got the same result.

Please note that I must have followed aother online tutorial when intitally setting up the whole duckdns thing which is why I had the extra line in the cofig/yaml file and forwarded port 80.

Just asking a few questions:

  1. Could this DEPRECATED line be the reason that I could not log in locally with no internet access?

  2. Even if it is not the reason, I am just asking for advice as to if I should remove this line anyway as I am quite new to HA and am worried that if I delete this line I might lock myself out of HA.

  3. Would the DEPRECATED line and port forwarding Port 80 be interlinked somehow and deleting the DEPRECATED line also means I could delete the Port 80 forwarding rule?

Sorry if my explanation seems convoluted or I have used some wrong terminology as I am only a begginer!

Take a look at the NGINX Add-On. I believe that’s what allows you to access your HA instance internally using the IP while using the duckdns URL externally, even when your ISP is down.


Thank you for this guidance. I have installed NGINXit and it now appears to be logging in from Local when i unplug the internet to test.