Feit Smart Bulb

Hi All,

I just picked up a 2 pack of Feit Smart Bulbs from Costco (~25$) Link. I don’t see anything in Home Assistant for them, has anyone had any luck with getting these into Home Assistant yet?


I picked up a pair yesterday, and managed to get them to work with home assistant without too much difficulty, though there were some ‘hiccups’ I have yet to fully understand/explain.

The Feit wifi bulbs are built on the Tuya platform, so they can be added to home assistant through the Tuya component. As per recent discussions (for instance, this one), I had to specify the platform on which I created an account (either Smart Life or Tuya) to get it to work.

A few further wrinkles I experienced, and I’m not sure whether these complications were due to my setup in particular or not, was that I could not get the Tuya component to load using the ‘tuya’ platform, and had to use the Smart Life app and platform. Secondly, when adding the bulbs to any of the (iOS) apps other than the FEIT-branded one, you are unable to control colour or colour temperature within the app. Luckily, this issue is limited to the app, and full colour and colour temperature controls are available through homeassistant. Finally, I was unable to add the bulbs to any of the apps through the ‘normal’ mode (fast-blinking), and had to add them in AP-mode (slow blinking – instructions for setting them to this mode are in each of the mobile apps). This hiccup might be because I use a mesh wifi system, so others may or may not experience this issue.

Hope this helps for anyone, who, like me, was wondering whether these bulbs could work as a ‘finest-cheapest’ expansion to a home assistant lighting system, and could be made to work with HomeKit.


Thanks setlursh!

I also had to use the tuya component (I was able to omit the platform parameter), and I went straight to AP mode for programming)

All is working for me. Thank you!!

Picked up a 2 pack of these at Costco (Canada) for 40 CAD. I agree these are really good value for money and seem to work flawlessly with the native (Feit) App. I got these working with Home Assistant through the Smart Life app and Tuya component. I can adjust Brightness and Color but the Color Temperature slider doesn’t work in Home Assistant. Anyone else experiencing this issue?

Can confirm, the color temperature slider does not function.

I am using Feit app and the lights are working perfectly in non AP mode. But when I am trying to add these lights in Home Assistant, I am getting error like below:

Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/homeassistant/setup.py", line 154, in _async_setup_component
    component.setup, hass, processed_config)  # type: ignore
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/tuya/__init__.py", line 60, in setup
    tuya.init(username, password, country_code, platform)
  File "/usr/local/lib/python3.7/site-packages/tuyapy/tuyaapi.py", line 44, in init
  File "/usr/local/lib/python3.7/site-packages/tuyapy/tuyaapi.py", line 68, in get_access_token
    raise TuyaAPIException(message)
tuyapy.tuyaapi.TuyaAPIException: Get accesstoken failed. Username or password error!

Here is my configuration:

  username: xxxxxxxxxx
  password: 'xxxx'
  country_code: 1
  platform: 'tuya'

Could you please let me know if I am doing something wrong?

Hi chanchal,

Here is what I had working my config.yaml (from HA ~v0.8 - current)
# Tuya (Feit Bulbs)
username: !secret tuya_name
password: !secret tuya_password
country_code: 1

Also, as of about ten minutes ago I stopped using the tuya component. This was horribly slow to respond from the HA interface. I found this video explaining how to OTA update to a Sonoff -Tasmota firmware for the chip in the bulb.

-> I OTA updated the bulb
-> flash the core 2.5 firmware from here (sonoff-minimal first, then sonoff.bin) for the 1M flash
-> applied the template to the bulb from here
-> set the commands from above to flip the RGB -> BRG color mapping
-> followed(ish) the instructions here to use MQTT discovery in the sonoff firmware and connect it to HA.

this isn’t the best instructions for what I did, but is should get you pretty far! Feel free to post again with questions and I’ll answer when I can!


@ErichO Will existing Feit mobile application and Google home integration work after this OTA update of the bulbs?

I picked up Feit Electric Color Changing WiFi bulbs in 2 packs at Costco as well and was able to get them to work with HASS. Reset the bulbs and set them up in the Tuya app rather than the Feit Electric app. When you set them up, you will get a warning that the bulbs don’t work and that you have to update the app, but ignore that warning. Now set the Tuya module up in Hass and they should all work. They worked for me, however the color temperature slider was glitchy. I was still able to change the temperature with the Call Service function though.

All the best,
Jack D Knight from Loopdy Loop

@chanchal1987 sorry for not responding! As soon as you do the Tuya convert, the bulb does not connect to the Feit/Tuya app. The bulb runs on Sonoff/Tasomota firmware and is entirely local.

You might have to use the ‘Tuya Convert 2’ process, because the original process has been blocked on the blubs current firmware. If you are interested more, look up digiblurdiy, he does a great video with the old ‘Tuya Convert’ on youtube. Digiblur Livestream

Is there anyone who knows python able to convert the Tuya component to be a Feit one. I’ve had a look at the code but am not very familiar with python.

I use tuya-convert and flashed them to esphome.
Needs the dev version though to get the LED driver working.

This is my config, but keep in mind that I use them as a pure white bulb, no RGB (although I could)

  data_pin: GPIO14
  clock_pin: GPIO4
  num_channels: 3
  num_chips: 1

  - platform: sm16716
    id: output_red
    channel: 0
    power_supply: rgb_power
  - platform: sm16716
    id: output_green
    channel: 1
    power_supply: rgb_power
  - platform: sm16716
    id: output_blue
    channel: 2
    power_supply: rgb_power
  - platform: esp8266_pwm
    id: output_cold_white
    pin: GPIO5
  - platform: esp8266_pwm
    id: output_warm_white
    pin: GPIO12

  - platform: cwww
    name: feit_a19_rbgw_01
    cold_white: output_cold_white
    warm_white: output_warm_white
    cold_white_color_temperature: 6500 K
    warm_white_color_temperature: 2700 K

  - id: rgb_power
    pin: GPIO13

Is there any way Home Assistant can support native Feit RGB bulbs without altering the firmware?

@chanchal1987 yes. I think you are most of the way. From the error you posted, you seem to have the wrong username or password in your configuration.yaml file.


platform: smart_life

thats what fixed my issue as I was using the smart life app

I’ve used the Tuya Convert 2.3 instructions at https://www.youtube.com/watch?v=dt5-iZc4_qU to flash Tasmota firmware on my bulbs and used https://www.youtube.com/watch?v=KOg5qwO3Rh4 to set up autodiscovery of those bulbs. All works well until I try to adjust the color through homeassistant. When I click on Red, I get a blue color. It’s as if I need to click 120 degrees counter clockwise from the color I want to get the intended color to display. Has anyone run into this and is there a fix?

These bulbs I believe are in BGR color order. You might want to check out setoption37. Pull up the console on tasmota and I believe the command to enter is setoption37 54.

That worked on my feit bulb.

Your memory is impeccable. Nice fix!

Bought new bulbs and made the mistake of connecting them to the Feit app. I’m not sure if it was that action that caused a firmware update silently or if it was already patched ahead of time, but the above instructions no longer work. Glad I only have 2 of those.

All the Feit stuff has gone to a different processor, so Tuya convert no longer works.

1 Like