Fibaro Double Switch Showing as one switch

I had this set up right for a while but it seems an update broke it along the way.

My dual switch now shows up as one switch in HA.


It used to show up as


In OZWCP it shows up as a dual switch with a toggle for each switch. I can’t seem to replicate this in my config.

Anyone know how to fix this?


What model is it?

Have you tried just re-adding it (don’t worry about deleting it) just put ha into inclusion mode and press the button three times


hmm really dont want to do that if I can avoid it, it’s in the wall behind the switch and it’s a pain to get it back in when i take it out.

Model is FGS 222

So have you got a switch connected to S1 that you can use? Cause you can use that instead of the “B” button

I completely forgot I could do that, it’s been so long since I set it all up!

Yes, I will try that out, thanks for reminding me :slight_smile:

1 Like

I have the same problem with mine… tried re-adding many times but only get the one switch

TL:DR: Update OpenZWave Control Panel to latest version

I’ve been looking into this and have a solution. First I found that my FGS-221 was being added as a FGS-222 in open zwave control panel.

Looking at the fgs222 config xml (that came with the all-in-one raspberry pi installer), it is very different from the fgs221.

Next I check the latest version on git and I saw it looks different again. A key feature missing was parameter 7 which makes the second switch a switch.

However, the latest config xml on the OpenZWave Control Panel git does have parameter 7.

So if you can update the config folder in /srv/hass/src/open-zwave-control-panel/ to the latest version in the git here you can recreate your zwcfg_XXXXXXXX.xml file to work correct with home assistant.

On a side note, it would be good if the fabric installer could do a git pull of the latest OpenZWave Control Panel release (keeping the specific hass settings).

1 Like

Is there any news on this topic? I recently updated my Home Assistant, which was on version 0.30 at that point. I was aware about some breaking changes in version 0.31 (indexing the z-wave devices) but besides the indexing I went into the same problem that’s described here. The 2nd switch of my FGS-222 went away.
Also my Fibaro motion sensor went away (but that’s another topic).
Is there something I have to do to get it work again or is it just about waiting for a bugfix?

I think I updated the config folder but not sure how to recreate the zwcfg file; as such I still can’t access the second switch on the FGS-222

I got a Z-stick a week ago and now trying to include my Z-wave devices. I got stuck when trying to add my FGS-222. If i open the OpenZwave control panel I see the device and can control both switches without any issue. However in home assistant i only see 1 switch and it is oddly named switch.__switch_4_0

@skptic: what do you mean by [quote=“skptic, post:7, topic:5688”]
recreate your zwcfg_XXXXXXXX.xml

I updated libopenzwave and openzwave (/libopenzwave-0.3.1-py3.4-linux-armv6l.egg) by compiling the actual git source. Then I ran ozwcp an removed my fgs-223 and reincluded it. Still it appears in HASS only as one switch and does not react to switching physically nor by HASS…

Can you lead me into the right direction?

I’ve read a lot of threads about similar problems. At one point someone said you have to restart. I hate restarting. But did it. I can’t believe it but it helped actually! No clue why a reboot should change anything… Perhaps the z-wave usb stick needed some power off…

So for me the problem was solved by updating to newest openzwave, then remove and reinclude the fgs-223 and then reboot my raspberry pi.

I had the same issue and the only thing that fixed this for me was to open up the OpenZwave control panel and rename the device, this somehow fixed it for me and I finally got 2 switches for my Fibaro in HA.

I had this issue today. And indeed, stopping HA, removing the z-wave usb stick and inserting it again, start HA, fixed it! Argh! It’s quite hard to build confidence in Openzwave, imho…

Spoke too soon…the best I can get with (re)adding the node, is this:

Notice the two switches, but only one has a full name. Whenever I restart HA and/or rename the node the entity called “switch.Switch” just disappears (along with a few others). And I can no longer control my switch port S1. What a mess, no idea how I ended up here. It was working fine yesterday!

Where you successful at last?

Just sorted mine (remembered we had a power cut around the same time the switch went missing),
cut power to the Fibaro (at circuit breaker)
re-powered Fibaro
both switches back working :slight_smile:

This also happened to me (0.68.1) when I tried to add an FGS223.
It showed up twice as in the screenshot. I was able to solve it by deleting entity_registry.yaml and restarting Home Assistant (I found that solution in another thread (ZWave Double Switch Naming). I have not noticed any negative side effects and the switch is showing up correctly now).