First Installation slowed down extremely, second as well

Hey guys,

I am currently getting started with HA and facing some general issues… I installed HA from the OVA file in my Virtual Machine Manager on my DS920+. 2 Cores, UEFI, 32GB HDD.

I did basic setup, installed Node-RED, vscode and some integrations such as KNX, HUE etc. I did some first Node-RED flows as well.

Suddenly, HA became slower and slower and totally unresponsive… I tried around and decided to start over. I did a fresh install, restored from my backup and got rid of some minor important integrations for now… but again, the system is quite unresponsive. When I change a switch in my dashboard, the node-RED flows sometimes take up to 10 seconds to react.

What I am now struggling with is to get hands on the actual issue… I see some messages in the log, but cannot really deal with them. Is there some possibility to monitor the integrations or running processes for bad performance or high resource consumption? I really am missing on how to get to the point here… Also, when e.g. starting the vscode addon, the startup takes 15 minutes or so…

Besides, whenever I reboot the HA instance, I am ending up in the emergency console needing to type login. I’d expect the system to start up without any requirement to interact with the CLI… If I am out for some days and the Diskstation or HA instance restarts for whatever reason, this would be something to hardly explain to my wife and children :slight_smile:

I’m grateful for every advide on general tracing of performance issues etc.

Best regards and thanks to all of you!

Let’s start with the log. What does it say. Until then we’re just guessing.

1 Like

Hi Nathan, thanks for the quick response. Which log would you require? I know there’s a bunch of them, but which would be the best fit for such general problems? Supervisor? Core?

In addition to NathanCu’s excellent recommendation, you can also refer to the Troubleshooting section of the The Home Assistant Cookbook - Index. In particular, this guide may help: 2024.5+: Tracking down instability issues caused by integrations.

1 Like

Here is my homeassistant.log: HA Log -

HA is basically running, but I see strange behaviors every here and there… delayed Node-RED flows, error messages when tryng to display addon in sidebar etc.

General Problems ? And you said you are currently started with HA ( Does this means you are new to HA ? )
Beside the core-log Multiple repeatedly Errors, And your Node-RED delays, have you tried to fix any of these multiple “problems” ?

If you are new to HA( As You claim ), i suggest you take it “easy”, and bit by bit, then im sure you’ll notice when and why it becomes to overwhelming for you.

I am new to HA and trying to take it easy, but it is really hard to find out where to start. I see some errors in my logfile, yes, but which ones are the ones that really point to the problem and which are the ones that might be follow on errors?

I am really willing to dig into, please don’t get me wrong (maybe it’s a language issue as well, I’m not a native speaker). If I would have an idea how to identify the exhausting integrations, I would disable them piece by piece. The things that I could clearly see in the log (e.g. FiatChamp) are inactive now, but new messages start to pop up.

I’d also not be afraid of doing another fresh install, but I’d like to get to the root cause of my issue, because otherwise I’d either make the same mistake over and over or just restore the mistake from a backup :wink:

And who says you didn’t already ?

As i said, you got MULTIPLE errors, and yes i noticed some car-integration, beside MQTT etc.
Most peculiar was the first errors thou, i’ve never seen those “general issues”

Sounds like your best choice, AND don’t apply a backup, from an installation you had problems with ( as was what you say you did initially ,a Mistake you easily can avoid )
Then go on and install your integrations one by one, configure them, make sure the run properly, checking your log-files, before and after every step ( every restart/reboot ) , Ofcause initially, so you get familiar with your logfiles (vanila vs extreme customized)

The NAS only have 4Gb as standard and you try to run HA on it, which prefer 4Gb alone when using addons.
Did you upgrade the ram?

Yes, running on 20GB of RAM, this should not be the bottleneck.

@boheme61 For sure, I can just start over. But honestly, this is not my demand here. This installation is really without any bigger value… But I want to really understand what went wrong and get used to narrowing down errors to their root cause I can fix.
Just imagine I’d be one year ahead, with hours and hours invested in my setup and then facing a comparable error… Then my go-to-solution will definitely NOT be to start over, without restoring any backups. I think it is important to not only follow the happy path. This is the only thing I’m pointing to here… If this is not your approach, ok for me. But maybe there’s someone else out there who might help me out with some hints on identifying and fixing such issues.

What I did in the meantime: Deactivated FiatChamp and removed the device from MQTT. Put debug on startup entries as descibed in “Integration blocking startup” in 2024.5+: Tracking down instability issues caused by integrations - Community Guides - Home Assistant Community (, but this did not really provide valuable insights.

Nevertheless, I still see random errors such as error when changing vscode addon configuration (sidebar switch). The only things I see in the home-assistant.log at that time is an error because there was a timeout. That is it. But for identifying the timeouts cause, I’d need to know which process or integration eats up resources…

My Question is Why ?, why start over with the same installation you just decided to wipe ? , sure if that back-up was prior to your issues, i would have understand, but it sounds like you actually don’t know, and you obviously haven’t “followed” your systems health after each installation/configurations of your add-ons and integrations.

If you want to learn about HA, and the various integrations, don’t just “pump in” until it breaks

I wouldn’t call that a “Happy Path”

Install in a controlled manner getting acquainted with the system and it’s component , is a Happy Path, and it will give you the means/knowledge you will need later …

Because I did not find a description of how the backup works. Does it just restore everything what was there, or does it hold an inventory of the installed packages and re-installs them from their sources when restoring the backup? If this guardrail is unknown, I do not think that I have to be blamed for giving it a try.

And frankly speaking, the way that HA behaves at first setup supports to “pump in” stuff, because the discovery basically already does this… But I see your point.

As is(was) yes, obviously if there in the meantime have been released new versions of specific components you will be notified in HA or HACS, after re-start

All your settings etc is restored to “previous” state, and the various HA components, and your specific integrations/device etc , to the time when the back-up was created ( consider it as an “image” of your system )

I don’t blame you, but i do consider it a “mistake” :slight_smile:

According to the specs only 8gb of ram can addressed.

Officially, but 20 are recognized and used up fine.

There are even compatibility lists on larger modules.

Okay, then it should not be ram, unless you limited it in the VM settings. :slight_smile:

I just started over and created a fresh VM in Diskstation Virtual Machine Manager with the recommended settings, imported the OVA file and booted the machine. The preparation run through, I clicked through the few steps of the onboarding assistant and after that, I found me facing this message:

Screenshot 2024-06-08 061330

Countdown always restarts… I opened the VM’s screen through the virtual machine manager and found this:

I did not use any backup, anything else from my previous setup… I ran extended S.M.A.R.T. test on the drive which found no errors.

I used the most recent .ova file from the official home assistant alternative installation methods page.

Any ideas? :frowning:

That could indeed be the cause of your previous issue also , i strongly suggest using another disk, SSD if possible

Ok, supporting my guess as well… I really could not figure another explanation anymore… Just ordered an SSD… In the meantime, I’ll give it another try with the current one… deleted everything, even up to the DS storage pool for that drive… Maybe I can copy over the VM then, will see. Or I start over… again :smiley:

1 Like

Quick update: While waiting for the SSD to arrive, the volume where my VM’s are running on in my Diskstation went from “Healthy” to “Critical”, recommending immediate replacement of the drive…

So it is indeed a hardware problem.