Fitbit integration stopped. Please help me

In the FitBit Developer Portal. See the integration’s documentation for more details.

I have read the documentation over and over. I admit, I could be missing the key information… And I sincerely would truly appreciate pointing out my error, as this has been working before @allenporter added it to work within the UI. It seems no matter what I do, I get the same results. Additionally, Invalid redirect_uri parameter value. From this,

Directly to this


Can anyone tell me where I am wrong?

This URL →, which you need to copy-paste exactly as it shows, is only for the Redirected URL box.

All other fields, including Organization, you need to enter your personal external HA URL, not this URL

1 Like

That worked for a non-google migrated account, thank you!

Maybe my trouble is elsewhere?

Did you follow precisely every step of the integration? If you follow each step exactly it should work. If you are unsure if you didn’t correctly followed a step, you can ask us.

Yes. I did follow the steps, and provided in depth screen shots earlier.
Included in the posts were specific errors that still have not been acknowledged.

I don’t think that works on my system…
And I think the URL in question is because it

Thus, “https: // gives the error Invalid Parameters given.

And what about your duckdns address, are you using port 8123 to access your Home Assistant instance on your network? I don’t see 8123 in all your URL boxes except which shouldn’t.

For local, I use http:\
Yes, I use port 8123 with duckdns. I was confused that you mentioned that I had it as part the redirect. Well that made me confused. I thought long and hard (It hurt too LOL, my memory is getting worse) about the missing piece… NGINX! I can’t remember exactly why, but, I had to use that to solve my local access troubles I had sometime back… Any way, I tinkered with settings, and all the settings and it finally linked! I believe the magic was changing https to http.

I want to express my sincere thanks to the many people assisting me here since October. @allenporter, Thank you for making the integration better by including it within the UI. @donparlor, Thank You!! for hanging with me and poking at my poor memory. Many have HA for various reasons. My assists me personally by by monitoring several things for my health. Now I am going back to the hardest failure, Alexa is no longer announcing via HA when I am in need of medical attention (Dexcom). I am now needing to reauthorize, but that isn’t working either… 1 down, 1 to go!

Thank You All!!!