Forever stuck on "Preparing Home Assistant Screen"

I’ve been trying to solve this for days and I’m at a loss. Figured I would come here for help before I give up on this completely and seek out other home automation solutions.

I have a Raspberry Pi 4B and a 32 GB SD card which I am trying to use to install Home Assistant. I am following the official instructions that are found here https://www.home-assistant.io/installation/raspberrypi.

I’ve tried both the 32 and 64 bit versions but I get the same result each time. I just get stuck on the “Preparing Home Assistant” screen. I’ve even let it run over night once, but nothing happened. I’ve re-flashed the SD card at least 6 times, but it hasn’t helped. I’ve also tried it with the ethernet cable from the Pi connected to both my router and even directly to my modem, but neither way works.

It’s just stuck in this loop (see text below). Something about an internal server error.

6 20:32:51 INFO (SyncWorker_5) [supervisor.docker.interface] Updating image homeassistant/raspberrypi4-64-homeassistant:landingpage to homeassistant/raspberrypi4-64-homeassistant:2021.5.4
21-05-16 20:32:51 INFO (SyncWorker_5) [supervisor.docker.interface] Downloading docker image homeassistant/raspberrypi4-64-homeassistant with tag 2021.5.4.
21-05-16 20:33:06 ERROR (SyncWorker_5) [supervisor.docker.interface] Can’t install homeassistant/raspberrypi4-64-homeassistant:2021.5.4 → 500 Server Error for http+docker://localhost/v1.40/images/create?tag=2021.5.4&fromImage=homeassistant%2Fraspberrypi4-64-homeassistant: Internal Server Error (“Get “https://registry-1.docker.io/v2/”: context deadline exceeded (Client.Timeout exceeded while awaiting headers)”).
21-05-16 20:33:06 WARNING (MainThread) [supervisor.homeassistant.core] Error on Home Assistant installation. Retry in 30sec

Any help would be greatly appreciated. I was super excited about Home Assistant when I first heard of it and was really eager to get it going, but this has not been a good first impression.

Have you tried using a different sd card?

That will be the next thing that I will try I think.

Just wanted to check here before I spent money on another sd card.

New SD card came in and I tried it out.

Still running into the same issue.

That is strange. I’ve found this solution fix. Maybe it will help.

Thank you, I will give this a try.

Somehow I wasn’t able to uncover that one in my many searches haha.

Just wanted to say that the solution you linked worked. Thank you!

To anyone else having this issue please try that solution!