Fullchain.pem and privkey.pem are missing

I have just installed HassIO (0.84.6), and I’m having a problem when I try to connect to HassIO trough https://mydomain.duckdns.org:8123. Works fine tith http://…


          base_url: mydomain.duckdns.org:8123
         ssl_certificate: /ssl/fullchain.pem
         ssl_key: /ssl/privkey.pem 

DuckDNS config in

      "lets_encrypt": {
        "accept_terms": false,
        "certfile": "fullchain.pem",
        "keyfile": "privkey.pem"
      "token": "xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx",
      "domains": [
      "seconds": 300

Problem seems to be that the SSL folder is empty. This folder should contain the files fullchain.pem and privkey.pem?
Can the files be stored in another location, or is there any way I can generate new files?

If you change accept_terms to true in your config does that generate the files?

1 Like

No, that did not help :frowning:

Log in Duck DNS:

# INFO: Using main config file /data/workdir/config
+ Account already registered!
Tue Jan  1 01:02:43 CET 2019: KO
# INFO: Using main config file /data/workdir/config
Processing https://my_domain.duckdns.org
 + Signing domains...
 + Generating private key...
 + Generating signing request...
end of string encountered while processing type of subject name element #1
problems making Certificate Request

Try https:// in your base url

Have tried https:// in base url to, and restarted but still no .pem files.
Have formatted the SD card and installed HassIO one more time… still the same problem.

(Installed add-ons are: Configurator, Duck DNS and SSH server).

Https:// is not a valid domain name.

I also have this in my config yaml but not sure if it’s needed?

  domain: subdomain
  access_token: duckdnstoken

I hope he had put the full URL and not just https://

No. Https:// doesn’t need to be in base URL.

I’m referring to the duckdns config. Under domains. Https:// is not a domain name.

for the domain … its not correct.

use the exact syntax

mydomain.duckdns.org” using the quotes.

Your configuration.yaml, the spacing looks wrong for ssl_certificate and ssl_key… they should be over just a bit farther to the right.

1 Like

The files aren’t being created because the duckdns config is incorrect

1 Like

Is the duckdns section still required in config yaml or can I remove that?

Duckdns component has nothing to do with the add-on. If you weren’t using hassio and wanted to update your duckdns name, you would use the component

1 Like

Oh yeah, I will remove it then, I have probably been updating my IP with 2 systems.

If you are running the Hass.io DuckDNS add-on this component is not required. The add-on will keep your IP updated with DuckDNS.

Wicked -that worked for me.