General HA / DuckDns Problems today?

Hi all,

I’m experiencing a problem with my HA. I no longer get updates from Dark Sky, Google Travel Matrix, Custom_Updater and Arlo.
It suddenly happened today.

I already tried restarting HA, tried upgrading to the latest, but no difference.
I’m using DuckDns on thios installation.

What’s weird is, I asked one of my friends who don’t use the DuckDns service and dnsmask and he don’t have any of these problems?

Some of the erros I get:

Setup of custom_updater is taking over 10 seconds.

Error doing job: Future exception was never retrieved

darksky: Error on device update!

Unable to connect to Dark Sky. HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /forecast/690238f4dca1e1cf761c9d3ffa522ecf/xxxxxxxxxxxxxxx?units=si&lang=en (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x704dab50>: Failed to establish a new connection: [Errno -3] Try again',))

Error during setup of component arlo
Failed to establish a new connection: [Errno -3] Try again


Looks like you are having general connection issues.

I would try Pinging external resources by IP and then by domain, see if DNS is working correctly.

Are any other devices on your network having issues?


Well I don’t have any other issues besides my HA. My DNS works as it should and this suddenly happened.
See another post here as well:

same here, also my spotfy, my google assistant and my dark sky not working

my supervisor logs:

19-01-17 20:51:37 ERROR (MainThread) [hassio.api.proxy] Client error on WebSocket API Cannot connect to host ssl:False [Connection refused].

DNS is domain name service. It takes something humans can read and memorize ( or and responds with the appropriate IP)

This applied in two fashions for HomeAssistant. The first and one you are more likely familiar with is the DuckDNS addd on which checks your current external IP (the address for your home modem) and sends it to ducksdns which then always redirects your duckdns domain to your home IP address.

The second way that happens constantly with every internet connected deivce is a dns request for a request to visit a website. Your computer asks a dns server (either specified by you or your internet provider) where can I find, it will respond with an IP address ( ie. The computer then sends the request using the IP address provided and everything outside your network knows how to route an IP but not a domain.

That being said. I suggested you check that you can reach external websites from within HA. I have seen the DNS setup in get broken before and this is an easy test.

Thanks for your reply and much appreciated explanation.
I have a iframe with a link inside as shown in the picture - works brilliant, so I know the DNS can resolve it:


As you can see the weather card doesn’t get the data and I just checked my api calls and I’m not near the limit.
The iframe loads fine using the domain name.

hmm, darksky is working fine for me and their status site doesn’t show and issues with the api currently.

Can you log in to the dark sky api site and below the api key is a link to a typical api call. Click it and confirm it works. If that works we can deduce that this is a hassio issue and not a local network issue.

Maybe you are on to something. I just disabled the dnsmasq add-on and now things seem to get up and running!