Home Assistant Community

Getting frustrated

#1

I installed hassbian 1.1 on a Rpi3 about two days ago. Had all sorts of issues with running the automated scripts not working. About “host not resolved” after some googling I figured out I needed to modify my hosts file. Great… at that time I was able to get samba working and able to access it using my main win 10 rig. For some reason I still had issues with open Z not working right. Then I saw that .39 had came out. Alright time to just start over. So now I clean Hassbian 1.1 as soon as thats done I edit the hosts file, then apt-get update and upgrade, then run the mosquitto, z wave and samba scripts. Now Samba is not working. I’ve tried modifiying the smb.conf file manual. but can’t get it to show up on my main computer.

I’m trying to stay calm and not completely throw in the towel. Trying to make this not sound like a rant. I am wondering why all this stuff just doesn’t just come pre configured. If your a power user and know that you don’t want it you can remove it. It seems much harder if your not a linux user or a software developer to try to get all these packages and programs working together and installed properly. Install the stuff for Zwave, have a button to shut it off, 99% of people are going to want it. Just getting tired of read walls of text and half the stuff changes with each new version of software. or commands are out dated and links broken. I am not opposed to playing around with the software, but when you can’t get anything working right it gets really frustrating. Maybe I just don’t understand the way linux works. I don’t know. I’m not knocking all the work that’s been done, I’ve seen quite a few videos and it seems like it is very good. As a guy that works 50+ hours a week and has kids I just don’t have time to sit down an spend hours trying to get the core of home assistant working properly.

If someone has a fool proof way of getting Home assistant, mosquitto, samba, and open zwave installed please point it out.

Thanks.

0 Likes

#2

Using the All In One installer will give you HA, Mosquitto and OZW, leaving just Samba, which is likely an easier challenge to tackle on it’s own if this is all new to you.

As for things breaking, this is still very much a work in progress - it’s a beta, as is shown by the fact that it’s not yet version one, and that point releases come out fortnightly. If you’re looking for something perfectly stable, that requires little time investment, then this probably isn’t for you. Instead you’re probably looking for a commercial platform.

If you’re willing to learn how to set up Samba (which I suspect very few HA users use), and accept that reading the release notes is critical because there will be breaking changes, and that using this will involve an investment of time - then maybe this is for you. In all of this you’re making a choice - spend money, or spend time.

Oh, and rather than posting “it doesn’t work”, provide details. Provide error messages, configuration files, explain what the problem is. Without you doing that, nobody can help - it’s like phoning a garage and saying “my car doesn’t run” and expecting them to be able to diagnose the fault with nothing more to go on.

0 Likes

#3

I was using hassbian image 1.1 I was under the impression that this just installed the a basic os and HA. That the other stuff needed to have the scripts ran to install it. And that is what I did. Then I had issues when I got the “can’t resolve local host”. So I thought I fixed that. But now Samba doesn’t work properly. I can get around in the file structure a little ,but there are files I’m supposed to change like the configuration.yaml that I can’t seem to locate. Says its supposed to be in the /home/homeassistant folder. Then I navigate to that folder and ls. There is nothing.

0 Likes

#4

I’ve found that just a basic install of Linux then manually installing Home Assistant tends to work a little better.

the yaml files would be in /home/USERNAME/.homeassistant

the . in front of Home Assistant is important and indicates a hidden folder in Linux.

I think a lot of people’s frustration comes from not understanding the Linux operating system more so than problems with Home Assistant itself. Brushing up on some basic Linux knowledge might actually be a better resource tool and use of your time when dealing with some of these issues. Approach them as a Linux question as opposed to a Home Assistant question if that makes sense.

All that being said, if you are not familiar with Linux you will have a bit of a learning curve to get it going the way you want. You’ll learn some new skills and have a solid product when you’re done, which I personally feel is worth it in the long run for most people. If time is an issue or you have no desire to do all those things, I don’t see anything wrong looking into a commercial product that solves what you are looking for.

0 Likes

#5

Hassbian gives you the ability to quickly get both the OS and core of HA installed. It doesn’t bring anything else though. Using the AIO installer:

The Raspberry Pi All-In-One Installer deploys a complete Home Assistant server including support for MQTT with websockets, Z-Wave, and the Open-Zwave Control Panel.

Any time you’re starting with something completely new, it’s really worth taking the time to read up on all the options, and often to ask in the forums. Kicking off with a “I’m new to all of this and know nothing about linux, where should I start” post is likely to get you some solid tips.

Where were you getting that error? Are you still getting it?

And without configuration files, error messages, and more meaningful descriptions we can’t help with that :wink:

That’s because in the *nix world, files and directories starting with a . are hidden by default (as geekoftheweek says), so you need to use ls -a rather than just ls. If you’re going to use HA I’m afraid you’ll need to invest a bit of time in understanding the basics of *nix.

I’d highly advise the nano editor over other options, while you’re sorting out Samba.

0 Likes

#6

I thought that this way had become obsolete with the use of hassbian 1.1 and the scripts. If this is the better way I will give it a go.

I was getting this error running the scripts. I changed the host file and fixed this error.

I don’t get any error messages. However maybe you can point me in the right direction. I tried just editing some of the settings in the smb.conf file. Set wins to yes, editiable to yes. I can try to copy and paste it here. However Bruh Automation had his samba config file under the video he had done. I tried to delete everything in the file out and pasted his file in there. Still didn’t work. I also tried changing a couple settings but that didn’t go anywhere.

Thanks for the info I will poke around some more.

0 Likes

#7

So, you’ve:

  1. Installed Samba
  2. Changed the configuration
  3. Created the account for the homeassistant user (smbpasswd -a homeassistant)
  4. Restarted Samba
  5. Tried to browse to \\servername\homeassistant and \\server.ip.add.ress\homeassistant

And you just got a timeout for the last step?

FYI, this is the smb.conf I just created and tested, which is basically the default one with all the commented out lines removed:

[global]
# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   server role = standalone server
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
   usershare allow guests = yes

[homes]
   comment = Home Directories
   browseable = no
   read only = no
   create mask = 0700
   directory mask = 0700
   valid users = %S
0 Likes

#8

Thank you for your help. If nothing else you’ve given me a push in the right direction.

So I started over. Installed Rasbian, Ran the all in one script. I learned about the “ln” command to fix open zwave. I was able to turn my light switch on and off using the open zwave control panel.

Baby steps.

I installed samba and used your configuration. It sort of works. I am able to see the user pi’s directory tree. However I can’t view the root folders. Does that make sense? Going to mess with it later. Need to take a mental break.

Thanks again Tinkerer

0 Likes

#9

Samba - that makes perfect sense, the only thing that’s shared are individual home directories. If you want to share other folders you’ll need to add those separately. However, for just editing the HA configuration, you should only need the user you’re running HA as (which will be homeassistant).

0 Likes

#10

Trust me I am on the uphill side of the linux learning curve. I spend most of my time googling command lines to figure out what they are doing.

0 Likes

#11

In the long run it’ll be worth it. You’ll teach yourself some useful skills in the process.

The hardest part for a lot of longtime windows users is having to relearn the fundamentals and throw out a lot of preconceived notions on how and OS functions. MacOS is pretty similar under the hood, both posix compliant.

Once you hit that aha moment youl begin to realize how powerful of an OS it is. Baby steps, it won’t happen in a day.

0 Likes

#12

I tried out Hassbian when I wanted to redo my installation from scratch. I had been running HA for some time with an original AIO installer.
I have to say that I have spent nearly a full day trying to get Hassbian working and I have a reasonable amount of knowledge of HA and Linux but I found the scripts for Samba, Zwave, MQTT often failed.

As much as I wanted to get it working the amount of time and failures was just too great so I reverted back to the AIO installer which completed successfully.

Hassbian is such a great idea but I do think that Zwave, MQTT and possibly Samba need to included in the image. I would love to see Hassbian develop into something that can really get new users using HA without too many complexities. From this starting point, it may encourage them to then learn about HA and Linux as they setup and configure HA.

0 Likes

#13

If you are just tying to set up samba, to be able to edit configuration files, then I think you should be better off with putty and mc.
Putty is for accessing your linux hardware without the need of a local keyboard or monitor.
Here is the link: http://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html
it is just an exe no need to install anything, just double click it in windows, type in the ip address of your pi, and log in with any user (except root, but you can change to root when you are logged in.)
By now you should know that you need to use apt-get to add or remove packages from raspbian.
So try sudo apt-get install mc.
Then run mc with the mc command. It gives you an old style commander look interface where you can copy, move, edit file with certain F1-F9 buttons (check the bottom line of the screen). You can even set the view to display hidden files and folders.

Take a deep breath and ease up :slight_smile:

there is even a raspbian jessie install howto on the forum…

cheers
tom

0 Likes

#14

To follow the configuration-topic:
Once set up, using the Simplistic Configuration UI may be even easier to use.

0 Likes

#15

I will check that out. Thanks!

0 Likes