GIT Pull Addon

The documentation on this one isn’t particularly clear either. I was trying to set it up, but it doesn’t seem to be working. Im getting the following error.

does not match regular expression for dictionary value @ data['options']. 
Got {'repository': 'http://x.x.x.x:port/<username>/home-assistant', 
'auto_restart': False, 'repeat': {'active': False, 'interval': 300}, 
'deployment_key': ['-----BEGIN RSA PRIVATE KEY-----', 'Proc-Type: 4,ENCRYPTED', 
'DEK-Info: AES-128-CBC,C921147D10E5C3A2832F3CFE917887D3', 'NSEUIsEVnMbr/7HG/FY/nC80Y3o5ZptKSzlqXuail++SC9UvRnbZ7zM8r4gVKmvA', 

This is the config I use

  "repository": "http://x.x.x.x:port/<username>/home-assistant",
  "auto_restart": false,
  "repeat": {
    "active": false,
    "interval": 300
  "deployment_key": [
"Proc-Type: 4,ENCRYPTED",
"DEK-Info: AES-128-CBC,C921147D10E5C3A2832F3CFE917887D3",
  "deployment_key_protocol": "rsa"

Is this somehow related to this issue, because I use a port number? if so, how do I get around that when hosting my own gitlab server on docker. I’d rather keep standard ports available.

@naveci any news about that?

No, I still haven’t figured it out and I decided to do it at the system level. I run on top of Cent OS together with other docker containers, so I’m able to go underneath to the file system of Cent OS. However, I cannot do the same trick on my raspberry, so that one isn’t in Git yet.

I’m having this exact same problem on my Raspberry Pi 3 in March 2018. Has anyone had any luck with this?


Did you try to add .git to your repository URL, as mentioned in the Docs? This did fix the error for me.

I’m running with a username and password and get the following:

[Info] Saving git credentials to /tmp/git-credentials
git repository exists, start pulling
*** Please tell me who you are.
git config --global "[email protected]"
** git config --global “Your Name”**
to set your account’s default identity.
Omit --global to set the identity only in this repository.
fatal: unable to auto-detect email address (got ‘root@core-git-pull.(none)’)
[Error] Git pull failed

Tried running commands as root with no luck.

I can confirm it still clears your config :), tried playing with SSH and get a similar error other posters:

not a valid value for dictionary value @ data[‘options’].

I managed to get the “GIT Pull” to work and did a couple of tests. This add on will only be useful if you do all your changes in GitHub. If you change or create any automation/scripts in Home assistant front-end, then “GIT Pull” will not overwrite the local file that has changed.

Equally unfortunately it won’t upload the new changes to Github either which would be really useful.

1 Like


I try to use it today but unfortunatly I have this message

not a valid value for dictionary value @ data[‘options’]. Got {‘repository’: ‘’, ‘auto_restart’: False, ‘repeat’: {‘active’: False, ‘interval’: 300}}


“repository”: “”,
“auto_restart”: false,
“repeat”: {
“active”: false,
“interval”: 300

Hassio 0.71.0
Plugin : 4.7

Thks a lot

I tried using git pull before findiing this thread and it appears to have the same problems other have mentioned. After installing it, my home assistant has become unusable. It seemed to do the clone without issue, but there wiping of the config directory before that was not something i had anticipated. There were files in there that I hadn’t properly backed up. I will spin on it a bit more to see if I can recover, but it feels like I will have to wipe and start again.

Would be useful to be able to disable the automatic check of config files in this addon which seems to take most of the time. I run this check already in a pre-commit hook so it’s only slowing things down for me.

Am I correct in my understanding that if you use this you should modify yaml on the remote repository and it will update your working directory?

If so, does this work with so you can restore your add-ons (and the associated configs as well)?

Matter of fact, I would think it should restore things .homekit.state, nest configs, etc.

Why this addon still at repo? He kill all my config folder :frowning:
And nobody can config him. :thinking:

I am also trying to use this addon in order to streamline my config updates, but it seems it is not working properly (as TEDSv mentioned, I cannot get any way to configure it).

Should I just quit?

the docs are here:

I’m using this addon, I really like it, it works for me :slight_smile:

Equally unfortunately it won’t upload the new changes to Github either which would be really useful.

A git push addon would be a nice thing to have :wink:

1 Like

gitpush would be useful… I don’t see much use for editing my config on GitHub and pulling it to HA. I then use Winscp o update my HA to Win10 PC and then github desktop to sync changes.

Are you guys able to properly configure this addon? I tried so many combinations, but every one resulted in:

not a valid value for dictionary value …

I am basically using the default value as a template (which, by the way, if you save the configuration it generates the exact same eror).

Could you share your Git Pull add on configuration (obviously without sensitive info)?

Hi, I would like to use the GIT PULL Addon for backing up my hassio.
I already have my hassio setup. What are the steps to get it to use my current config?
And when I change settings locally, I need it to sync back to github, what settings should I use for this to work?

This is a poor addon in that it works but has bad outcomes for unfamiliar users and also needs the option to upload (push) your existing config to github before pulling it again. There isn’t even a warning !!

Before being approved this issue should have been implemented

1 Like