Github rate limit error HACS

Have you done this? The graph will not show you any traffic, how could it, there is none, because Github doesn’t send you any data…

Yes, only I had done it via a curl command, which is why I think there is a bug somewhere.

Core: “limit”:60,“remaining”:58
Rate: “limit”:60,“remaining”:58

Everything else is untouched 5000 out of 5000, 10 out of 10, etc.


On a fresh install of HACS I’m seeing exactly the same, yet I’m getting rate limit errors in my HA logs and can’t use HACS at all. :thinking:

This error originated from a custom integration.

Logger: custom_components.hacs
Source: custom_components/hacs/api/
Integration: HACS (documentation, issues)
First occurred: 16:15:58 (1 occurrences)
Last logged: 16:15:58

GitHub Ratelimit error

I installed HACS yesterday also on a fresh install. But I am stuck (also after reboot and waiting for more than 24 hours) on this screen:

In the API of Github I have still rates remaining:

1 Like

Same situation here … it took ages to get the local tuya keys and now hacs is not working. 40 minutes delay anounced, within 1 hour it should work but after 2 hours no progress. still the same error.

And these are the stats - just 0 used and no progress. I hope I will have to deal with that only once during installation.


After 2:15 hours now the system seems to work and Hacs is connected but no local tuya integration offered … from issue to issue for over a week now.

UPDATE: the resume thing never appeared again so it is just a kind of delayed installation. Hacs install worked on the next day. So it is just like “have a break before you will get your hacs”. Not nice, but would be a lot easier to explain this in the installation procedure and in the videos on yt that do not cover this topic.

As a complete newbie you feel lost if 1 hour is over and nothing has changed. You might think to restart the system after 1 hour but what if the time would start again from 0?

For me it was nerve racking on the long way just to get 4 tuya plugs working offline.

I am new to this and maybe I missed something, but the ratelimit errors went away when I unchecked these options:


1 Like

We call that a coincidence and it’s nothing to do with the problem so far as I know but if you don’t use appdaemon or netdaemon apps then you shouldn’t have them checked…

Worked for me too :+1:

Sorry for the delay, things cleared up shortly after I posted and with life and things working properly I promptly forgot about the issue.

That is until today. I went and installed the Mini Media Player this morning played around with it a bit and restarted HA as one of my Snapcast clients wasn’t detected. After the restart I tried to access my Media tab in HA but it wouldn’t load. The only thing I’ve added to that page today was the Mini Media Player. I think it is the only page with anything related to HACs on it.

I checked the logs and noticed that HACs was again rate limited.
I logged into Github and checked the Authorized OAuth Apps and I can see this:

Last used within the last week · Owned by hacs

I went to: ‘
and here are the results:
{"resources": {"core":"limit":60,"remaining":59,"reset":1623251777,"used":1,"resource":"core"}, "graphql":"limit":0,"remaining":0,"reset":1623251785,"used":0,"resource":"graphql"}, "integration_manifest":"limit":5000,"remaining":5000,"reset":1623251785,"used":0,"resource":"integration_manifest"}, "search":"limit":10,"remaining":10,"reset":1623248245,"used":0,"resource":"search"}}, "rate":{"limit":60,"remaining":59,"reset":1623251777,"used":1,"resource":"core"}}

You mentioned getting information from the Info Page. Where do I find the Info Page?

I managed to solve putting the token in configuration.yaml

  token: your-token

I restarted Home Assistant and HACS came back!


Where do I get that token from ?
I have a Github account but never heard about a github token before.
Will it stay the same or depends on time ?

I have had this issues at least twice in 14 days, first installation and later one update.

Maybe this Creating a personal access token - GitHub Docs

The link is from Configure HACS with YAML

I have the same issue. Just installed hacs for the first time yesterday. Seemed to install fine per the guide. Went to install the circadian lighting repo and it just spun.

For hours.

Next morning it isn’t installed and I am rate limited. It has been 9 hours now and the rate limit has not gone away

This is a new install fully patched with Debian also fully patched underneath it

What token are you referencing? The instructions don’t discuss a token?

They do if you are using yaml mode for HACS

I followed this suggestion, added a token to my configuration.yaml. Restarted, Bam, working instantly!!!

I’ve had problems with HACS ratelimiting every now and then from the very beginning but it’s only gotten worse even though it’s been a known problem for a long time. The extreme spikes in Github calls from HACS that happens all the time is annoying at best but maybe I wouldn’t really care if it actually recovered, but it doesn’t. My HACS tells me it will recover within 1 hour. It has currently shown that message for over a week.

Maybe, just maybe, it makes sense to poll all those thousands of repos upon the initial installation (although that seems like asking for trouble). But thousands and thousands of calls every day even though I’m not even interacting with HACS in any way? I really don’t get it. Many people have asked about this but I’ve not seen any clear answer. All I see is “fixes” that tries to avoid Github’s limit by lowering the calls slightly, but no attempt to fix the root cause.

Every HA restart is a lottery, sometimes HACS will initialize but most often it never does and mostly never recovers. There is nothing special about my installation and the Github account is dedicated to HACS. Reverting to a legacy YAML config, as some people recommend as a fix, seems kind of backwards and the documentation seems to not recommend this.

I could provide more detailed information but from what I can see many people have already provided that many times before to no avail so I don’t think it would help. As long as this is considered a feature rather than a bug or design flaw, I don’t see any reason to spend time debugging it.

1 Like

Please do something with the rate limit issues, i trying to set up HACS for like 6 hours and always gets rate limited. Clone to a different server or something like.

Trying to install HACS for the first time and it just spins for over 2 hours at “Please wait while the integration is being installed…”

I’m not sure how to install HACS at this point. Any suggestions?

constantly getting this issue even though i have fucktons of calls remaining

x-ratelimit-limit: 60
x-ratelimit-remaining: 57
x-ratelimit-reset: 1628525798