Google Assistant working with sensors?

Have you customised the device class of those components to be a temperature sensor?

I have the same problem, only badges are visible and I have made the sensor device_class in custimisation, also restarted HA en synchronized Google Assistant

ha: 0.96

@andrewdolphin I have

Here is my sensor:

  - platform: mqtt  
    state_topic: "office/temperature_fahrenheit"
    name: "Office Temperature"
    unit_of_measurement: "°F"
    value_template: '{{value | round(0) }}'

And here is the google assistant piece:

  project_id: id
  api_key: key
    - sensor
    - climate
  expose_by_default: true
      name: Living Room
      room: Living Room
      expose: true
      name: Master Bedroom
      room: Master Bedroom
      expose: true
      name: Office
      room: Office
      expose: true

For those that have the badge showing. What happens if you ask Google assistant for the sensor? Mine shows a badge with no “UI” but does return the temperature (albeit rounded to the nearest 0.5 degress and with a comment about being off").

Yes that works, I get the temperature also with 0.5 degrees.

same here. Google speaks the temp but also states the status “off”, because that is the state of the dummy thermostat.

Same here, I works when I ask google with the “off” status, but still just the badge on google home.

Hi All,
It start working for me as well.
Give’s me the temperature as well as that it is currently “off”

Climate is removed in the last update and my fake thermostates are gone…

So is there any way I can get Google assistant working with sensor now?
I am on the latest version: 0.98.1


Please can someone help me?. I’m going crazy.

I have zigbee2mqtt correctly configured and my Xiaomi MiJia temperature & humidity sensor is working as expected and showing correct values in Home Assistant.

I have renamed entity id from sensor.0x00158d00039e30e5_temperature to sensor.salon_temperature. Not problems. All working as expected also with new name.

Then I have added next line to my configuration.yaml file:

  customize: !include customize.yaml

and next lines to my customize.yaml file:

  device_class: temperature

restart Home Assistant without errors and query to Google Home:

“What it’s my salon temperature?” (actually I do that in spanish)

And always have the same response in english (not in spanish):

“Sorry, I didn’t get any response”

In Google Home app I see shield icons without values. I did the command “resync my devices” many times that also works as expected but I always have the same response.

I have google assistant correctly configured because I have Ikea Bulbs also with zigbee2mqtt that works great with Google Assistant voice commands. Anyway i put here the configuration i have.

  project_id: <my_project_id>
  api_key: <my_api_key>
      expose: false

All domains are exposed by default.

The only way I’ve ever managed Google Assistant respond with the sensor temperature has been setting a generic_thermostat as follow in my configuration.yaml:

 - platform: generic_thermostat
   name: Salon
   heater: input_boolean.fake_heater
   target_sensor: sensor.salon_temperature

   name: Fake Heater
   icon: mdi:toggle-switch-off
   initial: on

If fake_heater is off doesn’t work. The problem with this is that the response is very hateful because is something like “The temperature of heater is set at 20 and you have a ambient temperature of <sensor.value>” .

I have Home Assistant 0.96.5. Am I the only one with this problem?. Am I misunderstanding something?. Maybe a problem with my Google Asistant region (Spain)?

Thanks a lot.

Same problem. I am spanish too.

Maybe is a spanish google assistant problem?

I have the same setup as you (zigbee2mqtt with Xiaomi temp and hum sensors) and for me works fine.
The only difference I see from my setup is that I am not using customization for the sensor.
I expose direct the sensor to the home assistant and I ask in my language (portuguese), witch works perfectly.

One other ting I did was to expose the sensor with a specific name (ex: Salon Temperature) or you can do it from google assistant as well, and ask google " what is the temperature in “name you have exposed” (again, I do it in my language and works fine).

Hope will help somehow.

1 Like

Hi there.

I’m at Spain too and this issue is driving me crazy.
All temperature sensors and climates that were exposed from HA were working OK on my Google Homes and Google Assistant until 1 month ago aprox.
Suddenly, at the next day it started to answer “Sorry, I didn’t get any response” (in Spanish accent English or the like) whenever I ask the temperature of any device (climate or sensor) that is OFF. If the device is on COOL or HEAT mode, it answers correctly…

Moreover: if you ask the temperature in English language instead of Spanish, it answers perfectly (in English of course). You have to set both languages in your Google Home settings to use English when asking.

I tried all and every solution I found here and the whole internet without any success. You can try to unlink and relink accounts, resync the devices, reconfigure languages, reset your devices… Whatever.
There is no current solution and is a recent bug by Google that is affecting only non-English speaking.
I try every 3-4 days to ask again to test if it’s solved but it’s not…

This is the issue at Google support site.

Many users with the same problem but unfortunately no answer nor fix from Google…

Thank You!

This was driving me crazy! I spent two days trying to figure it out.

Suddenly, today it started to work OK

1 Like

I just noticed! Hopefully the problem has been solved.

I still need to change the “HVAC status” to OFF to confirm proper functioning but I hope they solved that issue too.

Man im spanish too, how could you get it to work i need help :frowning:

I did nothing.
From night to morning, it started working.
No change on my side.

Has anyone managed to get the ESPHome created sensors to show up?
The Hue sensors I have automatically showed up, no configuration needed. Google still thinks they are thermostats and says they are “off”, but I guess we have to live with that.