Google Home TTS not working

So I’m trying to make my Google Home speak something I wrote in a script.

Now I’m just trying to do it in Developer > Services tab with Service being tts.google_say and the service data being { "entity_id": "media_player.corgi_speaker", "message": "Hello there" }

My Google Home is recognized so I’m suspecting it’s the configuration problem. I have SSL and set my tts base_url to https://[smt].duckdns.org:8123. I checked the log too and found this line

2019-03-22 19:24:54 DEBUG (Thread-2) [pychromecast.socket_client] [Corgi Speaker:8009] Received: Message urn:x-cast:com.google.cast.media from 3674be2d-e25a-4904-9ef9-bf9c05d12b20 to sender-0: {'requestId': 17, 'type': 'LOAD_FAILED'}

Can anyone tell me what’s going on?

doesnt work with ssl in some routers.

Is there some way around it? Mine is ASUS router.

here u can find the reason, and with some ppl answers, maybe it can help u. good luck.
use http and it will work smooth.

1 Like

I’ve been having similar issues, supposedly setting a base_url under the tts section should help.

I haven’t been able to get it to work however and am now having “NoneType” issues after trying to update the gTTS token…

My experience:

  • I configured SSL, duckDNS, and set my baseURL to the duckDNS URL.
  • I authenticated with Google
  • I had to change my baseURL to my local IP address (https://192.169.86.53:8123) to authenticate with another vendor who would not accept the duckDNS URL.
  • My connectivity with Google broke when the baseURL was changed
  • Once I got my authentication key from the other vendor, I was able to change my baseURL back and
    and everything worked.

What I wonder about?

  • Why did Google authentication fail when the baseURL changed? Someone suggested that it might have been a caching issue. I suspect it to be an issue with the pychromecast module in HA.

  • Would Google have let me authenticate with a baseURL set to my local IP address? If so, is there any reason why the baseURL should ever be set the the duckDNS address?

Has anyone been able to work out what’s going on with Google TTS?

I’m using Hass.io and I’m also using DuckDNS.
BaseURL is : https://[mydomain].duckdns.org:8123 as it should be.
I’m using Google Assistant integration through HA Cloud.
Everything else is working fine. I can use Google Assistant to turn on lights, control media players, activate switches etc.

When I try to use the tts.google_say service I can hear the speaker activate (a beep is heard) but the speaker won’t actually say the message.

I think I had the same problems as you.

Try removing the port (8123) from base url property inside tts (so it’s gonna be just https://[smt].duckdns.org). That did it for me

3 Likes

That worked!
Thanks

This isn’t working for me, google assistant and other things work fine. Just can’t get anything to play over google devices.

I’m having an issue with google home’s and TTS all of a sudden also. Is anyone else having problems? I’m using amazon_polly but tired to switch to google_translate but same issue. I see the mp3 is generated and the google home does the start sound. I also have a valid cert and base_url set. My config was working up to a few days ago.

Hi could you please share the code or where do I have to change it?

Thanxs

Check out 3 solutions on this thread