Google music in HA

I thought I had a workaround for the Config Entry errors.

Removing those entries from gmusic.yaml and instead adding them to gmusic/switch.py did in fact stop the warning message and GM continued to work through 91.4

Today I upgraded to HA 92.0 and unfortunately the GM custom switch now prevents HA from starting. :frowning:

I’m still not receiving any error messages but HA just hangs about halfway through startup. Removing the GM switch resolves the issue and HA starts as expected. I was not expecting this to be a breaking change until next release.

So it dies as of 0.92? I had silently prepared myself for it, but was expecting it to come from the Google side, not Hass

check out troy`s post: Google Music in HA -- Using AppDaemon (WIP) Soon :tm:

@Danielhiversen you see us struggleing? :roll_eyes:

Were you able to get it to work? I don’t have appdaemon installed, but would to keep this component working

Not yet - But very soon - atm getting an KeyError - But I use Hassio on Ubuntu. on FreeNAS its working already

Is it Has.io that’s the problem? I run manual in Venv, similar to @troy

And the struggle is real :rofl:

I’m fairly certain we’ll be able to keep Google Music in Home Assistant one way or another. I have
the (appdaemon version) working in a virtualenv and on my hass.io virtual machine. I don’t normally use hass.io so it’s taking a little help from others to get the bugs out

@ajfriesen @tc23 @MomoB @mouth4war @HypnoToad

troy got it working with Appdeamon Google Music in HA -- Using AppDaemon (WIP)

@Underknowledge @ajfriesen @tc23 @MomoB @mouth4war @HypnoToad

I hope you still consider to have a look at my expanded appdaemon version of this in the future.
I’ve just put the files on GitHub and updated this post with all the links…



In other news I also have this custom_compent working in Home Assistant 92.1

image

To workaround the invalid platform keys warning

:tada: This should be fixed now! :tada:

image
Please use the updated files at the links below.


:tada: UPDATED: May 11 2019 :tada:

Here are links to my modified files on GitHub

Basic Home Assistant config package
homeassistant/packages/gmusic_switch.yaml

Gmusic custom component files
homeassistant/custom_components/gmusic/__init__.py
homeassistant/custom_components/gmusic/manifest.json
homeassistant/custom_components/gmusic/services.yaml
homeassistant/custom_components/gmusic/switch.py

More about these changes and extra files here

1 Like

Thanks a lot. I was not planning to update to 92.1 because of the risk to loose this custom component but I will give it a go then !

@troy, interestingly, the custom component is able to turn on and play music, but it doesn’t seem able to turn it off? On 0.92.2. When I toggle the switch off, nothing happens and music continues to play. And thank you so much for doing great work on this component!

@tc23 Did it work differently before? I just added the extra files, I did not really change any code in the component. It could be related to the missing previous next controls.

I have my appdaemon version of this working very well now. I’m starting to work on creating a new custom component for this. I just need to figure out if this should be a new custom component or if it should be a new platform for the media player component.

1 Like

In the prior custom component, it stopped the music as well. But it’s alright, I just added a node red automation to turn off the respective Media players when the switch turns off. I’ll probably switch over to the appdaemon, but needed the custom component for the interim.

Hey everybody! I’ve updated these files on github.

  • The previous “Config Warning” workaround is no longer required!
    Settings have moved back into packages/gmusic_switch.yaml.

  • The media_player will now power off when the gmusic switch is turned off @tc23

  • Removed unnecessary code

If your were using these files before May 11 2019, you should update ALL the files


1 Like

Thanks so much @troy! You the real MVP!

I’m not seeing the media player turn off when the switch is turned off. I see @tc23 added this in a script but not in the code? Maybe I’m missing it.

@edif30

Sorry about that. I thought I already did this but it looks like I missed it :confused:

Anyways you can please try this.
Open custom_components/gmusic/switch.py. On Line 167 you should see the following.

#        self.hass.services.call(DOMAIN_MP, SERVICE_TURN_OFF, data, blocking=True)

Remove the hash (#) at the beginning so the line now looks like this.

       self.hass.services.call(DOMAIN_MP, SERVICE_TURN_OFF, data, blocking=True)

You’ll also need to restart Home Assistant.


UPDATED 06/01/2019:

I’ve also been playing around with changing this to a media player

It’s not perfect but overall seems to work rather well. I have most of the media_player services working.

You can test this out alongside the current gmusic switch and even use the same login information, including decive_id. However you can only play music using either one at a time.

2 Likes

Works great! And nice work on the other thing!

Hi all,

I forked Troy’s gmusic_player and modded it to use Artist / Album selection from google music.
Point is to get rid of playlists and 1000 track limit.

Now i can select All Artists and All Albums and generate queue from all my songs.
Or just select Artist and roll out shuffled queue from all it’s albums.

Also replaced shuffle, shuffle_mode to play_mode = (normal,shuffle,random,shuffle random)
And moved speakers to !secret:
gmusic_player.yaml ->
options: !secret gmusic_speakers

secret.yaml ->

gmusic_speakers:

  • office_speaker
  • patio_speaker
  • home_group

Feel free to test it out, it’s a hack, this is my first attempt on custom_component and i have only basics on python.
So i’ll hope this will be usefull for someone, and all help on this would be great!

miikka

ps.
As i have no subscription, i have no idea how this works with subscription.
I’'m using free account with my own library

1 Like

Looking forward to giving this a try. Thanks for sharing