Google Nest integration stopped detecting 'eco' preset triggered by 'Away'

Hi I also experienced the same issue and behaviour since few days. It was working fine before. I also removed the Nest integration and re-added it but it never got resolved. I can confirm that setting the target temperature works as expected as well as turning it off. Preset mode is broken at the moment. Hope someone can fix this asap. It stopped working per 1st April after checking my Nest energy usage history. Thanks!

Same here.
I have seen the issue reported on Github as well. Seems like it depends on the Thermostat model.

Exactly the same issue here. Setting the preset mode has become unresponsive. Good to see it’s not just me. Running Home Assistant 2023.3.5 and Nest Learning Thermostat V3. Been running this setup for quite some time now, without any issues up until now.

I too am running into this problem. climate.set_preset_mode simply seems to get ignored by my thermostat.

Nest V3
Home Assistant 2023.4.4
Supervisor 2023.04.0
Operating System 9.5
Frontend 20230309.1 - latest

I have worked around it by setting a temperature manually for now. It might screw with your schedules, but for me this was no issue.

Same Issue here!!
But is this a home assistant problem or a Google problem?

Home Assistant 2023.4.6
Supervisor 2023.04.1
Operating System 10.0

Same here - not wokring at all. Also not showing accurate heat history data

I’m very much a novice when it comes to Home Assistant and integrations, but I just found a solution that works for my needs, but understand it may not work for others.

I’ve changed the action in my automation to send a text command instead of changing the preset.
My Nest Thermostat is called “Hallway”.

I know it is a workaround, but it works for me.

I know this isn’t quite the same as the OP, but I landed here as I was trying to work out how to turn eco on from an automation, rather than read its state, and the set_preset_mode isn’t working as an action either.

The workaround of using the set_hvac_mode action is working, which for me has the same effect as turning eco on/off.

Same issue here - I can set eco in the Nest app or the Google Home app and it applies, I can also set eco from Home Assistant and it applies, but if I set eco from the Nest App or Google Home app it doesn’t update Home Assistant to show Eco mode.

I have an EU Nest Thermostat 2nd Gen.