Growatt Inverter Integration Issue

not stupid question, I have the same issue.
I’m using proxmox (virtualization machine), and I don’t have acces to this file.

vi /usr/local/lib/python3.9/site-packages/growattServer/

From the terminal, it does not search for any location from the growatt directory for me

Well that’s over a week now and still no official fix… any ideas when the next release of HA will be? or is it going to be lumped into the next monthly build? another 10 days away?

<rant> with all the breaking changes and issues with updates taking so long to be pushed out like this I’m starting to get really frustrated with HA, I spend way more time maintaining the system than what it could possibly ever contribute to my life. Don’t get me wrong I love learning, tinkering and the challenge of building things, its just getting to the point of “is it worth it”, so many people are interested in my setup when i get notifications from my cameras with AI highlighting people and cars, or when my air conditioning automatically adjusts based on solar production and full breakdowns of what appliances are costing the most or how much I’ve saved on power bills from having things controlled by HA. but ultimately the complexity of setting it all up and maintaining it is more than most can do themselves. </rant>

this might sound silly, but can the integration be cloned into HACS so we can update without waiting for official updates?

Thanks, it worked to me.

can’t we just read the data from the inverters themselves ?
then we are no longer dependent on chinese webservers !
mine are connected via LAN to my network, why not read them locally ?

or is that a stupid question ?

Its a good question and this video shows how it is possible. Howeder I didnt try yet:

Got a home assistant 2022.6.7 update with growatt installation. Still not working :frowning:

When you install the HA core 2022.6.7, the problem is 100% solved. Everything works for me again.

Not for me :pensive:
got this error.

Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/helpers/”, line 249, in _async_setup_platform
await asyncio.shield(task)
File “/config/custom_components/growatt_server/”, line 903, in async_setup_entry
devices, plant_id = await hass.async_add_executor_job(get_device_list, api, config)
File “/usr/local/lib/python3.9/concurrent/futures/”, line 58, in run
result = self.fn(*self.args, **self.kwargs)
File “/config/custom_components/growatt_server/”, line 878, in get_device_list
login_response = api.login(config[CONF_USERNAME], config[CONF_PASSWORD])
File “/usr/local/lib/python3.9/site-packages/growattServer/”, line 119, in login
data = json.loads(response.content.decode(‘utf-8’))[‘back’]
File “/usr/local/lib/python3.9/json/”, line 346, in loads
return _default_decoder.decode(s)
File “/usr/local/lib/python3.9/json/”, line 337, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File “/usr/local/lib/python3.9/json/”, line 355, in raw_decode
raise JSONDecodeError(“Expecting value”, s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

I have checked the login details, they are 100% correct.

Does anyone have an idea what is going wrong and how I can fix it?

I have installed the 2022.6.7, but still not working for me. I have tried to delete the integration and install it again, but I get the same error :frowning:

Just wanted to thank you, after installing the latest core update this morning, everything is back to normal!!!

:white_check_mark: could add the integration again today! I just entered my credentials and now it connected.

Still unable to load Growatt - supervisor-2022.05.3 , core-2022.6.7

It worked! dad is happy….BUT HA is logging minus 420 kWh, any surgestions?

Works for me too.

Home Assistant Core 2022.6.7

Home Assistant Supervisor 2022.05.3

Home Assistant OS 8.2

Seems to be a problem again:

home-assistant      | 2022-08-08 18:27:33.627 ERROR (MainThread) [homeassistant.components.sensor] Error while setting up growatt_server platform for sensor
home-assistant      | Traceback (most recent call last):
home-assistant      |   File "/usr/src/homeassistant/homeassistant/helpers/", line 281, in _async_setup_platform
home-assistant      |     await asyncio.shield(task)
home-assistant      |   File "/usr/src/homeassistant/homeassistant/components/growatt_server/", line 74, in async_setup_entry
home-assistant      |     devices, plant_id = await hass.async_add_executor_job(get_device_list, api, config)
home-assistant      |   File "/usr/local/lib/python3.10/concurrent/futures/", line 58, in run
home-assistant      |     result = self.fn(*self.args, **self.kwargs)
home-assistant      |   File "/usr/src/homeassistant/homeassistant/components/growatt_server/", line 42, in get_device_list
home-assistant      |     login_response = api.login(config[CONF_USERNAME], config[CONF_PASSWORD])
home-assistant      |   File "/usr/local/lib/python3.10/site-packages/growattServer/", line 119, in login
home-assistant      |     data = json.loads(response.content.decode('utf-8'))['back']
home-assistant      |   File "/usr/local/lib/python3.10/json/", line 346, in loads
home-assistant      |     return _default_decoder.decode(s)
home-assistant      |   File "/usr/local/lib/python3.10/json/", line 337, in decode
home-assistant      |     obj, end = self.raw_decode(s, idx=_w(s, 0).end())
home-assistant      |   File "/usr/local/lib/python3.10/json/", line 355, in raw_decode
home-assistant      |     raise JSONDecodeError("Expecting value", s, err.value) from None
home-assistant      | json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

Anyone else missing data since earlier today ?

1 Like

Already being observed:

Problem is there again for me:
Logger: homeassistant.components.growatt_server.sensor
Source: components/growatt_server/
Integration: Growatt Server (documentation, issues)
First occurred: 14:04:53 (1 occurrences)
Last logged: 14:04:53

Unable to fetch data from Growatt server

After this I also tried the uninstall of the integration / install integration. Install itself was succesful but still no data:
Logger: homeassistant.components.sensor
Source: components/growatt_server/
Integration: Sensor (documentation, issues)
First occurred: 14:04:54 (2 occurrences)
Last logged: 14:04:54

Error adding entities for domain sensor with platform growatt_server
Error while setting up growatt_server platform for sensor
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/helpers/”, line 428, in async_add_entities
await asyncio.gather(*tasks)
File “/usr/src/homeassistant/homeassistant/helpers/”, line 691, in _async_add_entity
await entity.add_to_platform_finish()
File “/usr/src/homeassistant/homeassistant/helpers/”, line 777, in add_to_platform_finish
File “/usr/src/homeassistant/homeassistant/helpers/”, line 533, in async_write_ha_state
File “/usr/src/homeassistant/homeassistant/helpers/”, line 571, in _async_write_ha_state
state = self._stringify_state(available)
File “/usr/src/homeassistant/homeassistant/helpers/”, line 539, in _stringify_state
if (state := self.state) is None:
File “/usr/src/homeassistant/homeassistant/components/sensor/”, line 404, in state
value = self.native_value
File “/usr/src/homeassistant/homeassistant/components/growatt_server/”, line 164, in native_value
result = round(result, self.entity_description.precision)
TypeError: type NoneType doesn’t define round method

1 Like

Hi, Seems like Growatt have made some changes…
Have a look at this thread on Github for the interim fix on this issue.

Hope it helps…

Uninstalled and installed the application again. Today this was succesful. I did it last time as well but then it had no effect.
I assume the integration changed the last days for the good.
Thanks to the people that replied and big thanks to the people that fixed the integration!

Maybe a stupid question, but what I have to chose to get the hourly values?