[GUIDE] Install HASSIO and KODI on same Raspberry Pi

@Oligarch
From the last update 2022.11.1 I get messages that the supervisor system is not supported,
The message I get is “System is unsupported because Systemd Journal and/or the gateway service is missing, inactive or misconfigured. Use the link to learn more and how to fix this”
and sends me to Systemd Journal - Home Assistant
I tried the command that appears on the page, I restarted the system and I still get the same error,
what can be done?
Thanks

@Oligarch Are these instructions still up to date?

Yes. It’s up to date

@Oligarch This is the error I get on installation

dpkg: dependency problems prevent configuration of homeassistant—supervised:
homeassistant—supervised depends on systemd—journal—remote; however :
Package systemd—journal—remote is not installed.
dpkg: error processing package homeassistant—supervised (——install) :
dependency problems — leaving unconfigured
Errors were encountered while processing:
homeassistant—supervised

A recent Home Assistant update added a new dependency. You can run the command:

sudo apt --fix-broken install
1 Like

Now I get this problem
what can we do?

Unsupported system - CGroup version
The system is not supported because the wrong version of Docker CGroup is being used. Use the link to learn about the correct version and how to fix it.

Just add systemd.unified_cgroup_hierarchy=0 to your /boot/cmdline.txt. And reboot

This command fails for me:
sudo apt-get install obexpushd

It says it can’t find the package.

It seems that for the 64-bit version of Raspbian, the package is called bluez-obexd. I need to update the instructions

I am unable to install docker. I get Segmentation fault on RPi3 debian.11~bullseye

After update of haos to:

Home Assistant 2023.2.5
Supervisor 2023.01.1
Frontend 20230202.0 - latest

I get two errors under repairs:

  • Unsupported system - Systemd Journal issues
  • Unsupported system - Operating System

Any idea how to solve those two?

Thank you for this guide, I’ve just run through it today and for the most part it was still all working as expected!

A few small updates:

Step number 2:

  • connect your microSD card to your computer
  • open the software
  • select your Operating System from download folder
  • select your microSD card as the Storage
  • Click the settings cog icon
    • Select to enable a hostname
    • Select enable SSH
    • Enter a username and password (or set SSH key if you wish)
    • Configure WLAN if you wish (or just plugin ethernet cable)

These updates allow you to skip step 3, 5.4 (optional) and some of 6.2 and 6.4.

The only errors/issues I had was:
10.1 - installing packages “kodi-vfs-nfs kodi-vfs-sftp”, the first one didn’t seem to exist (and is possibly not required any more as it’s built in?), the second one I didn’t need, so didn’t install.

I had problems with no sound over HDMI in Kodi, changing dtoverlay=vc4-kms-v3d to dtoverlay=vc4-fkms-v3d in /boot/config.txt worked for me, as detailed here.
And I had a bit of frame lag/stuttering, so in video settings, changing to Advanced mode, changing frame rate from 30 to 60fps and dropping to 1080p (I don’t have any 4K content) fixed this for me.

I didn’t follow steps 8 or 11, as these weren’t required for my setup.
I used home assistant OS-agent version 1.4.1.

Thank you for the guide! It is great, however got the following results:
Installed on Rasbberry Pi4 type B 8GB

  1. No success with bluetooth section
  2. After making Kodi to autostart got an error in HA ( Unsupported system - Network Manager issues )

Does anybody know how to fix it?

  1. After making Kodi to autostart got an error in HA ( Unsupported system - Network Manager issues )
sudo systemctl enable NetworkManager.service
sudo reboot

I seem to have a problem with 5.4 Configure PuTTY with Private key:.
After typing login as: pi PuTTY immediately replies with a fatal error, saying:
No supported authentication methods available (server sent: publickey)

Edit:
Probably modifying the file permissions in .ssh went wrong. I assume I cannot get access to my Raspi anymore and will start again from scratch

I’ve just started the installation and ran into the problem that the package systemd-resolved is no longer available, but the file /lib/systemd/systemd-resolved exists and is part of the systemd package, so I started the installation with:

sudo dpkg -i --ignore-depends=systemd-resolved homeassistant-supervised.deb

For some reason, the ethernet (or at least ssh) connection of my pi isn’t too stable, but after a reboot I continued with:

sudo dpkg --ignore-depends=systemd-resolved  --configure -a 

Then the installation succeeded and I got the “Preparing Home Assistant” screen and am now at the “onboarding” stage.

Edit:

After onboarding I added systemd.unified_cgroup_hierarchy=0 to /boot/cmdline.txt to get rid of the cgroup warning.

Also got the Network Manager issue, which was fixed by

sudo systemctl enable NetworkManager.service
sudo reboot

Haven’t tried the Kodi installation yet.

Oh, also didn’t get the bluetooth stuff working, but didn’t care about that.

Edit next day:

Installing additional packages, such as kodi, did not work anymore because of the missing dependency on systemd-resolved for homeassistant-supervised. I resolved that issue by creating a dummy debian package, which I installed with dkpg and made available for download at:

http://tuks.nl/software/systemd-resolved.deb

For a new installation, it would be best to download and install this package if installing homeassistant-supervised fails because of the missing dependency and then re-try, so the --ignore-depends switch is not needed. I haven’t tested this, though, so YMMV.

1 Like

Apparently this way is not supported anymore and installing suprevised is failing Installing Home Assistant Supervised on a Raspberry Pi using Debian 12

You can try this

sudo BYPASS_OS_CHECK=true dpkg -i homeassistant-supervised.deb

Hi there, is this method and integration still valid? I’m looking to do this on rpi 5 with ssd.

If possible to add systemd-resolved in apt install recquire.