HA Core 2022.6.5 wont install?

I’ve tried 4 times and the latest HA Core 2022.6.5 does not install, it looks like it is, but still shows the screen attached. Any thoughts??

Did you checked supervisor logs ?

Sorry but where do I access the supervisor logs

Settings - system - logs, upper right corner select supervisor

Thanks @pepe59 Here are the pertinent logs from a recent attempt to update to version 2022.6.5
22-06-11 15:41:23 INFO (MainThread) [supervisor.homeassistant.core] Updating Home Assistant to version 2022.6.5
22-06-11 15:41:23 INFO (SyncWorker_5) [supervisor.docker.interface] Updating image Package qemux86-64-homeassistant · GitHub to ghcr.io/home-assistant/qemux86-64-homeassistant:2022.6.5
22-06-11 15:41:23 INFO (SyncWorker_5) [supervisor.docker.interface] Downloading docker image ghcr.io/home-assistant/qemux86-64-homeassistant with tag 2022.6.5.
22-06-11 15:47:53 ERROR (SyncWorker_5) [supervisor.docker.interface] Can’t install ghcr.io/home-assistant/qemux86-64-homeassistant:2022.6.5: 500 Server Error for http+docker://localhost/v1.41/images/create?tag=2022.6.5&fromImage=ghcr.io%2Fhome-assistant%2Fqemux86-64-homeassistant&platform=linux%2Famd64: Internal Server Error (“Get “https://ghcr.io/v2/”: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)”)
22-06-11 15:47:53 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed

Are you short of disk space?

I would turn off the backup from that check box (but make sure you have a recent one you did manually obviously) it’s possible it can’t even get through the backup portion, as mentioned above could be a disk space issue. I at one time had it backing up my saved snapshots and video clips from frigate which made the backups take absurdly long.

Yes I turned off the backup and my VM shows used 15.9 of 32 GB so disk space is not an issue. The logs I posted indicates a Timeout exceeded, but I don’t know what is causing that??

DNS. It’s always DNS.

Check your Settings > System > Network settings. Try making the DNS server


Thanks @tom_l that was the culprit. I wasn’t even aware of being able to modify dns in HA, all is now well!