HA hardware stop working, and the zigbee2mqtt fails

I have ha installed in virtual machine virtual box in win 11 . I have zigbee2mqtt installed I installed it properly and every thing worked fine for couple of days and I could find my coordinator in the ha hardware and all is good.

after some days something happened and zigbee2mqtt stops working In log file : [13:05:31] INFO: Preparing to start…
[13:05:31] INFO: Socat not enabled
[13:05:31] INFO: Starting Zigbee2MQTT…
Zigbee2MQTT:error 2023-06-15 13:05:53: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2023-06-15 13:05:53: Failed to start zigbee
Zigbee2MQTT:error 2023-06-15 13:05:53: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2023-06-15 13:05:53: Exiting…
Zigbee2MQTT:error 2023-06-15 13:05:53: Error: Connection not initialized
at Ezsp.execCommand (/app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/ezsp.ts:551:19)
at Ezsp.version (/app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/ezsp.ts:349:35)
at Driver.startup (/app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/driver.ts:141:25)
at EZSPAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/ezsp/adapter/ezspAdapter.ts:165:16)
at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:132:29)
at Zigbee.start (/app/lib/zigbee.ts:58:27)
at Controller.start (/app/lib/controller.ts:101:27)
at start (/app/index.js:107:5).
and if I go to HA hardwares I don’t find and hardware in the hardwares and don’t see the coordinator.
if I restart the whole computer with the VirtualBox in it it start to work again for couple of days till it happened again.
It is very frustrating I installed every thing including the whole HA again and again and even format my computer after couple of days the problem comes back always. can you help?

Welcome to HA. :slight_smile:

Please take note off the few things written here:

Especially regarding code formatting and your installation data. :wink: It is nothing to educate you, it is simply necessary to help correctly. The code format is important, as HA relies on YAML, and in YAML indentation is very important. Without proper formating we can’t see these indentations.

And please provide your hard- and software data, eg. are you running HA OS or a supervised install or just core?

But let me say one thing: for sure it is frustrating, but installing over and over again might have helped in the 90s for WIndows, but here it isn’t a good idea. If there ever where some hints in the logs, you are constantly deleting them. We need to find out, what is causing this. :slight_smile:

Have you tried the link to the trouble shooting section that is mentioned in your log? :slight_smile:

Did you enable pass-through for your USB-adapter in virtualbox ?


Is your dongle plugged in a USB-2 port or a USB-3 port ?
is it plugged directly into your machine, or do you use an extension cable ?

Anyway, I would not use Windows for HA.

Right there in the error message.