HA Install on HP T640 Thin Client - I'm lost

New user here…

I just started this journey the other day with basic sensors running on a Raspberry PI 3. Zwave/Zigbee dongles on the way.

Anyways, the barrel for DC power on my RPI is flaking out, losing power intermittently, need to replace. Instead of purchasing another RPI, I have a brand new HP T640 Thin Client that was never used by my client. Specs are as follows:

  • HP T640 Thin Client
  • HP ThinPro
  • AMD Ryzen™ R1505G (2.4 GHz base clock, up to 3.3 GHz max boost clock, 4 MB L3 cache, 2 cores)
  • 4 GB DDR4-2400 MHz RAM (1 x 4 GB)

I am not a Linux guy at all, I almost qualify as a Windows guy. I did some searching on the web on how to install HA onto a thin client. Not gonna lie, I am more confused now than I was before reading stuff. Right out of the gate, its talking about different images (VirtualBox, KVM, Vmware Workstation). I also cannot find a step by step guide for the silly people like myself.

I am hoping someone could step me through this as opposed to getting an overpriced RPI.

Installation for a mini PC uses generic x86 so your instructions are here… Generic x86-64 - Home Assistant (home-assistant.io)

Your choices are basically going to come down to install type. HAOS, supervised, container, or core.

For the differences: Installation - Home Assistant (home-assistant.io) (Direct link to installation type comparison)

Personally - especially when someone’s new to HA… I’m a fan of HAOS, treat it like an appliance, If you run into a situation where you need to run other stuff on the PC you can always run a virtualized HAOS (Inside one of those solutions you mentioned above). It’s the simplest way to start and if you need more capability later just back up your installation and restore it to wherever you move HA into later.


Thanks @NathanCu all the info. This thin client will be exclusively for HA.

I will try these steps over the next couple of days and will let you know.

the easiest way for me on my HP t630 was using proxmox

This also gives you the advantage of running other stuff in the future. Mine runs pihole and Openmediavault

+1 for Proxmox but the RAM is low for that. (I have upgraded a T630 to 16Gb RAM)

@Effers: if you take your time now to reflect, you might save yourself some time/re- installs/…
Proxmox is virtualization software on which you can install multiple systems.
Pi-Hole or AdGuard are used quite often; I run 10 different systems as containers, one of them is a second test HA setup.
Proxmox also gives you an easy option to create backups and snapshots of your systems.
Virtualization gives you a lot of possibilities and you use the full potential of your hardware.

With HA-OS you have similar ways to install add-ons (which also are containers) but in that case your HA is the foundation.

I also upgraded my t630 to 16gb ram. I run a backup test instance for HA although mostly it is switched off as Its not needed. Mine has 3 old sata 1tb ssd disk running on it via USB for openmediavault. It also runs motioneye with 8 cameras, 2 of which do motion detection. The processor is running about 75%.

If it will be exclusive for HA, I wouldn’t bother with proxmox (as it is a virtualization platform allowing you to run multiple machines).
I would go for :

1 Like

Tons of useful stuff here:-


How did you guys get to install on HP T630 thinclient. I can install nothing on it because I cannot disable secure boot in BIOS. It always resets to activated after saving and leaving the BIOS. So booting from USB is not possible.
I also tried giving a BIOS password as some people advised for disabling secure boot. BIOS always says “loading standard settings” during boot. But password is remembered, also BIOS is in German which I don’t think is standard.

take out the hdd and use balena-etcher to image the drive from another machine?

ps, using vmware here

1 Like

I didn’t have any issues changing the bios in my t630.

Using the process, everything went great… up to step 8 (loaded the HA image, no errors). When going into bios I made sure the hard drive was first on the boot order. After rebooting I get a GNU GRUB black screen popup with grub> line.

I double checked the boot order and it looks fine. I am at a loss right now, thoughts???

Is the BIOS in UEFI boot mode?

Grub is a bootloader, so it’s possible that the boot process didn’t complete properly. In the BIOS, was the boot drive set to UEFI mode?

This is were my knowledge bottoms out. When I go to the BIOS settings and under Storage->Boot Order I get the following

I’m a little confused at the UEFI drive entries. The first in the list says ‘ubuntu’. It may be worth a quick recap, just for (my) clarity:-
Did you decide to go the HAOS (generic x86) route? This would mean the whole drive/device is dedicated to HA.
If so, did you remove the drive and use something like Etcher to burn the image you downloaded onto the drive?
If not, which route did you go?

I did decide to go the HAOS, dedicating the device to HA.
Using the link above (Generic x86-64 - Home Assistant) and method 2, Create a “live operating system” on a USB device running e.g. Ubuntu, I booted Ubuntu via usb drive. From there I ran Balena-Etcher to flash the onboard drive.

Slightly different than me, then. I took the drive out of my Wyse thin client and plugged it into my PC via a SATA to USB adapter to burn the image directly onto the hdd. (that’s not entirely correct - I replaced the onboard 32GB ssd with a larger one). Having said that, the process should be much the same.
Have you tried choosing the “Legacy” option from the bottom menu? I’ve read other threads that suggest this might help. Don’t know personally, but it’s worth a try,?

1 Like

Looks like it was user error. I was writing the wrong file to the wrong location.

I apologize for wasting the group’s time.

1 Like

Not a problem from my end. Glad you got it sorted. Sometimes it’s enough to talk things through with someone which shows us where we’ve gone wrong. Done it loads of times myself :wink: