HA OS on unRaid!

I tryed also to start from scratch again downloading new image. I noticed when i try to resize this with qemu-img resize nothing really happens.

There’s any alternative command?

Did you start the VM and check it? You probably have over 32GB allocated now, as they are 32GB by default.

If you hover over the “used space” bar on the host card at the supervisor > system page you’ll see total space.

image

1 Like

Yes now image is a bit larger than before!

I upgraded to 6.9 and largely had no problems. I previously had passed a USB card to my HASSOS VM, I think this helps to prevent a lot of issues as the VM doesn’t have to “fight” anything for control of the USB.

1 Like

Still have performance issue with my VM in 6.9.1. Can someone please share settings of the VM just to double check?

I have HA installed in a VM and it’s now in a weird state, no idea what happened. It’s been running for months without issue. When I realized none of my automations were running today, including my HVAC temp schedules, I discovered the VM was turned off (i didn’t stop it) and when i restarted, I’m on this screen:

Quick google search yieled some reports of same issue due to bad update and related to boot order: System update fail

However, typing exit and getting into the “Boot order” menu, shows my HD in the top slot so I don’t think this the issue:

@tmchow
I have been encountering this issue either randomly or when I moved a vdisk for some time. This problem is usually not just related to hass on unraid but all vms. .

So far the only reliable fix for it that I have found is to create a new vm in the GUI with the same specs and add the existing hass vdisk to it.
This is fine for my hass vm but impacts my windows vm licenses.

I have also had some success with backup and restoring of the nvram but not enough to provide a reliable guide.

Which method did you use for your VM did you create a Linux VM and then run HASSOS on top of it?, if you went with the QCOW2 route when I get home from work I will post settings that have been rock solid for me since I created it close to a year ago

1 Like

Yes I created a Linux vm using qcow2 for the image.

It WAS stable for me as well till the update to 6.9.1.

Yes please if you can share with me your setting I will double check mine.

Thank you

@tmchow

Yes, I’ve come across this as well once or twice. As @tinglis1 describes, creating a new VM and using the previously used vdisk worked for me in that situation. Also not limited to Linux VMs in my case.

That config looks almost identical to mine.

Anyone know the difference between the network model choices of virtio vs virtio-net?

My vdisk bus is set to SATA vs VirtIO.

mine was too (followed the original post from @cogneato).

I will try to switch Primary vDisk Bus to VirtIO ad Network Model virtio-net to see if performance are better.

Finger crossed.

In the meantime THANK YOU @mrbilky!

Hi,

Im using the Frigate docker that saves the images to a unassigned drive called Spare

And I want my VM Home Assistant to have access to that drive

I tried this but the VM config just hangs on updating

image

Any suggestions please?

im guessing I will then need this in configuration.yaml to map the new media share (if someone could please confirm?)
image

Im wanting to do 24/7 recording and would prefer to use a spare unassigned hardrive compared to a SSD or having to spin up the array

I am using HA in a Vm and frigate as a docker and have a similar problem to you and was going to try figure it out in the coming weeks.

I was going to try mounting a share in HA using something like the following post.
Link

I see you are using an unassigned device. This could create issues with having it available as a share. In my case I have my device mounted as a btrfs pool with only that share saving to the pool.

I might try the Linux host/guest folder option as well now that you have planted that idea.

On a side note I just installed a m2 (a+e) coral tpu in my dell 7060 sff wifi slot and it works perfectly. I also tested it with success in a dell 9020m.

1 Like

To mount a folder under a linux guest you need to use the following config section.

I have never used this feature myself.

@NewToThis This thread has tried folder pass through before without success. I also tried and failed and stumbled on that post while trying to find a solution.

Link to post.

Best bet would be to try mounting a network share using a script.

You could always try get the 9p driver merged into the HA build but that it a real edge use case.

Thanks for the replies :slight_smile: being honest a lot of what’s being said and described is way over my knowledge level (at the moment)

I may have got round my issue anyway… I am wanting to store a week of Frigate data so I have set it up as a Docker with access to my unassigned drive

With the integration and adding this to configuration.yaml (yes i need to sort the icon out)

  frigate:
    title: Frigate
    url: http://192.168.1.(ip of my docker container):5000
    icon: mdi:lightbulb-on

it works fine in HA
Only thing not working is being able to see these files in Media Browser… Which with the Frigate integration I don’t think I need.

Only thing left to get working is to send a ios notify message including the image, I’m hoping that does not need the Media Browser!