HA Supervised - How to move from UNSUPPORTED to SUPPORTED

Hopefully the below long journey on how to resolve my all of my “Unsupported” issues for HAS will be useful to others. I fixed them all and was left with one final issue that was the OS being wrong - so I have HAD put the current and final question on top of the long story below - but read through my additional editswhere I had to undo some of the changes for the sake of stability. Sheesh.

Currently I have I had an RPI 4b 8GB running the standard RPI Raspbian 32 bit OS that came with it but booting off a 1 TB SSD rather than a MIcro SD Card which makes a HUGE difference in speed. I’ve installed on the host some software (weewx) which is a wonderful elegantly written program that collects weather data from my weather station, hosts a website showing same with graphs, also storing that data in a DB and also transmits the data to NOAA and various weather websites all over the world. Along the way I taught myself linux and python so as you can imaging is was a struggle (I was a programmer for many years on wall street (windows, not linux) - now do something else for a living - so I did have the aptitude - just alot to learn).

It is very efficient and uses so little CPU, and as a gadget freak/glutton for punishment I decided to also use the same RPI for Home Assistant, hence it has to be “Supervised” running in docker.

I got HA Supervised up and running about 9 months ago but it was a struggle with many different versions tried until on the 4th try it was finally up and running - hence my issues below. I have full backups of the entire SSD - and also backups of just the HA. But no other kinds of backups. (For example - I would now know how to restore just the weewx, on a new OS, etc…)

Under settings/repairs the “System Information” has “you are running an unsupported installation” and when I click more I get the popup: “Below is a list of issues found with your installation, click on the links to learn how you can resolve the issues.”

apparmor (RSOLVED)
systemd_resolved (RESOLVED)
cgroup_version (RESOLVED)
connectivity_check (RESOLVED)

The description under each link given above is somewhat vague - just shows the requirements - does not explain what the issue is with each in my case, but I did a GREP through my syslog for anything with “unsupported” I get a better explanation of each issue. But - guys - don’t even bother going down that rabbit hole that will lead you to China with few improvements! Do what I finally did and bite the bullet, here is how I fixed everything with a :joy::joy::joy: 20 degree cooler :joy::joy::joy: running :joy::joy::joy: lower cpu % rate :joy::joy::joy: and 64 bit instead of 32 bit :joy::joy::joy: - in that post 29 below has exact step by step instructions on how to do it for noobs. These are my end results - a squeaky clean puppy that runs with a much lower cpu and 20 degrees lower temperatures - totally supported:

System Information

version core-2022.11.1
installation_type Home Assistant Supervised
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.10.7
os_name Linux
os_version 5.10.0-19-arm64
arch aarch64
timezone America/New_York
config_dir /config

Home Assistant Community Store

GitHub API ok
GitHub Content ok
GitHub Web ok
GitHub API Calls Remaining 4423
Installed Version 1.28.3
Stage running
Available Repositories 1200
Downloaded Repositories 22


can_reach_server ok
remaining_requests 41

Home Assistant Cloud

logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok

Home Assistant Supervisor

host_os Debian GNU/Linux 11 (bullseye)
update_channel stable
supervisor_version supervisor-2022.11.dev0401
agent_version 1.4.1
docker_version 20.10.21
disk_total 917.0 GB
disk_used 10.4 GB
healthy true
supported true :joy:
supervisor_api ok
version_api ok
installed_addons Log Viewer (0.14.0), Samba share (10.0.0), Home Assistant Google Drive Backup (0.108.4), File editor (5.4.1), Duck DNS (1.15.0), AdGuard Home (4.7.4), Terminal & SSH (9.6.1), Core DNS Override (0.1.1), Mosquitto broker (6.1.3), AppDaemon (0.9.3)


dashboards 4
resources 15
views 25
mode storage


oldest_recorder_run October 4, 2022 at 2:29 PM
current_recorder_run November 4, 2022 at 11:33 PM
estimated_db_size 1443.68 MiB
database_engine sqlite
database_version 3.38.5
1 Like

Until it was toned down, Supervised came with a warning:

This method is considered advanced and should only be used if one is an expert in managing a Linux operating system, Docker and networking.

The requirements also say:

This installation method can easily be broken if one manages the operating system incorrectly. Therefore, the following additional conditions apply:

  • No additional software, outside of the Home Assistant ecosystem, is installed.

It’s also going to help us help you if you use code markup, as explained in the sticky post, for the blocks of log/code.

Personally I’d recommend you take the backup and restore it to another computer (or a VM) running Home Assistant OS.

Ok then 1. what about the host processes I described that I am also running?, and 2. Why does HA Supervisor even exist if no other software is allowed to be on the host system?

  1. The point of it is to allow you to get the HAOS experience on hardware that can’t run HAOS itself, since initially HAOS had very limited hardware support. Things have changed a lot since then, HAOS supports a lot more hardware, so hopefully the future of Supervised is limited.

I can’t help with (1), but hopefully somebody who runs Supervised will be able to help you.

1 Like

My last few post in that thread cover some of the cgroup and connectivity things.

1 Like

At first I was going to give you a ‘heart’ for responding to help out, but then I reread your statement “hopefully the future of Supervised is limited”… NOOOOOOOOOOOOOO!!!

I also say that because I have fans along with some wires soldered together with a resistor and a transistor and plugged into some of the IO pins and wrote an app to monitor the temperature and turn the fans on if the RPI goes above 65 degrees C and the back off again when it falls below 55 degrees C. It writes to the syslog and I have the syslog sitting in the shared directory so that HA supervised in the container can see syslog so I’ve got a bunch of command line sensors monitoring various syslog entries - before you get rid of the supervised you’d have to support any and all such hardware and configurations within HAOS (so it would have to be able to support everything)…

(I’ll give you a “like” anyway :slight_smile: )

1 Like

The trouble is, setups like yours are in breach of the requirements, which can (and have) result in issues with the whole environment not working correctly.

I understand why people do this, I worked in tech support for years and know too well that people view requirements as vague suggestions, but if you’re at that point you’re better off simply switching to a Container install using Docker (or Podman).

You’ll never fix the os issue. Only supported OS for supervised is debian, no derivations of debian (e.g. what you’re running).

As for cgroup_version, there’s a fix in the documentation

This highlights how to do the change

1 Like

@petro - As noob to python and linux but with alot of patience, time and (what I think is a somewhat) good aptitude, how do I migrate RPI that has two host processes running as well as a few cron jobs, and also HAS, from “Raspbian GNU/Linux 11 (bullseye)” to “Debian 11 (Bullseye)”?

I have a suggestion but not sure how to do it. Given that within HA I have full configuration backups so I can restore all of the HA settings with no issue (and have done so in the past) using the add-on “Home Assistant Google Drive Backup” - my question ultimately comes down to:

What backup system/software (preferably with a UI) can I use that will allow me to restore specific files and configurations on the host (just two processes and some cron jobs) after I have blown one OS away and installed the second OS from scratch?

I just back up the configuration folder for HA to source control. I’m currently using GIT, but I did use mercurial for a while. Both have steep learning curves, but it’s really easy to move between versions once you learn the CLI. You can also use both of those backup systems with interfaces. For mercurial I used TortiouseHG. For Git I use GitKraken or VSCode. GitKraken doesn’t let you use private repos. Both VSCode and TortiousHG are “harder” to use than GitKraken.

Thank you but what about the last paragraph - the items on the host is my main concern - weewx is a VERY process involved with huge number of moving pieces and add-ons - (note the below link and then the images on the right side of that web page)


Sounds like a question for the Weewx support community. I googled “move weewx to another computer” and found this:


Hope it helps.

1 Like

Right, and it seems like there’s a containerized version of weewx here

1 Like

@123 Thank you!

@petro Thank you! Seems like I have alot to learn… So haos uses containers as well and I would have this (weewx) in one of them, managed by HA? So confused lol

I seem to have been able to fix the cgroup error by adding systemd.unified_cgroup_hierarchy=false to /boot/cmdline.txt on raspbian on a RPi CM4.

1 Like

If you see aboive I tried “=0” and it caused me all manner of issues, but the core issue is the wrong OS… I am doing some research tro see if weewx can run on Debian instead of Raspbian - and if it can, then I am going to bite the bulket and reinstall everything from scratch… UGH!

Since I am doing some research tro see if weewx can run on Debian instead of Raspbian - and if it can, then I am going to bite the bulket and reinstall everything from scratch…

  1. Can VNC be used on Debian (for headless use)?
  2. Can weewx run on debian?

Yes, have a look at TightVNC

Installing either of those is likely to lead to you still being Unsupported.