HA supervisor on debian aarch64

Hi there, I just followed the intructions on the official installation page for home assistant supervisor and having troubles.

I tried to install supervisor on my Debian aarch64 linux server. At the end of the installation I can see the homeassistant container not working.

I suspect that I made a mistake when I choose the architecture. I remeber there was a menu during the installation and I choose “genericx86-64…”. I think I should choose other one.

But how can I fix it now ? I tried to remove everything and retry to install but the screen where we choose the architecture didn’t show up again.

Is there anywhere in a configuration file where I can change the name of the image to pull or something ?

Thanks all !


There are a few environment variables that you have to add in order to make the Supervisor work properly with newer versions of the Supervisor. These variables have to be added to the run command for the Supervisor container, on most installations this is a script called from a service file.

  • SUPERVISOR_SHARE - The path to the directory for the Supervisor data files, typically /usr/share/hassio.
  • SUPERVISOR_NAME - The name of the supervisor container, typically hassio_supervisor
  • SUPERVISOR_MACHINE - The machine you are using. For a list of machine types, have a look here

Thanks @francisp ! Ok I think I might change the SUPERVISOR_MACHINE, how do I know what machine in the list to choose ? nothing look like “aarch64…” and how to I change the SUPERVISOR_MACHINE variable ?

ok I think i just have to change the machine here and reboot the machine ? it will automatically try to pull and run the right container ?

Yes, indeed

Erf, that’s not enough, i changed the config file, restart the machine, restart the supervisor container, but there is something else to do

qemux86-64 is still intel/amd

Thanks, I change it to qemuarm-64, and restart the machine

but it still pulling the generic container

and if you manually

docker pull homeassistant/aarch64-hassio-supervisor:latest

OMG, i just had to stop the supervisor container and removed the image. It did everything by itsefl and it seems to work now.

thanks @francisp