HA SwitchPlate - DIY LCD Touchscreen wall switch replacement


#792

@luma, you’re awesome, thanks!

I wasn’t sure how the labeling was setup on the Nextion, and wanted to double-check before I start soldering. I traced them out on your PCB (D5 & D7), but I’m not 100% sure as to which pins TX/RX on the Wemos for Serial1 in SoftwareSerial.

Plus, sometimes the labeling on these things aren’t consistent. The Sonoff B20s, for instance, the TX goes to TX on your programmer, which I figured out after I had quite a few tufts of hair on my desk. :slight_smile:

Oh, and much nicer pic… Thanks again!


#793

I’m running HassOS in Docker on my Synology NAS, is there a way of using the deploy script?


#794

Sadly I have no idea and no way to test - while I do have a Synology here it’s an annapurna-based unit that doesn’t support Docker. If anyone here has any insight as to how or if this would work I’d appreciate it.


#795

hi,

@luma saw the live stream of @DrZzs must say amazing job guys spreading this nice stuff out and around.
I have tried and tried again and keep failing with sketch up. I still want to make a snap on design with screws tightening at back of the plate i cannot get acquitted with sketch up tried and tried again and i am failing to import it into fusion 360 i am good with that , can you provide a fusion 360 compatible file to edit

thanks


#796

f360 can open SketchUp files directly, although it does so poorly and isn’t very editable. Anything else would require starting over from scratch which I’m not really prepared for as I don’t know f360. Others have suggested taking this up but keep in mind that my future work on this project is probably also going to take place in SketchUp. As a result, if you want to dive into re-creating things in f360 understand that you’ll need to keep it updated as I make changes to the model in Sketchup in the future.


#797

I have HA in a docker container. I have not run the setup script yet as I am still running a very old version of this project (pre-v0.20), but I plan to upgrade things this weekend and start fresh.

@luma did write up how to do a manual install of things which is basically what the deployhasp.sh script does. You can find it in the documentation here.

That being said, it shouldn’t be hard to do. If you put the script in the root of your config directory (/config), you can open a bash terminal into the container and execute the script that way. Depending on how you have networking to the container setup it may or may not work and you may run into issues since docker HA is different from HASSIO. Again, I haven’t tested it, but in theory it should work.


#798

I’ve been hacking away at the documentation, providing better explanations of the provided Nextion HMI along with a walkthrough of MQTT message patterns and Home Assistant automation workflows.

I’d recommend reading through the updated MQTT section if you have a minute, it should help provide some context around how things work with HASP.


#799

luma, won’t ship an assembled unit to Canada?


#800

For the moment no, just because my current shipping software doesn’t provide the option and every international shipment would mean a bunch of paperwork and a trip to the post office. At some point here I’ll need to upgrade to a paid shipping service but I need to be selling at a volume that would support the increased monthly cost. This may change in the future but for the moment it will be domestic shipping only.


#801

A new “minimum clearance” rear enclosure model has been published. This model is a stripped-down rear enclosure that is just big enough to fit the HASP components. The walls are thin and flimsy and the model will require supports to print. I don’t recommend using it unless your work box just won’t fit the standard model.


#802

I just added a new plate, but the menu option at the top in the HA web interface doesn’t appear while using Lovelace. The menu option is there using the default ui though. I just wanted to bring it up since lovelace will be the default ui soon


#803

Hi,@luma

thank you, first of all i am amazed by how quick you keep on responding kudos on that buddy. also i learnt how to edit STL i figured people keep on doing this for thingiverse so i got it to working testing some prints currently with diffrent clip-on & dimensions for Indian size modular boxes . w

will post results and share files you can take it from there as you are better in this,

Also is there any luck with dimming screen at night and then wake it up on touch .

Thankyou again for this amazing device :raised_hands: :raised_hands:


#804

Can you explain a bit more about what you’re seeing? I just ran through the deployhasp.sh process on 0.84.6 a couple times and switched to lovelace mode and the panel tabs all appear as expected.


#805

This might be a little difficult to troubleshoot I think.

default view:

lovelace view:

I’ve only just started down the lovelace path recently, and I think I selected an option to migrate my existing groups to lovelace (or something along those lines). I’m not using ui-lovelace.yaml, I’m using the webui editor for my frontend. I believe this stores the configuration in config/.storage as a json object in the lovelace file, but I could be wrong (and I probably am)

On a side note, I really need to setup a second instance for testing (I even use docker, it should be fairly easy)


#806

Question for the audience here - is anyone using a HASP in their environment, and also using a Belkin Wemo device?


#807

to be more detailed who is running HASP with HA and wemo and using discovery to find the wemo switches


#808

I have a couple of Belkin Wemo switches, and obviously have some HASP devices as well (including test units).

I’m happy to help. What are you looking for?


#809

are you using the wemo switches with discovery in ha enabled?
we are trying to figure out why having wemo autodiscovered and hasp running freaks out the wemo switches and somewhat locks em up requiring a physical reboot of the switches

what we found out so far is with discovery enabled and hasp running the wemo lock up and they work fine when discovery is disabled and the wemo switches are defined in the configuration.yaml

its a frickin mystery


#810

Well, I’ve certainly noticed the same issue. I had to power cycle one of my wemo’s recently. Both have been running for nearly two years without issues and I was just assuming I had a power issue that put the switch in a weird state.


#811

nope i spend the last 2 days trying to figure out what can possibly cause the wemo’s to go unresponsive
when this happens it also screws with the wemo app
but there is no connection with the wemo and mqtt so i’m quiet stumped