HA with Supervisor and Pihole in the same Raspberry Pi

First off, rest assure I have googled this request and look all over but I may either not full understand how to implement the solutions or couldn’t find the exact use case I’m looking for.

I’m currently running PiHole in a Raspberry Pi4 seamlessly. I’m Using Pi OS with the desktop. Everything works seamless.

I’d like to add Home Assistant to the same Pi, which I was able to do by installing docker and then pulling HA from hub.docker.com following instructions.
The thing is, (and I learned about this limitation) there is no Supervisor in this version of Home Assistant and not possible to include “out-of-the-box”

I’m not very savvy with Linux, Docker, etc and I’ve been looking all over but still couldn’t find a way to have the Supervisor tab in the left of HA while also having running Pihole in the same hardware.
Everything works when each application is stand alone (I tested both in a VM using Hyper-X) but I cannot combine both applications in the same Raspberry PI

Once again, many of the solutions I’ve seen don’t show the specific use case I’m describing here.

Thank you in advance and I appreciate your patience with this noob!

1 Like

Install Home Assistant, previously known as “Hass.io”. Then install piHole from the addon store.

I assume you meant I could install Pihole right after Step 1 and before Step 2?

Otherwise,this is just the regular installation of HA which of course , it works, but not resolving my issue. Remember, I want HA and PIHOLE in the same RaspberryPi.

Please, advise.

May be I’m mistaken, but my understanding is, the PiHole addon from the store is to allow the “integration” between HA and Pihole *check stats, etc); but it’s not the Pihole application. Am I right?

I tried to install Pihole after deploying Hass.io (with Supervisor) in the Raspbery Pi but I got an error messaging saying that the OS wasn’t compatible. I don’t recall the exact error message but the PiHole installation started and halted with the error message. Actually, this process was the very first one I tried but assumed the OS was even more basic than what the minimum required by PiHole. (again, I’m not savvy in Linux environments so may be I’m missing something)

Thanks in advance.

1 Like

Nope. It’s the application. But i notice now that it’s deprecated.

Install Raspberry Pi OS. (Best the lite version)
Install Pihole
Install HA Supervised (see link from tom_l )

That’s all. Works. Had it like that a long time.

1 Like

What @tom_l linked you too will give you exactly what you asked for. Remove the current install of HA you pulled from Docker, and follow the guide.

To all folks who replied my question. Thank you very much for your help. I still need to try this out (having a full-time job makes it difficult :slight_smile: )

Thank you @tom_l @oriolism and all. I promise to report back as soon as I follow your instructions!

I am extremely thankful for all your help! I successfully got what I was asking for.