HA won't let me access 192.168.(local):8123

I’m trying to get ha running on my old 2014 Mac mini and an running an Ubuntu VM for Haas. I’m using a few solutions, and a few VM softwares, but I always get the same “192.168.(local):8123 refused to connect” error. I’ve disabled the firewall, but the same thing happens.

Is your VM running in bridged mode so it gets its own ip address on your network?
Many VMs default to a mode where it gets NATed through its host. That will not work for a web server.

Are you trying to access HA from the Mac mini or some other host on the network?

It is running bridged and I’ve tried accessing it from the physical Mac mini and my phone, but still the same error.

I assume where you have .local is the rest of the ip address.
what do HA logs say?
What firewall did you disable? VM, host, or both?

On Ubuntu i ran curl -sL goo.gl/goR2HT | bash -

it gives a success message and everything was compiling fine, so I’m putting it down to a network issue. I disabled the host mac’s firewall, but il try disabling the ubuntu one as well.