HACs.. Some intergrations wont install others wont update!

Restarting is a given and doesn’t make things work.

Pm both a proxmox vm and a fresh install on a pie the results are the same.

install hacs reboot and then add to integrations.

Install a intergration and one of two things happen.

Incase of alexa media player it shows up requesting a restart but after a restart it’s missing from intergrations.

For other intergrations it does not show up after install in hacs and even a restart makes no difference.

Checking custom components shows that it appears to have installed but it doesn’t appear as installed in hacs and either doesn’t show in intergrations or does and doesn’t work.

What does your HACS logs say when you install the integrations?
It could be a SDcard failure, if you run on that.

What? !!

Proxmox is a virtual machine software that runs on a pc or server hardware and in this case it server hardware.
Your not going to be finding a SD card anywhere near either of these types of systems.

it was also tested on a fresh install on a pie 4 with a ssd to rule out software or hardware issues with the server.

There is no SD card involved with either of them.

There are no errors showing in the logs regarding hacs after a install

Sorry, missed that info in my thought process… :slight_smile:

Happens to the best of us .

Given that this is happening with a fresh install on two very different setups i suspect its a issue with home assistant or hacs.

I can restore a backup and then update alexa media player in hacs which works.
But if i try and install alexa media player in a fresh install it appears to work and requests a restart but fails to show in intergrations after a restart…

I am too blind these days to poor through things to find out if its a hacs issue or a home assistant one

make sure HACS is up and running. The status is operations and not updating to GITHUB. This usually happen when we run HACS for the first time where it trying to get as much plugins as it could and the limitations get hit.

Its not a time related issue.

One hour or a week later same result.

Also facing this issue in Home Assistant OS on a vm on Ubuntu host, while manually migrating from a Home Assistant Core in docker setup. I’m trying to use the spotcast and govee custom components, which work in my previous setup. I’m having a similar experience where the components don’t show up on the HACS page even after restart, though the components are downloaded. The govee integration does show up but gives the same “…does not support configuration via the UI…” error. My log shows Error occurred loading configuration flow for integration govee: No module named 'custom_components.govee.config_flow'.
I’m thinking perhaps it’s a compatability issue with the latest version of HA.

From what i can see we aren’t the only ones.

Some intergrations like open media vault work fine and others like wyze, govee or euffy don’t work correctly as mentioned.

Seems to be a issue between the latest versions of HA and Hacs.

All HACS componen is part of the unofficial HA, so any problem that occurs should be addressed to each developers. In my case all my HACS is working great on the current HA.

Turns out there with issues with github on the server end causing delayed responses which is apparently mostly fixed.

Fingers crossed

that is my 1st suggestion which happen to me alot of time. Github limitations which in my case usually I will create a new account just to avoid this issue. So I can switch account during the restore procedure. Anyway it will be fixed for sure.

@Magnus33 you can always install those community integrations by hand. In Most cases the instructions are on the repo. At least if you approach it that way you can Isolate the integration from HACS. If it is HACS, you can un-install HACS, reboot, and re run the install script from https://HACS.xyz. I have solved a few syncing issue that way.

It’s working for me now, I guess the issue was solved.

1 Like

So it it turns out i clot very easily and have TIA mini stokes, What i should normally grasp easily i suddenly start missing.
Looking on it after the fact is very startling and i do apologize .

Its shocking looking back and seeing what typed and realizing it makes little sense…

My apologizes if it seemed a little crazy or i got offensive…

it like looking back at a different person running the show at these times.

Hi. I’m experiencing something very odd. I can update HACs interations, after which I can read a warning information asking to restart the system. After restarting, nothing is up to date.
I’m runnng HA on a PI4 as a standard installation.
Thanks and regards.

Have you checked your log file for errors?

I did now clean the log in order to have a better look and found this 2 errors:

Este error se originó a partir de una integración personalizada.

Logger: custom_components.hacs
Source: custom_components/hacs/helpers/methods/installation.py:96
Integration: HACS (documentation, issues)
First occurred: 08:54:50 (15 occurrences)
Last logged: 08:54:50

Download was not completed [timeout() got an unexpected keyword argument 'loop']

Logger: backoff
Source: /usr/local/lib/python3.10/site-packages/backoff/_common.py:119
First occurred: 08:54:39 (15 occurrences)
Last logged: 08:54:50

Giving up async_download_file(...) after 5 tries (TypeError: timeout() got an unexpected keyword argument 'loop')

Seems that the download never worked, but somehow it shows that it is done and a reboot is pending. I never thought there would be an error in the log. Any ideas of why this is happening?

Having an idea of the problem, I managed to solve it. Just needed to update HACs with the command shell running the following command:
‘wget -O - https://get.hacs.xyz | bash -’
Sorry for the newbee question.
Best regards.

Happens to us all

Glad it was resolved