HAOS install on Nano Pi R2S/R4S/R5C with separated networks?

The supported images are here

The generic aarch64 may work.

1 Like

Many thanks, I corrected the title.

So next step would be to load haos_generic-aarch64-9.5.img.xz to my eMMC and see what happens?

Feedback from FriendlyElec: They haven’t run HAOS on R5C and there is a lot of work expected to make it work on R5C.

Another option would be that I see some nanopi run debian bullseye, which may leave you able to run a supervised install.

1 Like

Good idea - so first flash Bullseye to the eMMC like this NanoPi R5S - FriendlyELEC WiKi and then install this GitHub - home-assistant/supervised-installer: Installer for a generic Linux system like this Install Home Assistant (Supervised) on Debian - Matheson Steplock or is there a better guide to install HA supervised?

The supervised install instructions are here Linux - Home Assistant

There is a good guide here. Installing Home Assistant Supervised on Debian 11

Having said all this, have you spent money on the nanopi yet? You may be better on a x86-64 machine with 2 nics.


I got the Nano Pi R5C working with HA Supervised / Supervisor.
It didn’t work with the Bullseye Image from FriendlyElec.

With the Bullseye image from DietPi,
the installation went through without any problems and now it works.

This is very interesting - you did Supervised, not Core? Which install manual did you follow?

I used this guide GitHub - home-assistant/supervised-installer: Installer for a generic Linux system
In detail I used these commands:

HA Supervised for NanoPi R5C (aarch64 cpu):
apt-get install \
apparmor \
jq \
wget \
curl \
udisks2 \
libglib2.0-bin \
network-manager \
dbus \
lsb-release \
systemd-journal-remote -y

#Step 2:
curl -fsSL get.docker.com | sh

cd /home

#Step 4:
sudo wget https://github.com/home-assistant/os-agent/releases/download/1.5.1/os-agent_1.5.1_linux_aarch64.deb

#Step 5:
sudo dpkg -i os-agent_1.5.1_linux_aarch64.deb

#Step 6:
wget https://github.com/home-assistant/supervised-installer/releases/latest/download/homeassistant-supervised.deb

#Step 7:
dpkg -i homeassistant-supervised.deb

#In Step 7 select odroid-n2

With this Steps it works for me Supervised Intallation on NanoPi R5C.

1 Like

OK - do you get those errors?

If no, did you start the installation from the latest DietPi release that got some optimizations for NanoPi?

If yes, what do you do with those errors? Just ignore?

Both of those errors have links which give you more info.

Both links I have checked and spent many hours on trying to fix them. Unfortunately without success.

Those two errors originate from the combination of hardware and OS. As drdigital has same hardware and OS it would be really interesting if he is facing the same errors and/or how he is dealing with them. At least when I followed the instructions I was not successful.

yes i have the same error.
So far I haven’t noticed any limitations in functionality.
That’s why I just hidden the errors and didn’t pay any further attention to them.

1 Like

More options to consider (I don’t trust the provided images from the google drive download):

I am still figuring out how to install them to the eMMC

The easy “push to MMC” option is the main reason I went with one of the Images provided by FriendlyElec. Warning: If you plan to use Docker which does its own Overlay Filesystem, do NOT use an USB-to-MMC-Image but DO use an SD-to-MMC image, connect the mouse when booting from ist, do IMMEDIATELY cancel the install, go to the menu and set the checkbox “Disable OverlayFS”. Then install.

DietPi to the MMC seems like an extremely interesting option, also because HA core is provided as drop-down-option by the OS. If you made any progress with installing DietPi to the MMC, please notify.

While I had some drawbacks in installing HA to the R5S, some anger and tears were starting to trigger a buyer’s remorse - but I still consider the R5S as the ideal hardware for my HA and networking needs.

I installed DietPi into the emmc memory using FriendlyWRT.
Boot FriendlyWRT from MicroSD and then use the web interface to install the DietPi image in the emmc memory.
See Option 1: Install OS on Web Page

1 Like

Wow, great! Good to know this is possible!

I first tried to move the dietPi installation from sd card to emmc via dd commands from a dietPi blog or forum post. This ended in a non booting device for me.

The quickest way seems to be via FriedlyWRT. Either by using the pre installed OS or boot from the sdcard. For this to succeed, you don’t have to put the nanoPi into your own LAN nor does it need internet access.


  • download friendlyWRT (sd version, not eflasher version)
  • download dietPi
  • flash friendlyWRT to sdcard.

flash nanoPi:

  • boot from sdcard. It will boot with static ip see: 5.4 Login FriendlyWrt
  • connect to PC via crossover ethernet cable or via regular switch
  • put PC with dietPi image to the 192.168.2.x network.
  • open web gui on (default password is password)
  • Then you can flash the image to eMMC via “System” ->”eMMC Tools”
  • (select and upload dietPi image, let it flash, remove sdcard, wait for auto reboot, boots dietPi)
    adapted from Option 1: Install OS on Web Page section

What machine type did you choose during install?

I managed to install homeassistant supervised on top of Debian bookworm on a FriendlyElec’s R5C on eMMC. I used an image from inidev. The installation was’nt straight and I had to find a lot of special solutions. At the end homeassistant only complained the expected cgroup version was not satisfied. Currently it seems no problem but I do not know why it must be cgroupv1.
During installation I was asked for the machine type. I used qemuarm-64. drdigital, what machine type did you choose with DietPi?