HAOS installation on old x64 laptop

Greetings everyone and thanks to all of you for the amazing community you have created.

I have been experimenting with HA for quite a while, and I’m amazed by the unlimited possibilities for home automations and much more.
Initially, I have used a workaround to run HA on my Windows PC, without a VM. That worked good enough for a while, mainly for experimentation and tinkering, and loved that I could edit my .yaml’s with just Notepad++ and save changes instantly.
However, sooner rather than later, I stumbled upon Add-Ons, which seemed really usefull and couldn’t be run with the method I was using to run HA, so I switched to a VirtualBox VM.
A bit more hassle to edit yaml’s, but loved the ability to use the Add-Ons.

The main problem, however, is that I need to keep my PC running 24/7, which is not optimal, and the fact that I cant properly set the VM to start when my PC boots.

Since running HAOS on a VM on my PC is not the best solution, I didn’t even bother with the shitload of workarounds needed to disable required login on startup, disable UAC and force the VM to start as admin when windows starts. Too much hassle for nothing, imo.

So, I thought that I could use an old garbage clevo (OEM rebranded) laptop that I had laying around, that wasn’t used by anyone.
This machine has Intel i5 2nd gen and 4G of RAM, which I think is plenty of juice to decently run HA, and paired with a 60G sata SSD, i think it would have no problem handling it.
However, this machine doesn’t support UEFI boot.
I tinkered a lot with different ways of creating the boot disk. Tried with Balena etcher on my main pc, tried to etch it on the same machine booting with a hirens boot cd, but no luck.

Before trying all those, however, I first tried to run it on a VM in a windows instance on the laptop. The problem there was that it doesn’t support virtualization. I downloaded an older version of virtualbox (6.0.x) that can run VM’s purely on software virtualization, but since I was attempting to migrate an already existing VM, that was created in x64 architecture, I couldn’t make it to run, given that software virtualization only supported x86 (and probably due to other issues that I didn’t proceeded far enough to encounter)

So, at this point, what are my options?
Is there a way to run HAOS natively on a machine that doesn’t support UEFI boot? if yes, how is that possible?

Or, if not, should I use docker to run HA in a linux instance in the laptop? I get that I cant have addons, going with this option, but if it’s my only option, I suppose I can live with it.

I’m probably not tech-savvy enough and had no previous experience with docker, so any detailed guide, if it comes to that, would be highly appreciated.

Thanks for your time and keep up the good work of helping each other

This post might be of help:

I do not believe so.

PS. I was in a similar situation, I was running HAOS (before the UEFI requirement) on an old Zotac net-top with a pre UEFI bios. I forced me to look for other options as well. I got lucky I think, I found a used NUC NUC5PPYH for < 70 usd. on Ebay minus memory and ssd, got both for about 50 usd.

And it’s been smooth sailing since :slight_smile:

Thanks for your reply. I ended up following the post you mentioned, and some video tutorials ofc, and installed debian and HA Supervised on my laptop. Works flawlessly so far, after some hours of headscratching and troubleshooting on how to stop my laptop from going to sleep when I close the lid, or when a fixed amount of time passes.
At the end, I uploaded my HA backup and got picked right up wihtout any issues.

1 Like

Any one can help me.
When I start the laptop with new a new hasso image installed I get this message. (Picture below)
I used Ubuntu on a usb stick to flash the HAOSS onto the formatted hard drive on the laptop.
Got no errors when installing HA.
When I restarted laptop I get this. The last line DHCP just has the spinning dash sign

You laptop is trying to boot from the network (most likely cannot find a bootable SSD/HDD). Disable network boot in BIOS and also try to boot using UEFI. Make certain your disk is the first boot device.

Don’t cross post. You already started a thread with this question.

Sorry. Meant to delete this one

I disabled the network boot.
Still no joy. It just boots to the boot screen option
I have no UEFI options in my bios settings?

I think it is safe to say HAOS will not run on the system you are trying to use. Either find another system which supports UEFI or use another installation method supervised/core.

1 Like