Home Assistant Community

Hass.io Add-On: letsdnsocloud - Custom Domain SSL & DDNS

hassio-addon
Tags: #<Tag:0x00007fcf4ccdec68>
#22

Following this. I’d love to be able to do the same.

#23

You would have to duplicate all of your current DNS records over to Cloudflare, switch your DNS over and then run the add-on. It’ll create a new separate A record for your subdomain.

Moving forward you would need to use Cloudflare for all of your DNS. Whether or not that suits your use case is up for you to decide.

#24

Hi do you maganed to get it working with that provider?

#25

Hi, sorry, I did not finish that. Can not say for sure

#26

Apologies in advance , but im bricking the whole setup with port forwarding.

So all I do is 443->443 with internal pi box IP
or do I need 8123->8123 also?

#27

443 -> 8123

That will map your default ssl port to your local install. When outside of your local network you won’t need to specify a port on the domain name. ie: https://yourdomain.com

1 Like
#28

I have everything set up, however when I go to the domain, it defaults to my router. I’ve tried everything port forwarding-wise, but nothing seems to make it point to hass. It only works if I specify the port in the domain url. Anything else hits the router regardless of http, https, random ports. Any ideas?

#29

Tough to troubleshoot without knowing what router and how you’ve set it up.

If you’ve set the port forwarding to any port but 443 then you’ll have to specify the port.

#30

I’m starting to think it could be something else. I had a bunch of error files get generated when I was running the addon, so I think something was conflicting.

I haven’t had issues with the router before, I liked the idea of using my own domain vs duckdns

I’ll mess around with it and let you know what I find.

#31

As someone who has tried to set up Letsencrypt and DuckDNS previously I can only say THANK YOU.

I know what I’ll be doing later tonight! :smiley:
Now to try and think of a catch domain with high WAF…

1 Like
#32

I cant see the addon… I added the repo but the addon didnt show up… I checked the system log and found this:

19-04-11 11:54:50 INFO (MainThread) [hassio.addons.git] Clone add-on https://github.com/PhrantiK/hassio-addons repository
19-04-11 11:54:54 WARNING (MainThread) [hassio.addons.data] Can’t read /data/addons/git/3983e8d8/letsdnsocloud/config.json: required key not provided @ data[‘arch’]. Got None

Please help.

#33

I fixed the warning but I don’t think that has anything to do with the addon showing up.

It’s right down the bottom of the page when you add the repo.

#34

It wasn’t there previously. All my other add-ons were visible. But whatever you just did seemed to work as I can see it now :slight_smile:

As per home assistant docs, if an add-on does not appear after the repo was added, check the system logs for an error and let the repo owner know… :slight_smile:

Thanks dude!

#35

Has anyone else lost local access to HASSIO after installing this add-on? I have no issues accessing remotely now (woo!), but I’m unable to access locally via IP or hostname. Does the add-on support adding multiple domains, including localhost?

#36

Try enabling multicast on your router, that should fix the problem. You’ll be able to access the installation with your external domain name on https locally as well as externally

#38

Thank you. This works great. I have it running with the Nginx Home Assistant SSL Proxy addon

#39

Works great for me, thanks a lot for your work!!!

A suggestion: will it be possible to activate “DNS and HTTP Proxy (CDN)” automatically?

#40

Going to be trying this out soon. Currently use non encrypted within my network and over ssl from the internet via traefik (and a wildcard ssl cert).

As i’m still running other services on my network over https via this traefik container (all running on a separate docker stack) it’ll be interesting to see how my phone will handle on and off network. will see how it goes!

#41

This is precisely what I need, but after following the guide to the letter, it still won’t work.

When I reach the step to start the addon, I click the button, refresh the page and see that it’s not running and there is no log output. I’ve been following the dmesg output and other stuff via ssh, but I can’t make any sense of it.

This is on a RPi 3B+ with 100% up-to-date hass.os installed 2 days ago. I’m only running configurator, ssh, esphome, and samba.

#42

Click start but don’t refresh the page. Just scroll down and hit refresh on the log. It takes 4-5 seconds to kick into action.