HASS.IO Appdaemon loading but not working

Hi, i’ve installed Appdaemon from HASSIO but cannot get the Hello World app to log anything. Please see details below;

Appdaemon config;

>   cert_verify: False
>   logfile: /config/hadaemon/info.log
>   errorfile: /config/hadaemon/error.log
>   threads: 10
>   app_dir: /config/hadaemon/apps
>   ha_url:
> HADashboard:
>   dash_url: http://cp.local.io
>   dash_dir: /config/hadaemon/dashboards

app.yaml and hello.py are as per the tutorial. Everything must be loading ok as I see the following in the info logs;

INFO AppDaemon Version 2.0.8 starting
INFO Configuration read from: /config/hadaemon/appdaemon.yaml
INFO Got initial state
INFO Loading Module: /config/hadaemon/apps/hello.py
INFO App initialization complete
INFO Starting dashboard
INFO Connected to Home Assistant 0.55.2

I’m struggling to identify where to look for the error (error log is empty) as it appears to be loading everything perfectly fine. Is there anything wrong in the config as that is all I can think off?

This hint from AppDaemon can't find my modules worked for me for 2.0.8: add the contents of apps.yaml to the end of your appdaemon.yaml and restart.

More recent versions of AppDaemon v2 will will split this the configuration back into two files.

1 Like

That’s brilliant, thanks. I had assumed because it was loading the module that it should be working but it obviously wasn’t loading the app itself.

It seems I’m having the same problem. I’ve verified i’m using the latest version of appdaemon via pip and my ‘app’ yaml is in apps.yaml. I have gone so far as reviewing the appapi.AppDaemon class to verify that the code is indeed looking to ‘apps.yaml’ for the app configurations. I’ve installed both HA and AppDaemon using pip in a virtualenv with homegrown systemd config files.

if you installed with pip its not the same problem, because this is about hassio which cant use pip :wink:

I find myself in the same situation, finally decide to try this and a very basic config is not working…

  logfile: STDOUT
  errorfile: STDERR
  threads: 10
  app_dir: /config/appdaemon/apps
  ha_key: xxxxxx
  dash_dir: /config/appdaemon/dashboards

# Apps
  module: hello
  class: HelloWorld

appdaemon log output

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 
 Hass.io Add-on: AppDaemon v0.4.0
 Python Apps and HADashboard for Home Assistant
 From: Community Hass.io Add-ons
 By: Franck Nijhof <[email protected]>
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 02-updates.sh: executing... 
INFO: You are running the latest version of this add-on
[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 03-version-requirements.sh: executing... 
INFO: Supervisor version requirements checks passed.
[cont-init.d] 03-version-requirements.sh: exited 0.
[cont-init.d] 20-init-configuration.sh: executing... 
[cont-init.d] 20-init-configuration.sh: exited 0.
[cont-init.d] 21-compiled-dir.sh: executing... 
[cont-init.d] 21-compiled-dir.sh: exited 0.
[cont-init.d] 50-compiled-symlink.sh: executing... 
[cont-init.d] 50-compiled-symlink.sh: exited 0.
[cont-init.d] 80-system-packages.sh: executing... 
[cont-init.d] 80-system-packages.sh: exited 0.
[cont-init.d] 81-python-packages.sh: executing... 
[cont-init.d] 81-python-packages.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
starting version 3.2.4
[services.d] done.
2018-01-18 19:50:49.780819 INFO AppDaemon Version 2.1.12 starting
2018-01-18 19:50:49.782178 INFO Configuration read from: /config/appdaemon/appdaemon.yaml
2018-01-18 19:50:49.840602 WARNING Unable to connect to Home Assistant, retrying in 5 seconds

My api password is correct and yes my ha_url is correct and working as entered. My local net is listed in hassio as a trusted network, so I have also tried it with a blank api password and also with “” as the password.

I have also tried sse and websockets.


can you reach HA in a browser with this url:

if you have set encryption in ha probably not.

Yes, sure can.

then i have no clue.
if you have no encryption installed inside home assistant and the url works with your password it should work.

Rene, I had to use my FQDN and port number to get this up and going.

FQDN?? sorry i dont know what you mean by that.

Fully Qualified Domain Name - XXX.YYYYYYY.org:8123

ah thanks. yeah you need a working link.

I was a little taken back that it would not attach to my internal ip and port. When home I can access the web UI for hassio by ip:port, FQDN:port or hassio.local:port. The only think that would work in the case of the appdaemon UI was FQDN:port.

Yes you can :wink:
You can actually list additional Python pip packages in the add-on configuration :wink:

can again then :wink:
some time ago i had problems when people tried to install packages that were needed for some apps.
at that point they couldnt use pip to install them.

but im glad to hear its possible.